Roku3 is displaying subtitles on files without FORCED subtitles. Preview Channel v 5.2.0

roku

#1

Plex is automatically displaying subtitles on files that aren't using forced or hard coded subtitles. I have to manually go into each file's settings and disable the subtitle before i start it. here is the mediainfo of the files that are doing this. I don't have this problem with any other player, OpenPHT, Plex Media Player, or the web app. Only Plex on Roku

General
Unique ID : 243162392375117091674974039386212398162 (0xB6EF5F8F6F95059D83F5AF068195F452)
Complete name : It's.Always.Sunny.in.Philadelphia.S04E01.Mac.and.Dennis.Manhunters.DVDRip.DD2.0.x264-NTb.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 489 MiB
Duration : 21 min 17 s
Overall bit rate : 3 212 kb/s
Encoded date : UTC 2013-08-20 15:53:53
Writing application : mkvmerge v6.3.0 ('You can't stop me!') built on Jun 28 2013 20:09:41
Writing library : libebml v1.3.0 + libmatroska v1.4.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings : CABAC / 13 Ref Frames
Format settings, CABAC : Yes
Format settings, RefFrames : 13 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 21 min 17 s
Bit rate : 2 956 kb/s
Width : 720 pixels
Height : 480 pixels
Display aspect ratio : 4:3
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.357
Stream size : 450 MiB (92%)
Writing library : x264 core 133 r2334 a3ac64b
Encoding settings : cabac=1 / ref=13 / deblock=1:-3:-2 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=1.10:0.10 / mixed_ref=1 / me_range=48 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=6,6 / fast_pskip=0 / chroma_qp_offset=-3 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=0 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=6 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.80 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.10 / aq=1:0.70
Language : English
Default : Yes
Forced : No

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Codec ID : A_AC3
Duration : 21 min 17 s
Bit rate mode : Constant
Bit rate : 192 kb/s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 13 ms
Stream size : 29.2 MiB (6%)
Service kind : Complete Main
Default : Yes
Forced : No

Text #1
ID : 3
Format : VobSub
Muxing mode : zlib
Codec ID : S_VOBSUB
Codec ID/Info : Picture based subtitle format used on DVDs
Language : English
Default : Yes
Forced : No

Text #2
ID : 4
Format : VobSub
Muxing mode : zlib
Codec ID : S_VOBSUB
Codec ID/Info : Picture based subtitle format used on DVDs
Language : Spanish
Default : No
Forced : No

Text #3
ID : 5
Format : VobSub
Muxing mode : zlib
Codec ID : S_VOBSUB
Codec ID/Info : Picture based subtitle format used on DVDs
Language : French
Default : No
Forced : No

Text #4
ID : 6
Format : VobSub
Muxing mode : zlib
Codec ID : S_VOBSUB
Codec ID/Info : Picture based subtitle format used on DVDs
Language : Portuguese
Default : No
Forced : No


#2

Just a guess, but from the info you provided, the audio track for that file does not have a language tag.

I think because of that, Plex and/or the Roku assume the subtitle is required because the audio track is probably labeled as “Unknown” when you view the information from a Plex app. Assuming your language settings are to show subtitles with foreign audio, this is probably the desired behaviour.

You can add the language tag to the audio track easily with MKVToolnix, or several other tools. Sometimes downloaded files have unwanted tags or missing tags that give weird results in Plex.


#3

To add to this.
Based on the filename you may have dozens of files like this one.

Quick batch file.

mkvpropedit.exe %1 -e track:v1 -s flag-default=1 -s language=und -e track:a1 -s flag-default=1 -s language=eng

Save it as SetAudio2Eng.cmd or something similar. Then, drag each mkv file onto the saved cmd script.

This will set the 1st video track(I assume only one track anyway) to undetermined and the 1st audio track to english. You could get fancy and make a for/loop to process all mkv’s in a given folder.


#4

thanks! really appreciate the help