Running Plex 1.10.1.4602 on Ubuntu Server 16.04 and Plex Server status is indirect

server-linux

#1

Hello All,

I am not sure if this is the right place to ask this question but here I go.

Here is how I came to where I am now. I had an OpenMediaVault machine that hosted plex. The Plex app stopped working because it was conflicting with the WebGUI Config panel of the OpenMediaVault. So I uninstalled Plex from that machine and it is no longer running on that box.

I then installed Plex Server 1.10.1.4602 on my Standalone (meaning the only plex is on this box and nothing else) Ubuntu 16.04 server.

Since I did this EVERY device shows the plex server is "indirect". While before the OMV Plex app died I had a direct connection.

I have not made any changes to my network from the uninstall from OVM to the install on the new Ubuntu box.

I then did some digging on forms and saw that DNSMasq needs to be disabled on my router. So I did that and rebooted the router. Still says indirect.

On the plex server, i disabled "Secure connections". It still says indirect.

I wish I knew what version was on my old OMV server as that I am sure that would help the troubleshooting but as per 1.10.1.4602 I keep getting "indirect"

Now to be clear I can get to the box via the Plex app on all of my devices but the quality is low.

Currently, my network looks like this

Router - 192.168.11.1 -> DHCP Server - 192.168.211.1 -> Media files are on - 192.168.211.115 -> and Plex is - 192.168.211.113 -> All devices 192.168.211.100-255

any direction would be helpful, thanks in advanced.


#2

If you’re running PMS on native Ubuntu, did you remember to open the firewall ports in ufw ?

If they are not open, you will always get indirect on your LAN and Relay for WAN.

Confirm please? Router: 192.168.211.1 ? I presume a typo

https://support.plex.tv/articles/201543147-what-network-ports-do-i-need-to-allow-through-my-firewall/


#3

@ChuckPA said:
If you’re running PMS on native Ubuntu, did you remember to open the firewall ports in ufw ?

If they are not open, you will always get indirect on your LAN and Relay for WAN.

Confirm please? Router: 192.168.211.1 ? I presume a typo

https://support.plex.tv/articles/201543147-what-network-ports-do-i-need-to-allow-through-my-firewall/

to confirm my router is 192.168.11.1 it has a DHCP redirect to my DHCP server 192.168.211.1

as far as adding to UFW i followed these steps.

I would assume that those settings are correct.


#4

If you’re using 192.168.211.x and 192.168.11.x , what is your subnet mask? You’ll get indirect if you go hopping across subnets because broadcast packets (PMS local player discovery) do not cross subnet boundaries.


#5

subnet mask is 255.255.255.0 for router and dhcp


#6

There’s your problem.

192.168.211.x and 192.168.11.x are distinct and independent subnets. The only thing they have in common is Plex.tv after going out the internet and coming back in (hence indirect).

Flatten the LAN (everything on one subnet). Your choices are:

  1. use the same subnet addressing (192.168.11.x or 192.168.211.x)
  2. change the subnet mask for everything to 255.255.0.0

#7

k, I will have to do it tonight after the kids go to bed. Because if I take the internet down now it would be the end of my life. LOL!

I will post back which of the two I use and the results thanks again.


#8

I think the loss of body parts would be more painful but totally understand LOL


#9

ok gave it a shot. I moved everybody to the 192.168.11.x network. SO now it is.
Router - 192.168.11.1 -> DHCP Server - 192.168.11.10 -> Media files are on - 192.168.11.115 -> and Plex is - 192.168.11.205 -> All devices 192.168.11.100-255

On all cabled devices Plex says “nearby”. But any wifi devices it says it is “indirect”.

I checked the ip’s of a wifi device and its ip is 192.168.11.152 with a subnetmask of 255.255.255.0.

This is strange because like i said before I didnt change anything else on the network so I am not sure why everything started acting up.

So I went to my “work log” to see I changed the MTU on my router 3 days before i did any work on the plex. I changed the MTU back to 1500 now all Wifi and wired devices worked.

Thanks again for your help. This was a odd one but I am glad you knew what to do!


#10

I am not sure what happened to my reply but last night I moved the entire network to 192.168.11.x.

so now it is

Router - 192.168.11.1 -> DHCP Server - 192.168.11.10 -> Media files are on - 192.168.11.115 -> and Plex is - 192.168.11.205 -> All devices 192.168.11.100-255

once i did that all of the wired devices showed the Plex server was local but wifi devices show it was still “indirect”

I then looked at my “work log” and saw that 3 days before i rebuilt my plex i did change the MTU of my wifi from 1500 to 1350. I logged into DD-wrt changed the MTU back to 1500 and now they all work just fine.

thanks again for everything!


#11

ok gave it a shot. I moved everybody to the 192.168.11.x network. SO now it is.
Router - 192.168.11.1 -> DHCP Server - 192.168.11.10 -> Media files are on - 192.168.11.115 -> and Plex is - 192.168.11.205 -> All devices 192.168.11.100-255

On all cabled devices Plex says “nearby”. But any wifi devices it says it is “indirect”.

I checked the ip’s of a wifi device and its ip is 192.168.11.152 with a subnetmask of 255.255.255.0.

This is strange because like i said before I didnt change anything else on the network so I am not sure why everything started acting up.

So I went to my “work log” to see I changed the MTU on my router 3 days before i did any work on the plex. I changed the MTU back to 1500 now all Wifi and wired devices worked.

Thanks again for your help. This was a odd one but I am glad you knew what to do!