Samsung Play Methods Request & Error's



Hi Orca,

First of all, I just want to say that I am incredibly impressed with the app that you have created all on your own. It was the reason I was able to get into Plex in the first place and I hope that the team at Plex recognize that and treat you accordingly!

Onto the first actual question, I'm aware how the play methods currently work, eg:

Auto - Check if can direct play, otherwise direct stream/transcode (doesn't look at remote quality setting)
Direct Play - Direct play
Direct Stream - Check quality setting and then stream / transcode as necessary
Transcode - transcode all to quality settings.

I've noticed that on the other official plex clients, while they don't have the play methods you have selected above, it all seems to hinge around the bitrate / quality setting requested. EG if quality setting is 8Mbps 1080p, anything under that will direct play if client is capable.

Is this something that could be integrated into your "Auto" play method? I find that this is too hard to explain to my end users watching from my plex server and as such, I just set it to direct stream by default.

EG, Auto - check quality setting > check if can direct play > play accordingly (transcode / direct play per client capabilities).

Also, they also appear to be affected by the 2.008 known bug with direct play from remote. It seems to transcode all the time.

Lastly, I often get the error "Unable to connect to the content server" whether it is on LAN or Remote (TV = UA60JU6400, same TV at both LAN and Remote). I have fiddled with the HTTPS side of things (eg, disabled secure connections on plex, no change, turned on "secure connections" in samsung client & preferred in plex settings to not gain either). LAN happens very infrequently, but does happen every now and then (generally only with TV shows). Last night I was attempting to watch a movie via direct play remote and was not able to watch it whatsoever due to this error. Direct stream worked successfully.

I'd love to be able to troubleshoot this error further if you can provide some guidance. Perhaps just an explanation of the error may satisfy my needs for now as well as I may be able to troubleshoot from there.

PS, does anyone elses PMS log get flooded with these errors:
[1284] WARN - Held transaction for too long (..\Library\MetadataItem.cpp:6665): 0.499203 seconds
[3076] WARN - LongPoll: Got error, closing.

PSS, apologies, as I was typing the questions, more questions came into my head and I just kept typing!

Windows Home Server 2011


I am getting a very similar error in that TV shows / movies in certain MP4 format (iTunes download with DRM removed) will not play on one of my Samsung TVs and I get repeated Cannot Connect To Server when trying to play them, repeated attempts work on very rare occasions. These MP4 files will play on my other 2 Samsung TVs though. They do play if I put them on a USB stick and plug that into the TV. All 3 TVs are connected to my router via an Ethernet cable. I've checked the Logs and see the error you have described above WARN - LONGPOLL: Got Error Closing. Just above that error in the log file I see "Statistics: (u7cj6otenlpxi) Reporting active playback in state 3 of type 4 (scrobble: 0) for account 1" where as for successful playbacks the state is 2. I don't know if this is relevant. The only difference between my TVs are : a) the 2 that work are 55 inch Samsung Smart TVs(UA55H6400), the one that doesn't is a newer 60 inch Samsung Smart TV(UA60JU7000). All Samsung software updates on the TVs are current. The 2 that work were running successfully on Plex and are still running successfully having upgraded to Plex the TV that doesn't play these files is running Again don't know if this is relevant. Sorry I'm not answering your issue but maybe my problem may shed some light on a possible solution. Chris.


I've also just tried to play these files in different ways. They will play if I choose Direct Streaming or Transcoding on the TV but not if I chose Auto or Direct Play. Have seen on other threads reverting to Vers 1.7.x and not upgrading to 1.9.x works.


The longpoll error is just the server saying it restarted a new longpoll, it's used for companion only.
It records it as an error but it's not. anyway totally unrelated to your issue.

J models and MP4 have been a pain. I reported that to Samsung and It should be resolved with the latest firmware update.
If that doesn't help I'm afraid it's a model specific problem that I can't fix.

Changing the server won't make a difference for your TV, it will still not play those files directly.