Samsung + Plex Server Undefined



Hi All,
I know a lot of topic about this, but I have tried all the method but still unable to connect my Plex in Samung TV.
I have put my PMS in location A with internet connection.
I am using my 3 samsung phone + Xiaomi phone in Location B to discover this server and play the media.
Although it is said that no direct access, I can play the media smoothly.
However, my Samsung Smart TV (UA55F6700) from year 2013 using Plex v2.007 still showing server undefined:undefined.
This has happen for the pass few days and until now my TV has been unable to connect.
I have tried reconnect, unplug (for 3 hours), reinstall, make sure the server security setup as "Preferred", update my Samsung TV Firmware with no result.
FYI, my plex is showing PMS version 0.9.8. Looks very weird because my PMS has been updated to 1.5.5

Can someone advise if this is compatibility issue or is there anyway I can solve this?


If the TV shows the wrong server (probably an old one), it means that it's the last info it ever got.
Your server needs to be logged in to your Plex account so it can update that data. The app will then have the correct information to connect again. The problem might also be due to using different accounts for the server and the client.
Like in: client sees server A connect to account A, but you expect it to be B that should list server B.

Please also download the manual from the link below to help you set it up.
This topic might also have tips one connection issues.


Hi Orca,
Thanks for answering this question fast.
I have only 1 account and 1 plex server so far, so not possible to have different account.
I have seen my Samsung TV in my PMS registered, but in the TV, it is still showing that.
Now I am contemplating to downgrade that back to before v1 because of this reason :(

By the way, I have followed all the instruction to remove device, reset all applications and re-login.
Still no luck with my TV.


I tried from TV browser just to test if there is any other issue. My url was forced to http instead of https, probably this is TV problem, not support ssl maybe? Is updating software same with update firmware?