Samsung TV & VPN Suddenly Causes "undefined : undefined server_name" At Every App Restart



I've been using Plex with my Samsung TV for years now. Recently I've been having a problem when launching the Plex app on my Samsung TV. Upon opening, my local server is shown as unavailable. I then navigate to the server list in preferences where my server is shown as "undefined : undefined server_name". From there I can temporarily resolve the issue by deleting my server and adding it again using my PMS' local IP ( This works until the app is closed either via closing the app or powering off the TV.

I don't remember exactly when this started but it might be since PIA's latest client update. I really am not sure though.

/// MY SETUP ///

Windows 10 64bit (server)
VPN (Private Internet Access) (server)

Samsung TV (main streaming device and only problem device)
Samsung Galaxy S6 Edge (as secondary testing device)

TESTS (all while connected to local network):
OK - Samsung TV to PMS without VPN
FAIL - Samsung TV to PMS with VPN
OK - Samsung Galaxy S6 Edge to PMS without VPN
OK - Samsung Galaxy S6 Edge to PMS with VPN


Please always mention which version PMS and app are you using on which TV model.

The difference here is probably that you signed the Galaxy app in with your account, and did not do that on the TV app.
Try to use the PIN code login. You can download the manual here to help you set it up.


I apologize,

Taken from Plex App's "About Plex" section:
Samsung TV: UN50F5500 is a F-series (2013) model
Network Connection: Lan
Plex app version 2.007 PMS version

Taken from Plex Media Server:
Web Version 3.20.8
Server Version

I have of course always used the PIN method of connecting to my TV. However, I decided to try again now. It successfully connected to my Plex account, added my PMS and was automatically "undefined : undefined server_name".


Please update the app to the latest version (2.009) and see if that fixes the issue.


I have now updated the Samsung TV App to version 2.009, same issue.


Your TV app does not seem to be connected to the server you claim to have: Server Version

Since the app reports this: Plex app version 2.007 PMS version (that version is really old and no longer supported)

Try to press the yellow button on your remote, that brings up the server selection.
Check if your have the right one.


After updating to 2.009 I see that the PMS version is now correct in the Samsung TVs About Plex:

Here is a screenshot of my PMS version (I notice it says I’m signed in as my email address and not my username like everywhere else, if this is useful):

Here is what my server list looks like when I manually add my server using the local IP:

Here is what it looks like if I use the “Discover” feature or if I reopen the app:



Does this information help? I would love to not have to do this every time I want to watch something.


You are mixing up two ways of connecting, and that doesn't work well.
- The PIN code login will connect the app to your account so it can figure out by itself where your server is.
- The manual way: You only want to connect to your local server and don't use any other internet stuff.

If you want to use the last option (which I would not recommend) you should also turn off the setting that will overwrite your server settings every time you connect to Plex. (it can be found under preferences)

Both ways are explained in the manual, please read it, it might make things clearer.


I did look at the manual when you first mentioned that, I just looked at it again. I did sign out and back in with the pin. I get undefined:undefined. For this reason, I remove the undefined server and add it manually. Also, when I use the discover option (which seems to behave as the pin would) it replaces the local server with undefined:undefined again.

Also, are you forgetting that when I am not using the VPN it works perfectly?

If I do not manually add the server while on VPN, I will not be able to view any content. Also, in case you forgot, this is a new problem of only a few weeks.

If you want to have me try to follow specific steps, I will do it and report back. I can video it if you do not believe that I am doing it correctly. Whatever you say. I just want this resolved.

I am also available to communicate via other means if this would be convenient.


Ah right , you used VPN. (sorry, I read at lot of comments)
I'm not a network expert, and have no experience with VPN, so I'm not sure I can help you with this.

There might be others here that have a similar setup. Guys can you help him ?


The strange thing is that it worked fine for years.


I would also like to remind you that my Roku (another TV in the house), my Android phone, and my desktop have no problem accessing media using the PIN method, with or without VPN. This is seemingly a Samsung App issue.


I have a similar setup and am having the same issue. I have VPN with ports forwarded, the difference is that the samsung TV is not on the local network, but I can connect to plex on my phone (indirect). I saw that there are specific issues with the Vizio app because of their platform, are the different security standards imposed my Samsung?


I have exactly the same issue. As noted it only happens when I have the VPN running. I suspect that the app is trying to connect via the wrong IP address i.e. the VPN tunnel adaptor rather than the local IP. If I sent up the connection manually it works until the next time I turn on the TV at which point it reverts back to the error.


The TV has an (Samsung) APi that the app talks to, If it reports the wrong IP on VPN there isn't much I can do.
You could use the manual option, but you need to do two things:
- Your server and TV need to have a fixed (or DHCP assigned) IP address that never changes.
- if you don't want to have your server settings overwritten when you connect to Plex, make sure you disable the option Advanced > Use Plex account to update serverlist


Cheers Orca that solved it. Funny thing is that for the last year or so I have not had a single issue connecting and then this started to happen. I have also lost the auto play option. Did Samsung mess with the API?