Second plex install on freenas (FreeBSD) via VM

server-freebsd

#1

Im having problems installing plex on my second NAS. My first one is running fine but im upgrading and wanted to do this via VM so i have a system with windows 2012 r2 running freenas via hyper-v. Everything has been fine untill i tried install Plex server. It tries to install but has an error around the time it makes a jail i think. (I can get the exact error at a later time) im not sure if its because i already have a plex server going or if its because of it running on a VM?

Anyone running the same as me had any problems like this


#2

Can you post the error?

Also have you tried simply installing the port/pkg on a jail you manually create? The plugin is not maintained by plex and nor is the port, however I’ve never had issues with the port.

In fact my main PMS is running on a FreeBSD (not FreeNAS) VM. I created my own jail (with VIMAGE support).
You can do the same in FreeNAS, create a jail (make sure VIMAGE is on) and then install the port or even the package with pkg install If you’re using “latest” for the pkg repo config the pkg shouldn’t be much behind the port version. In fact the FreeNAS plugin is usually much more outdated.