Server not powerful enough to convert (only when subs enabled)

server-asustor

#1

Hello,
I have an ASUSTOR 1002T and a new LG OLED TV. (Wifi setup)
Everything seems to work fine... when subtitles are disabled! - When I enable subtitles the whole thing stops with the message "Server not powerful enough to convert..."
I've tried adding different subs - with no luck
Tried settings "burn subs..." - with no luck
The funny thing is that it works fine when I use my LG phone, tablet or PC to watch media with subtitles.

Server is updated to latest version

Hope someone can help me!


#2

Only SRT and SSA/ASS (all text based) can be used and only played on devices which support text-based subtitles.

Your processor is a Marvell Dual-Core 1GHz processor with hardware encryption. It is not strong enough to create the images (like VOBSUB or PGS) and merge that with the video frames in real time

Look at the XML for some that do play and you will find they’re one of the text formats I’ve referenced above.

If you want subtitles to process, you’ll need more CPU power either in the player (like a NUC / HTPC) or a stronger NAS with an i3+ class CPU


#3

Thanks for the answer ChuckPA.
Is there anything I can do to get subtitles to work with my NAS? :slight_smile:


#4

As I stated, you must make certain a) you do not have VOBSUB or PGS subtitles in them or b) whatever you are playing the movies on can perform the rendering (image overlay) tasks itself. Your NAS CPU does not have the ability as I stated.


#5

You could extract the subtitles from your files with a software like HdBrStreamExtractor and convert it to .srt (a text based subtitle format) with Subtitle Edit. Then merge the new .srt file with your movie file and remove the old .vob or .pgs file. If you are using mkv-files then MKVtoolnix will do the job for you.