# Server setting UX quirks

**URL:** <https://forums.plex.tv/t/server-setting-ux-quirks/937698>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [April 3, 2026, 9:44pm UTC](https://forums.plex.tv/t/server-setting-ux-quirks/937698 "2026-04-03T21:44:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mcandre](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/mcandre/32/210047_2.png) [@mcandre](https://forums.plex.tv/u/mcandre)\
**Post date:** [April 3, 2026, 9:44pm UTC](https://forums.plex.tv/t/server-setting-ux-quirks/937698/1 "2026-04-03T21:44:14Z")

</div>

Overnight, Plex completely broke. All attempts to connect on the LAN now trigger:

> Unable to connect to “bart” securely

 ![Screenshot 2026-04-03 at 5.06.25 PM](https://global.discourse-cdn.com/plex/original/4X/f/2/8/f28d9ac2fa64e536dcde9a8e5005336337e06e91.png)

I had unchecked a checkbox concerning remote access, which resolved a red warning triangle. Plex continued to work for serveral hours, but overnight, it now refuses to connect.

```auto
% snap info plexmediaserver
name: plexmediaserver
summary: Your media on all your devices.
publisher: Plex, Inc. (plexinc✓)
store-url: https://snapcraft.io/plexmediaserver
contact: http://plex.tv/
license: unset
description: |
  Plex makes it possible to enjoy all of your media, whether in your living
  room, the car, or on a boat in the South Pacific!
  .
  You can manage your media by browsing to http://localhost:32400/manage
commands:
  - plexmediaserver.pms-web
services:
  plexmediaserver: simple, enabled, active
snap-id: 85SmCU9pNtVq5DHmKJwbZsgbNqkG7wPR
tracking: latest/stable
refresh-date: 51 days ago, at 11:02 CST
channels:
  latest/stable: 1.43.0.10492-121068a07 2026-02-11 (512) 94MB -
  latest/candidate: ↑                                            
  latest/beta: ↑                                            
  latest/edge: ↑                                            
installed: 1.43.0.10492-121068a07 (512) 94MB -

% lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 24.04.4 LTS
Release:	24.04
Codename:	noble

% snap services
Service Startup Current Notes
mesa-2404.component-monitor disabled inactive -
plexmediaserver.plexmediaserver enabled active -
snapd-desktop-integration.snapd-desktop-integration enabled active user

```

My snaps are up to date. My Ubuntu packages are up to date. I’ve tried restarting the snap service. I’ve tried rebooting. Tried reverting to an older snap package version. Tried re-upgrading to the latest snap package version. Same behavior in all cases.

Unclear where the plexmediaserver stores configuration files. If someone could point to documentation for that, then we could at least investigate those.

The logs are unhelpful, and contain spurious critical level messages about libusb\_init:

```auto
% sudo snap logs plexmediaserver
2026-04-03T16:51:25-05:00 systemd[1]: Started snap.plexmediaserver.plexmediaserver.service - Service for snap application plexmediaserver.plexmediaserver.
2026-04-03T16:51:37-05:00 plexmediaserver.plexmediaserver[10750]: Critical: libusb_init failed
2026-04-03T16:51:37-05:00 -[10750]: Critical: libusb_init failed
2026-04-03T16:52:10-05:00 systemd[1]: Stopping snap.plexmediaserver.plexmediaserver.service - Service for snap application plexmediaserver.plexmediaserver...
2026-04-03T16:52:30-05:00 systemd[1]: snap.plexmediaserver.plexmediaserver.service: Deactivated successfully.
2026-04-03T16:52:30-05:00 systemd[1]: Stopped snap.plexmediaserver.plexmediaserver.service - Service for snap application plexmediaserver.plexmediaserver.
2026-04-03T16:52:30-05:00 systemd[1]: snap.plexmediaserver.plexmediaserver.service: Consumed 16.426s CPU time, 305.5M memory peak, 0B memory swap peak.
2026-04-03T16:52:30-05:00 systemd[1]: Started snap.plexmediaserver.plexmediaserver.service - Service for snap application plexmediaserver.plexmediaserver.
2026-04-03T16:52:43-05:00 -[12199]: Critical: libusb_init failed
2026-04-03T16:52:43-05:00 plexmediaserver.plexmediaserver[12199]: Critical: libusb_init failed

```

The documentation link [https://support.plex.tv/articles/206225077-how-to-use-secure-server-connections/](https://support.plex.tv/articles/206225077-how-to-use-secure-server-connections/) is unhelpful. It directs users to muck around with server settings. But this error prevents the Plex server page from loading ☹

I don’t understand why Plex is inaccessible. Help plz.

---

<div class="post-metadata">

**Author:** ![mcandre](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/mcandre/32/210047_2.png) [@mcandre](https://forums.plex.tv/u/mcandre)\
**Post date:** [April 3, 2026, 10:14pm UTC](https://forums.plex.tv/t/server-setting-ux-quirks/937698/2 "2026-04-03T22:14:20Z")

</div>

Update:

Temporarily fixed the problem.

Set `PublishServerOnPlexOnlineKey` to `1` in `/var/snap/plexmediaserver/common/Library/Application Support/Plex Media Server/Preferences.xml` and restarted the snap Plex service.

The UX for this is horrible. There is a scary red exclamation mark warning for the Remote Access section of the Plex server Web UI. The warning has NO tooltip or documentation of any kind to explain WTF it is complaining about.

The warning only appears after navigating into the Remote Access section. Selecting the option “Disable Remote Access” removes the warning. The option’s purpose is ambiguous. I thought it meant disabling online access, not ALL access including LAN access.

The remote access disabling action has a delayed effect. It only actually takes effect after the service restarts, creating a mental disconnect between the disastrous configuration change, and the Plex server later becoming completely inoperable.

The error messages and documentation about inability to connect completely fail to mention the XML value, attribute, or file path name that are extremely relevant to fixing the problem.

Once disabled in the server Web UI, it is impossible to re-enable it via Web UI. 0/10, do not recommend the Remote Access UX.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [July 2, 2026, 10:14pm UTC](https://forums.plex.tv/t/server-setting-ux-quirks/937698/3 "2026-07-02T22:14:42Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
