Setup plex DVR with Shield/Hauppauge, stuck on "looking for compatible devices"



I just want to use plex as DVR for recording live TV from my antenna via the Hauppauge dual tuner USB device.
I have plex server active, I have my shield connected on my home ethernet network, and I have my antenna connected and getting signal via the Hauppauge tuner (I can see it's working if I test it by way of the Tablo Engine app on my Shield).
Whenever I go to and login and try to "set up plex dvr" I get stuck on a screen that says "looking for compatible devices" and nothing ever happens from there.

One potential conflict is I'm stuck as double NAT (I live in a rural area and can't have a traditional ISP and must use a line of site dish to a local tower for my ISP and their setup forces a double NAT and I can't go into a bridge setup). If I enter the IP manually for the shield it can't find anything either.

I do remember when Tablo Engine app was starting I had to allow usb access (presumably for the Hauppauge tuner usb stick) for the app on my Shield at one point, but I've never had the opportunity to grant permission for the shield plex app to do this.

I have no VPN running on either computer or Shield. I have deleted and re-installed plex multiple times on the Shield, I have current versions of everything.

Tablo seems to be crap, and I can't get plex working, so I'm losing my cool now. Any suggestions please?


update, the double NAT doesn't seem to be the issue, I logged in directly via http://192.168.x.x:32400/web and still it is stuck on the "looking for compatible devices."


After a lot of playing around, I finally figured it out, and I really haven't seen this described as necessary.

I went to shield settings, permissions, and allowed storage access for plex and plex server... then I signed out of the server and "reclaimed" it by the 192.168.x.x:32400/web signin.
It still wouldn't work, but after a reboot I was able to finally get it to recognize the tuner.

I did play around with the tuner on a usb extension vs an unpowered hub, but the tuner has worked fine in both setups with tablo engine app and failed in both setups with shield until the other things I mentioned in this post.



I'll just keep talking to myself here, but it failed again recently after working for days. I have tried fresh installations of plex and plex server, update to the latest beta...

I have given up on an unpowered usb hub, it had worked for days on a powered hub but now no longer can I get anything to go. Main errors are:
1) server will not consistently stay up or start up when requested in the settings
2) my usb tuner is now not being recognized.

Is anybody getting shield and this tuner to work on a consistent basis?


This setup fails constantly. I do not know why it is promoted as stable. I am away from the location, and I am unable to add the tuner as described by Plex directions. I, too, am "looking for....." I had it working for a while, but all I recall is that it took all day to get the Hauppauge USB tuner to work with Nvidia shield as declared by the marketing people.

Do not dare try this setup with anything but a USB stick. I tried multiple SSD's and spindled hard drives, and all crashed the tuner. I suspect due to power demands. I have been constantly disappointed with this setup.


I too,am having the exact same issue.I try to get Plex to find my Hauppage(sp?) usb tuner and it just keeps "looking for compatible device.." I have a free 3 mo. trial of Plex pass and was excited to get live tv up and running,but the ONLY service that seems to work so far for live ota tv/dvr for the Shield,is the Tablo Engine (like the op said,it isn't very good). PLEX please get this worked out!!! or quit promoting it,until it works properly!


This happened to me, I think due to starting the setup and not having the USB tuner attached.

I had to clear app cache, data and even deleted everything, powered off the shield, then attached the USB tuner, power up the Shield and start the whole setup process over. It found the tuner fine. (Hauppauge WinTV-DualHD)

Bob H


I had the same problem. As far as I can tell only one app can have permission to use the tuner. So when you reboot and start Plex it can access the signal, but if you then give permission to Tablo TV it will prevent Plex from seeing it.


I am having the same problem with the screen stuck on looking for compatible devices. Checked version levels of Plex and Plex media server and shield version and all are in line with recommendations. I have also verified the hauppauge by installing on a PC. But I cannot get Plex to see the device on the Shield. I've tried all the suggestions above to no avail. Any assistance would be greatly appreciated.