shared user, no restrictions, photo library displays "there are no items in this library"

plex-web

#1

Running Plex server 1.7.6.4058 with plex pass. I am sharing all my plex libraries with a user. There are no restrictions on the user. The user can see all my libraries (Home Video, Movies, Music) except my photo library. When the user selects the photo library for the first time, a message complaining that timeline sharing will not work without a server update displays (which should not be the case, I am running 1.7.6.4058), and then after selecting to view by folder, the message "There are no items in this library" displays. There are no with my primary user being able to see the contents of the photo library, only my shared user has the problem.


#2

If someone from plex could help out here, I would appreciate it. I was an early plex pass supporter of plex, and I have tried to use sharing for years now, and there is always one problem or another with it. More data about the problem I am having:

On the user’s web home screen, with the “Discover All Libraries” view selected, it does show a few photos in the “recently added photos” section (despite the fact that the photos displayed were added years ago), and if the user clicks on one, it displays properly. But if the user clicks on the Photos library, the message “there are no items in the library” appears.

With my primary user, I can see all the photos, but I notice when I select the timeline view, some of the photos have a date of Jan 1, 1990, despite the fact that I have verified all the metadata in the associate jpeg file shows a 2017 date.


#3

I see other posts concerning photos not displaying for a shared user, and no responses from any Plex developer. What is the reason that photo support is being ignored?


#4

Same problem here. Plex keeps announcing new features with the photo library, but I don’t even get to see mine. Either “There was an error loading the timeline for this library. The photos timeline requires Plex Media Server 1.5.4 or higher.” or “There are no items in this library.”, both which is not true. I’m on Version 1.8.2.4209 and yes, there are photos in that folder.


#5

More debugging I tried: I added a new friend with a new email id that did not currently have a plex account. I created a new plex account for this new email id, and photo sharing works correctly. For my other existing id where photo sharing is not working as described above, in my main user account, I removed the friend , then added the friend back. Photo sharing remains broken for that friend, same problem described above, namely: When the friend selects the photo library for the first time, a message complaining that timeline sharing will not work without a server update displays (which should not be the case, I am running 1.9.5.4339 ), and then after selecting to view by folder, the message “There are no items in this library” displays. I thought about deleting the plex account for the friend that does not work and recreating it, but there are lots of warning about not doing that, including a month delay to use the email address again, and the friendly advice to seek help in the forums. Come on Plex Developers, this has been broken for a long time, and I have tried everything I can think up to help debug it!


#6

I am having the same issue when using the library for my own photo’s no sharing… the bummer in this is that I decided to take a plex pass when all worked fine… After obtaining the Plex pass it failed…


#7

Same here. PlexPass user since today (Version 1.10.1.4602)


#8

Still broken, has been for years. Years go by with new features added for photos, yet this bug prevents any use of photo sharing.


#9

I’m having this problem as well… I created a “Workout Videos” Library… the user can see all other shared libraries, but not this one… I can see the library just fine when logged in as my (admin) user. I have tried refreshing metadata, updating libraries, etc. with no luck!! Running the newest version of PMS (1.13.0.5023) on Windows Server 2012. File permissions are the same on this windows folder as all other library folders.


#10

Got it! There was no rating set and I had that user restricted… went in to each video and set the Content Rating to ‘G’ and voila!


#11

Update: When I removed a music album label restriction that had been in place for the user, the user was then able to see all the photos in the library. So while plex does not currently support adding labels to photos (which is another feature that is absolutely needed for sharing: see http://forums.plex.tv/discussion/232921/sharing-and-labels-for-photos ), apparently the use of a label restriction for music albums causes all photos to not be viewable.