Sideloaded Plex Classic sees PMS, shows no content

plex-classic-for-roku

#1

Hi fellow Plexers

Having some issues with a new Roku 3 (AU Telstra TV that is locked out of Roku Store) that I am trying to sideload Plex Classic 3.1.9 onto.

I have repeated this process a number of times.

My PMS is working fine, but I have rebooted it too (running on a spare Mac mini)

Running ATV 4 and Xbox player versions perfectly

I can connect the Roku to the PMS (it sees the server, located on the same subnet), I can login with my myPlex account, no worries (including entering my PIN)

But when I go into the Classic Home Screen, no content. When I click into Library Section or On Deck etc, it pops up a screen that says “No Library Sections. Either you don’t have a Plex Media Server running or it couldn’t be reached”

I have uninstalled Plex Classic. I have tried RARflix and Plex-NowTV-2.8.2 (I am back to Classic 3.1.9 now).

I have factory reset my Roku and redid it all again

I even tried putting my Roku into the api.qa.roku.com channel store, all with no luck

As you can tell, I have tried every Google, Plex Forum and YouTube search I can - to no avail

So I am now stuck and cannot get Plex content onto my Roku - So if someone could please help or give me some guidance, I’d really appreciate it! I’m going round n round on this!!

Cheers, Ben


#2

Try turning off secure connections in settings. I am not sure exactly where that is as I have not used the "Classic" app in quite a while but I do remember that there have been problems with the old Plex apps on the Roku when using secure connections.


#3

@Elijah_Baley WELL DONE!! Thanks heaps for the quick response and it bloody well worked!! I can't believe that it was a simple switch like that (but it always is I suppose!!)
Thanks heaps!!
Cheers, Ben