Since Upgrade to Plex App 2.006: Unable to connect to content server




first of all thanks for the great job on this beautiful app.
Unfortunately since my UE55JS8500 (2015) updated to Plex app version 2.006 I can browse my Libraries, but as soon as I try to play the contents, I receive:


Unable to play content requested
Unable to connect to content server


PMS is latest Version running on Ubuntu 16.
The same PMS worked fine with plex app 2.005 on this TV for quite a while and still works with 2.005 running on another TV.
Also this very same TV with App 2.006 can still play contents from a different PMS with an earlier version

I've tried reinstalling the app, resetting the settings, disconnecting the TV and a couple of other things.
Also I tried disabling HTTP Pipelining as recommended in another thread here.
Unfortunately nothing seems to help and by now I am officially out of ideas.

Anybody here have another idea I could try?

Thanks in advance,


Sorry, exact error message is

Unable to connect to content server
Request could not be completed
The requested item could not be found


That message indicates a 404 error. That means it can't find the item you requested.
If your server is connected an you get that error, please check if you haven't moved or renamed any files or directories. if so start a rescan of the library, so the database will be updated and it can find your items again.

If you can't connect to any of your content it might be because you updated the server and your token has become "stale".
To renew the token do this:
Go to the devices page on Plex web and delete all instances of your server.
Now go to the server settings and log the server in again, so it will get a new token.

On the TV either reset the app from preferences > advanced, or uninstall/reinstall the app.
Use the PIN code to log the app in again and it should pick up the new token.

Note: The procedure for local connections has changed in the latest server releases.
You can no longer use a manual IP address without changing settings on the server.
By default, all apps now need to be signed in.


Hi Orca,

thanks for your response.
I don think the problem can be located on the PMS because it used to work just fine with plex appp version 2.005 and still does work with another TV that's still using that older version. All content is found and also plays in the web player. So it's not a 404 either. I've run a library update a couple of times already anyways.
I did not update the server, just the app on the one Samsung TV from 2.005 to 2.006.
I am not signed in to plex and just use local connection. I always have the PMS configured to trust devices in my local network, so I doubt this could be the issue either.
It must me a combination of PMS version and plex app 2.006 because all other combinations I've tried just work fine:
Plex App 2.005 - PMS - OK
Plex App 2.006 - PMS - OK
Plex App 2.005 - PMS - OK
Plex App 2.006 - PMS - NOK
I'll activate and have a closer look at debug logs.
If you can think of anything else to try, please let me know.

Thanks again,

#5 said:
I am not signed in to plex and just use local connection.

That’s what I was pointing out (with the link) has changed with PMS version 1.1.3
You need to add the address for your TV to the trusted addresses or you can’t get access to your content.
It’s a new security feature that was added in the last version of the server.


I always have the PMS configured to trust devices in my local network, so I doubt this could be the issue either.
Plex App 2.005 - PMS - OK

As mentioned, I have my whole network added to the list of trusted hosts and networks because this security feature has been there for a while now.
Why would the security feature in the new Server version do nothing on client apps before 2.006?
Mind you, Plex App 2.005 still works totally fine with this server.

I'll give it a try anyway and add the IP of the TV specifically, but I don't think that it will change anything.
I'll let you kow.



If you do, please make sure your TV has a fixed IP address, or this will stop working again when the IP changes.
The easiest way is still to use the PIN code login, Plex will locate your server automatically and will update the IP whenever it changes.


Thanks again for your response.
That won't be an issue since the TV already has a static IP.
I will let you know later.


I have set the IP of the TV specifically, but as expected it did not change a thing.
This would have had to be a bug anyways as the whole network was configured there already

So I removed the IP again.
Any more ideas what I could try?

Thanks in advance.


I enabled debug logging and interesting enough it shows a 404 error after all:

Sep 12, 2016 20:56:03.432 [0x7f858bfff700] DEBUG - Completed: [] 404 GET /playQueues/0?window=50 (5 live) GZIP 0ms 313 bytes

Just not sure what it really means.
The complete log I took from one unsuccessful attempt to start and play a movie is attached.


And here´s the log from a successfull attempt from my other TV running Plex App 2.005.


The error I'm seeing is that it tries to create a playqueue but fails to do so because of a CORS problem.

Request: [ (Allowed Network)] POST /playQueues?type=video&uri=library%3A%2F%2Fc430bf2e-2c08-476e-9d62-f46da3726975%2Fdirectory%2Flibrary%2Fmetadata%2F7 (6 live) GZIP
Sep 12, 2016 20:56:03.404 [0x7f858bfff700] DEBUG - Request came in with unrecognized domain 'null' in header Origin; treating as non-local

Do you have any firewall or anti-virus software that strips headers from a request by any chance?
Have you tried the PIN code way to connect?


Hmmm, that's really interesting.
There is no firewall between the TV and the PMS. Also not on the PMS.
I checked the TV and there is a menu item "Smart Security". So I disabled all options in there like "Virus Protection" and "Network Protection". Unfortunately it didn't change anything.
I can't think of anything that could possibly cause this.
Do you think, resetting the TV to factory settings might help?
So far I've always just reset plex or smarthub, but not the TV itself. It would be a pain to go through the whole setup process, but if there's any chance it might help...
Or is there anything else I could try or check?

Thanks again,


Meanwhile I have upgraded to PMS Version
Unfortunately still the same issue. 2.006 doesn't work, 2.005 still perfectly fine.
I also switched Network from cable to wireless and back using different addresses - no change.
If only I could go back to 2.005...


Since upgrading my PMS to I have exactly the same problem as djiceman. I use my Plex server and Plex app (2.006) offline (i.e. neither are signed in), and although I can see all the content if I try to play anything I get UNABLE TO CONNECT TO CONTENT SERVER.

If I sign in the PMS and App, everything works, but I don't want to use the server this way.



Hey John,

sorry to hear you're in the same boat now. But at least now I know I'm not the only one seeing this strange behaviour.
May I ask what TV model you have?
Meanwhile I tried a couple more things, but still am stuck with this issue. Here's what I tried:
- Replaced network cable
- Connected the TV directly to the PMS (no switch or router in between)
- Reset the TV to factory defaults
- Changed network configuration (different IP address range)
- Tried DLNA - works fine
I am now really out of ideas.
Looks like I have to downgrade the PMS to to get Plex App 2.006 to work with it again.
I just don understand what might cause the CORS issue. Must be the TV itself somehow. Very strange.

If you guys have any ideas what else I could try, please let me know. At this point I am willing to try anything.



Hi Frank,

TV is a JU7000, and I can confirm that DLNA also works for me.

This is very odd behaviour, and I haven't found a solution other than to sign in PMS and App.




for testing, I just installed an older version of PMS on a small machine. Works without any issue with the same TV and Plex App that refuses to work with 1.1.3 and up...
Guess it is not any configuration or setup issue. It's just that 2.006 doesn't play nice with newer server versions in local mode only. :(



I'm seeing the same behaviour - Samsung app no longer works with latest PMS.
Neither my server, nor my TV is signed in, as I have no need for any of the cloud features.
It's pretty obvious it's requiring sign-in somehow and refusing to work because of this:

Sep 21, 2016 00:34:23.550 [0x7f1dd9fff700] DEBUG - Request came in with unrecognized domain 'null' in header Origin; treating as non-local

Which you have also been seeing.
It was working fine with the recent release that required putting the local devices in trusted devices, but recently stopped working entirely.

Note, that it works fine on other devices without being signed in, so this is clearly a bug in the TV client and/or the server.


Hi rayman84,

I agree 100%.

Did you add something to the latest client version 2.006 to block local usage?