Skipped lines during ass subtitles and delayed lines with srt

roku

#1

Okay, so I’ve been encountering this quite frequently recently with a few files, with ass/ssa subtitles I’ve been getting good sync, but skipped lines, and with srt delayed/out of sync lines, generally at the beginning of the dialogue with mid-dialogue lines usually being more in sync but sometimes delayed. I’ve tested the same files on a Samsung TV and they worked just fine.

I’ve prepared two short and small test files that I’ve uploaded to mega https://mega.nz/#F!9zAzTLZJ!gt7BjyEr7zZsOPalilCBKg
These test files show the issues 100% of the time in my testing, they are about 10MB each, I’ve also included some TV Cam footage showing the bug and some images displaying each of the skipped/delayed lines captured from subtitle edit
Delayed subs from SRT

Skipped subs from ass/ssa


#2

ASS subs, most likely, require transcoding.
If your server doesn’t have the horsepower to transcode a video stream - bad things happen.

The standard answer here is to convert those ASS subs to UTF-8 so they’ll Direct Play.


#3

They file with the skipped ass subs says it direct plays just fine on both TV’s, transcoding burning them in works just fine, I just don’t want the minor loss of quality from transcoding. With the delayed srt subs file, my cut of it included doesn’t direct play, but the source file does, I’ve had this problem with pretty much EVERY source with subtitles. the RokuTV I have is the TCL S405, and the Samsung TV we have that plays the files with subs just fine is the Samsung KU6300.
My PC Specs are, i5 3570k@4.0, 16GB@1600, and a GTX 980, this is more than capable of serving the files and transcoding if needed.


#4

If a sub is being ‘Burned In’ - it’s transcoding.

ASS subs are image based (probably) and will require transcoding with a Roku - at least on my Roku here at my house.
If you want to find out if ASS subs are transcoding:
Play item
Press *
Arrow down to Streams
There it will be revealed - Direct Play or Transcoding.

A sure-fire way to stop ASS transcoding is to convert them to UTF-8 (text)… that’ll do it.

Then, of course, there’s always the possibility those ASS subs are all ASSed up.
Get some good ones.

B)


#5

skipped subs ASS subs file

I thought it was full direct playing but, but I guess not, It’s still direct playing (copy) both the video and audio streams, I guess it’s converting the ASS subs, to work, and while that could be the issue
the Samsung TV does the exact same it appears, and it plays it just fine. (I used the test file I created to display the issue for the Samsung TV because the Samsung TV can’t direct play FLAC which the original had)

delayed SRT subs file

this full direct plays just fine, but the subs are delayed and or show longer than they should often, this isn’t unique to this file, pretty much every video I play with subtitles has issues, some more than others, but generally similar issues.

For the ASS subs file, The release I’m using is pretty good, the subs play just fine on the Samsung TV and my PC, and I did a mobile encoded version in handbrake with soft subs and the subs play just fine on my phone, a OnePlus One in MXPlayer, honestly MXPlayer on my phone does a better job with subtitles than both TVs.

For the SRT subs file, I’m using a Direct rip from Netflix and the subs are fine on the Samsung TV, my PC, and my phone, only have issues on the TCL S405 RokuTV.


#6

@DaSkyBro
I tried your test file Delayed sub start Example cut [horriblesubs] Devilman Crybaby - 01 [720p]_new cut.mkv and did not see the delayed lines. It played on my Roku normal and the subs were displayed at the correct time. Very different from your TV cam.

I also had no issues with Skipped lines Example cut [Coalgirls]_Nekomonogatari_Shiro_01_(1920x1080_Blu-ray_FLAC)_[374424D1]_new cut.mkv
All the subs were displayed.
None of them were missing. Again, it was very different from your TV cam recording.


#7

@NewPlaza you weren’t burning them in right? Thanks for testing. Honestly, I’m starting to suspect that it might be something with my TV when I get the chance I’m gonna try to mess around with the subtitle settings on the TV, I have most of it set to default right now I believe, but somethings may have been changed.


#8

Yes I was. Video & audio was transcoding


#9

If you wouldn’t mind could you try to test it with Direct play set to forced and subtitles set to only burn in image formats? The delayed sub test example should transcode the video anyway without burning them in, or at least it does for me, with the skipped subs example it should just direct play, provided you’re using the same or similar TV/Roku to me, TCL S405. This would be a great help, thanks.


#10

@DaSkyBro said:
provided you’re using the same or similar TV/Roku to me, TCL S405.

I have a Roku3. Thought I mentioned that. My bad.


#11

@NewPlaza Ah, okay. Thank you for testing anyway.


#12

Hello. Im running into this issue as well. File direct playing but subtitles are a bit out of sync and some lines skip. They are also ASS subs. And btw ASS subtitles are text based not image based subtitles. The clients are nvidia sheild and android phone.