So the Surface RT app doesn't work anymore

windows-store-app

#1

Seems like the app can connect and view content, but playing never starts. It used to work back when I paid for it before I got plexpass, haven't used it in over a year probably now that I have plexpass tried it and it wont play anything. Anyone else have luck? I'm on the latest plex server version.


#2

Maybe there are some infos in the logfiles:

%LOCALAPPDATA%\Packages\CAF9E577.Plex_aam28m9va5cke\LocalState\Logs


#3

Just a singe log file not mofidied since 3 years ago that has two lines in it. It is the ARM version of plex so perhaps it has gone out of compatibility with the current plex server versions.


#4

if you can view things then it should be creating logs - maybe somewhere else? Is it still in your app store? if so it should work


#5

It helps if I turn on logging. Here is the log file.


#6

That log doesn’t really show anything except that you tried playing something. Interestingly there are no particular errors except that it tries to load the video then fails because you have Direct Play disabled in preferences, tries to transcode the video and fails…
Questions -

  1. What version of the APP are you using on your surface?
  2. Your server powerful enough to transcode?
  3. Why is Direct Play disabled? Can you enable it and try again?

#7

Yep, transcoding is fine on the server, its an i5 quad core 3.2ghz, and the cpu is usually nil on transcode due to hw acceleration. I toggled hardware acceleration off and it still didn’t resolve this.
If it means anything I can play off my friends plex server over the internet with this tablet, just not my home server. I tried tethering off my iphone’s LTE to be “remote” to my server and it didn’t fix it. I can stream remote just fine off browser and iPhone and Roku from my plex server. My home server has no problems with Roku, iphones, browsers, xbox, ps4.
The app just sits at “opening” with direct play enabled, it wasn’t enabled because its default is off. I turned it on now and tried playing two different shows. Attached logs again.
I don’t know what version this program is, its from the windows store and so it must be whatever the latest build there is for windows RT.

I have that loopback thing in dd-wrt setup in the dnsmasq options, did that yesterday it didn’t help.
rebind-domain-ok=/plex.direct/

update - I deleted the directory for plex that those logs are in, uninstalled the app, then installed it again. I am able to play a couple items that are recorded off tv, like anything off comet tv, h.264 480p, pbs 720p h264. But not the voice and other things from big networks, I don’t know if its random or based on the quality or tv network it was DVRd off of. I use in-line transcoding in the dvr. Maybe the plex app on rt just doesn’t support all current h264.


#8

You can find the version under settings (bottom left corner) and then find the Help tab, in there it should tell you that you are hopefully running 3.2.20-someNumbersHere.
If you reinstalled I presume Direct Play is enabled now? Or have you disabled it?
The log you send is the log of it not working right? Can you send a log where you play a video that does work, and then a video that doesn’t? It could be as simple as the profile that is being used doesn’t quite fit the RT requirements (i.e. you are trying to play x265 for example… Can you also post the media info for those 2 videos?


#9

The Surface RT apps settings are when you swipe from the right when you are in the app, under settings there all I get is general, account, media, interface, sync, camera upload and advanced. I scoured through them already once and saw no version information. They did away with tabs etc in the metro interface.

The log is from it not playing anything. I think this app maybe just doesn’t have all the codecs it needs. I’m assuming you understand the surface RT is the ARM processor Microsoft tablet that is windows 8.1 only and ended with the surface 2 non-pro being the last ARM processor surface tablet. I don’t have any 265, this is all native plex recorded material in 264 format done by plex during recording. I’ll collect logs this weekend and the media info.


#10

I figured out the problem! The plex app will not play dolby 5.1. However aac 5.1 is fine and stereo stuff. I didn’t see any settings to have it request stereo. That is why it works fine for most lower end recordings off the free tv channels, but major network tv shows don’t work. I didn’t see any plex server settings for audio transcoding settings either to play with. So what can I do?

Also, I got a version number by looking at plex.exe that is running when the app is running. 2.1.4.33, its the latest available in the windows store.


#11

Hmm must’ve not updated the arm app then as we are on 3.2.20… Which may explain why not everything is working.

What you’d need to do is figure out which profile Plex is using (this can be found in the Plex server logs). The profiles are XML files in the resources folder where Plex server is installed. There you could modify the file in question and define only stereo output and it would help.

Happy to help out - we’ll need a Plex server log once you have tried playing something. Then we modify it and try it out.


#12

Dec 09, 2017 16:33:37.374 [7024] DEBUG - [Now] User is jmfolcik (ID: 1)
Dec 09, 2017 16:33:37.374 [7024] DEBUG - [Now] Device is Windows (JOSH-SURFACE).
Dec 09, 2017 16:33:37.374 [7024] DEBUG - [Now] Profile is Windows
Dec 09, 2017 16:33:37.374 [7024] DEBUG - [Now] Updated play state for /library/metadata/1751.

I found the windows xml file, what should change in it?


#13

I played around with windows.xml today and couldn’t get it to work. I tried redirecting it to dumber devices using the xml redirect, restarting plex server and it would have different reactions, the errors would just be slightly different on the client. None of them made it work. I think the windows RT app just either needs to be removed from the market or updated.


#14

I would imagine if we set it to transcode everything to a file format that works. I.e. mp4 max 720p with stereo sound it should still work? I don’t have the windows.xml at hand at the moment. Could you post it and what changes you tried? I’ll have a go then myself too


#15

here it is, attached


#16

I had thought the Surface RT was almost exclusively designed to run apps from the Windows Store? It just couldn’t run full programs. I had one a while back… liked it, but traded it in for the Surface 3.
Long story short, the RT part shouldn’t matter. It should work if it’s updated… but then there’s a question about the Windows Store version, which I believe in itself has not been updated in a while.


#17

Try this one. Let me know if you get anything?


#18

Some video works some doesn’t, It did direct play for most things still so maybe the app doesn’t respect the xml file? I replaced the windows.xml and stopped and started plex back up. Attached the plex media server log file.


#19

Hmm it seems that it doesn’t recognise the surface properly. We have 2 options, lets try the simpler first:

  1. Follow the article here to delete the system and framework bundles:
    support.plex.tv/hc/en-us/articles/201119258-Resetting-System-and-Framework-bundles

If that doesn’t work, we might have to dive in and check the plugins…