# \[Solved\] Plex stopped scanning NFS drive

**URL:** <https://forums.plex.tv/t/solved-plex-stopped-scanning-nfs-drive/905704>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [February 15, 2025, 4:51pm UTC](https://forums.plex.tv/t/solved-plex-stopped-scanning-nfs-drive/905704 "2025-02-15T16:51:29Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [February 16, 2025, 3:01am UTC](https://forums.plex.tv/t/solved-plex-stopped-scanning-nfs-drive/905704/4 "2025-02-16T03:01:20Z")

</div>

> [@leatherp](#):
>
> pmedia:/Multimedia /mnt/PMediaNFS nfs rsize=24576,wsize=24576,user,vers=4.0,hard,intr,rw 0 0

You are using `sec=sys` on the QNAP.

Your mount

> pmedia:/Multimedia /mnt/PMediaNFS nfs rsize=24576,wsize=24576,user,vers=4.0,hard,intr,rw 0 0

can be improved here.

1. With `sec=sys`, don’t use `user`
2. By default, Ubuntu & QNAP will negotiate the highest NFS level availble (4.2)
3. ‘defaults’ first establishes the baseline options which you then customize  
– otherwise you get only what you ask for.

I recommend you use the same on Ubuntu (like I do) since you’re running linux\<-\>linux

Feel free to adjust per your needs

> 192.168.0.20:/vol/media /glock/media nfs defaults,sec=sys,rw,auto,async,rsize=4194304,wsize=4194304,x-systemd.after=network-online.target,nofail,bg 0 0

My machine boots really fast so I have systemd hold back on mounting until after the network adapter is safely up.

I set ‘nofail,bg’ so it won’t interrupt boot if it can’t mount and then background the failed attempt if the NAS is off (shutdown)

One concern I have is user permissions on the QNAP.

I run with with everything as ‘admin’  
This means Ubuntu, which mounts as root, gets uid 0 ↔ uid 0 access  
Ubuntu then determines whether or not I can see the media.

I have this little shell script which will help you track down where access fails.  
If you run as `plex` then you can easily confirm if any path is blocked.

> [@Linux Tips](https://forums.plex.tv/t/linux-tips/276247/22):
>
> Resolving permissions problems This How-To is about finding and resolving permission issues where PMS cannot read the file(s) due to a problem somewhere in the path. While the process is straight forward (perform ls -la for each directory in the pathname to the file), the process is time consuming and somewhat tedious. This HowTo provides a basic script which you can use (change from read-test to write-test if needed) and find where user plex loses its permission to get to a specific file. C…

Additionally, you can simply launch a shell as UID=plex and then attempt to ‘cd’ your way into the remote mounted locations. (the ones you can’t see)

---

_[View the full topic](https://forums.plex.tv/t/solved-plex-stopped-scanning-nfs-drive/905704)._
