Some movies not playing on Apple TV 4

apple-tv

#1

I now have some movies that used to play fine on all devices that are no longer playing on multiple Apple TV 4s.

The same movies play fine on iOS, macOS, Roku Premiere+, Win8, WIn10 and using PMP or the web player. It is only the Apple TV 4s that will not play them. They just sit at a black screen with a spinning circle until the screensaver kicks in.

I have pulled some logs but am not sure which ones I should be looking at.

Any ideas?

PMS is running the latest version (1.4.2.3400) on my iMac.
ATV4s are running what I think is the latest version (1.6).
Files are stored on a Synology NAS DS1815+.
The files in question are h264 in an mkv container but so are all the other files that play fine.


#2

I have a similar issue with just 1 movie (that I know of at least anyway) Fantastic Beasts and Where to Find Them.

I play the file it attempts to play then goes back to the screen where there is a screen shot of the movie with a arrow in the middle and the cast along the bottom etc.

The movie will play on iOS devices and everything else except plex web and the apple TV. I tried re-encoding the mkv file to a m4v file and the same thing happened. But then I changed the quality from original to 12 on the apple tv and it worked??? So bizarre. I'm hoping this is just an isolated bug with this file.


#3

Is a problem with that specific encode I think. As you notice if you change quality it plays (because plex re-encodes it).


#4

In my case the encode played fine untl it didn't, but only on the Apple TVs. Then a day or so later that file played fine again...


#5

This issue is back again with the same file and others. Which log files tell me what is going on when the ATV is trying to play a file from the PMS?

PMS is running on my iMac i7-4770s and wired with a gigabit network so it shouldn't be a transcoding or network bandwidth issue.


#6

Try disabling subtitles. I found that I had a similar issue which was caused by unsupported subs.


#7

I disabled the automatic selection of subtitles on the PMS and that changed things. I still have random skipping and buffering issues but not as many as before.

I am also getting skipping and buffering when someone fires up a remote movie and it gets transcoded. An example is my brother in another state starts up a movie from my server. His plays fine but I get random skips and buffers. I need some help finding a direction to start troubleshooting.