Sonos Fails to play anything from PLEX



I am running a dedicated server (QNAP) with my PLEX server on a Win 10 machine. Running a single network drive with audio in it. Plex has finished loading all data and Sonos Win 10 Desktop control shows it but when I select a song or album to play I get a popup error "Unable to play xxxxx - unable to connect to Plex".

I have both FLAC and MP3 files on the drive and nothing works. There is also no album covers showing either.

And it might be important, but I am not running a standard flavor of Sonos (controllers or unit SW).


Moved comment to main entry...


Hi am have the same problem has any one found a fix for this yet??
I have Plex running on a pc and a sonos play 3 it can find all my music but when I try to play a track it comes up with a error unable play or connect both the pc and the sonos are hard wired. Hope this can be fixed


Same exact issue here with a vanilla (brand new) Sonos Connect and Sonos account. Running Plex Media Server locally on Ubuntu. Remote Access is fully enabled and shows a green check mark. Under Network I also set my Custom Server Access URLs to proper values. I also double checked remote access by going to a remote network outside of my router and pointed a browser back at my public server access URL -- works like a charm. Hoping someone has a suggestion here.


I had the same issue where Plex was working fine inside and outside the network. However Sonos would see the Artists and Albums but had the error "Unable to play [track] - unable to connect to Plex". I'm Running Plex Media Server on a Windows PC and the Remote Server was showing the green tick and 'Fully accessible outside your network". I disabled the uPnP on the router and suddenly the Plex tracks started to play in Sonos and the albumart was visible. However Plex was inaccesible outside the network. I deleted the Port forwarding to port 32400 and reset it back up. I also disabled the remote access and re-enabled it. Originally the public port was different to the private (External IP:17721 > Internal IP:32400). After doing the above, the external and internal were both 32400 and after enabling uPnP everything worked fine. Hope this helps somebody


No intention to cross post, but I have developed the "Sonos failing to play via Plex" problem today after a week or so of successful, but slow, performance. Have run through all of the fixes to no avail. Thanks.


I have also tried the fix above that Macbabb mentions. When I get both the internal and external port to 32400 and re-enable uPnP on my router, Plex on Sonos works but I still cannot access Plex outside my network. Any other thoughts?


Any update on this topic? I can either get Sonos to work and not be accessible outside the network, or Sonos stops working and Plex is available outside the network, but not both. Should I just wait until Plex moves out of the beta stage?


Still not working for me


This is a mess my setup has worked for weeks then today it decides it’s “unable to connect to server check remote access is enabled”
What’s that all about ?


Same, Same…

Everything has been dandy, then suddenly my sonos simply wont play anything from Plex.

It has had “Can’t find server”, I log onto my plex account and find my music, although I do realise that music I added to my itunes last week is not there.

So not sure if this is an Itunes problem?? has one of the updates between Sonos, Plex and Itunes cancelled each other?

There is jusy no communication between Sonos and PLex what so ever, on top of that Plex has not recognised my new music.

Something here aint right.


The Sonos app connects to your Plex server via its public IP so you have to have NAT reflection enabled for anything to play. You’ll see all the songs in the list but if you don’t get covers then the audio won’t play either.

I had to manually forward the port on the router and then everything worked. Using UPNP wouldn’t set up the reflection and wouldn’t allow Sonos to connect.

You could also point your Sonos to your Plex Cloud sever if you have one. That seems to work nicely.


You could try using Plex Cloud. It seems to work really well for me and no NAT is needed.


How exactly do you use NAT reflection? And surely not everyone needs to enable this to get Plex to work with Sonos?
Plex haven’t mentioned anything about this and I can only imagine not many know how to do it.

I’m able to forward ports etc for remote playback but struggling to understand this double NAT business if anyone can explain how to enable it? My understanding is that Plex uses your external IP address to contact the server and then Sonos is getting confused with the internal IP address or something along those lines.

Plex Cloud handy but I’d prefer to play my local content.


If you have double NAT then you probably need to resolve that first. Double NAT is just going to cause a whole host of issues.