Sorry I am having trouble accessing your Plex skill right now (Update its gotten worse)

alexa
voice-control

#1

I just set up a pair of music libraries tonight. When I say "Alexa ask Plex to play Music" or "Alexa ask Plex to play " or "Alexa ask Plex to play " all I get for a response is "Sorry I am having trouble accessing your Plex skill right now". I can use Alexa to control playback through Plex or see what is on-deck or start a video. I've set up (although perhaps unnecessarily) port forwarding in my router and can reach my Plex server from outside my network and stream music outside my network.

I really want to be able to play music from my Echo Dot any help would be appreciated.


#2

Ha. I just replied to your reddit post and then saw you posted here as well. Just to be clear remote access is required because Alexa skills run in the cloud so our code isn't local to your PMS.

The error "Sorry I am having trouble accessing your Plex skill right now" usually indicates a problem with Amazon accessing our cloud server where the skill lives. It's strange to me that you can use the remote functions but not music playback. An echo playback failure usually manifests in silence. I'll poke around and see if anything obvious jumps out on our end. If not I'll have to run this by a contact at Amazon.


#3

Thanks, I appreciate you looking into this and hope to have it working soon. Let me know if there is any information I can provide.


#4

I'm experiencing the exact same issue as well. I recently purchased a 2nd Gen Echo and have been trying to trouble shoot the issue still unable to play music. I've been using plex for over 3 years with no issues on multiple devices. Alexa works great when I tell it to start a movie, pause, resume or suggest a movie but when i ask it to tell plex to play any music I get "Sorry I am having trouble accessing your Plex skill right now". I've re-installed plex as well re-enabled the plex skill, also rolled back to a version I read that works for others which was Ver. 1.10.0.4523, still didn't work. Even though I can watch plex outside my network perfectly without having to manually do port forwarding I created a port forwarding rule anyway on my router using port 32400 and enabled NAT Loop-back but didn't resolve anything. Plex still works fine after re configuring my router, so not sure what else I can do to get music playback. Any suggestions would be greatly appreciated since its the only way I can stream my personal music library across multiple rooms in my house using voice control through my Echo and Sonos.


#5

I don't suppose there is any update on this issue?


#6

Well I have an update - it has gotten worse. Now I get that message regardless of what I ask it to do. It is very disappointing.


#7

Huzzah - it looks like the update has fixed it and everything is working now :smiley:


#8

We shipped a hotfix release late Friday to address users who had remote PMS connections that didn't work. In some cases there was a working address but we picked the wrong one. This hotfix adds a layer of intelligence to the connection picker so we always pick the right one or tell the user what's wrong if none of them work.