“Sorry, I’m having trouble accessing your plex skill right now”

alexa
voice-control

#1

not sure what's wrong but everything but "Alexa, Ask plex what's OnDeck", just gives me “Sorry, I’m having trouble accessing your plex skill right now”

Ondeck does report what on deck, but nothing seems to work ?


#2

Im getting the same as well


#3

I just enabled the skill and it's working great. I've seen skills take a while to work if there's a demand on the server. Hopefully that will even out for you and you can enjoy telling Alexa to play your media.


#4

I use a VPN on my machine which plays with remote access, when I turn the VPN off it works, but id rather keep my VPN on. I can still connect externally with the VPN on, just not use Alexa. Any ideas?


#5

I am getting the same message. I was able to choose the default server and player without any problems. But with every command I give, I get that same response about having trouble.


#6

I'm also getting this problem. I have attempted to remove the skill, de-activate the device and then re-run though the setup process again on the Echo. Then re-enable the skill, still the same result. I'm using an Echo Dot, other skills are working fine. Shall test later on encase of server issues outside of my own environment.


#7

I too am experiencing this issue. Often, when I repeat, it works the second time. It's working pretty well for the most part for a first release.


#8

I am also having the same problem


#9

the Issue is occurring consistently (1:35pm EST). eRmoving and restoring the skill did not help.


#10

I'm having the same problem sporadically as well (using an Echo Dot and Apple TV).

The Continue Watching and On Deck stuff seems to be working well for me but asking for recommendations does not work at all.


#11

On the very rare occasion I can get Alexa to work with Plex at all, I still get this message as a response.

Alexa ask Plex to play movie X
Movie x starts
"Sorry, I’m having trouble accessing your plex skill right now"

My other experiences with Alexa over the 6 weeks I've had an echo dot pretty much match this. Voice recognition is very poor so the intents are never triggered accurately and the lambda that backs up the skill has no chance.


#12

@earthbound said:
On the very rare occasion I can get Alexa to work with Plex at all, I still get this message as a response.

Alexa ask Plex to play movie X
Movie x starts
"Sorry, I’m having trouble accessing your plex skill right now"

My other experiences with Alexa over the 6 weeks I've had an echo dot pretty much match this. Voice recognition is very poor so the intents are never triggered accurately and the lambda that backs up the skill has no chance.

If you have issues with Alexa going on for 6 weeks, you might want to contact Amazon and get a replacement.


#13

still getting this, alexa working for other with no issues, but this error make Plex Alexa pretty useless.


#14

This is happening for me as well.

I have found that I can issue transport control commands, and I can switch servers and players. But seems that when I try any more complex commands (like 'whats on deck' and 'play xx') I get this message that Alexa cannot communicate with the skill.

Does Alexa have to communicate with my Plex server from the internet for these requests, or does it do it locally? If its from the web, it could be my firewall that is causing the problems.. is there any documentation on this?


#15

Try Askiung her to change your default player, it's one of the list of commands she understands. I had a similar problem and that's when I worked out my player did not appear to be the latest one and you need a player that has the Advertise as player setting in it I think. Once I updated everything and restarted my browser it worked. Same with the Roku had to restart that and make sure it was all up to date.

So now when I ask to change the default player and the Roku and my browser are both connected to the plex app it gives me a list to choose from.

If yours doesn't give you a list then that could be the problem. If it does then most likely the device may not support hte new commands yet.


#16

I have done some playing around, and just as I though in my last post.. the information for the more complex commands is obtained from the cloud, not locally. Where the transport and player discovery commands operate locally, not from the cloud.

I opened up my firewall, and allowed all traffic to access my Plex server. Once this was done Alexa was able to suggest movies, and play specific shows on request without this annoying message. However, when I enabled my restricted rules on the firewall again I got this behaviour.

The rules that I have setup allow me remote access to my Plex library from specific countries, and I also have a list of amazon IP addresses (which I obtained from here: https://ip-ranges.amazonaws.com/ip-ranges.json). I don't know why Alexa cannot communicate with my Plex library when I have these rules enabled. But this is an issue I need to figure out with my firewall rules I guess.

Hope this information helps!


#17

For anyone who is also stuck with firewall rules, I have found that the commands to process the more complex Plex commands from from DigitalOcean servers - Not the Amazon cloud.

You can find the IP addresses for DigicalOcean here: https://myip.ms/browse/ip_ranges/1/ownerID/38903/ownerID_A/1


#18

What ports are required?
I have my TLS port open to all of the internet which allows remote viewing from anywhere, (I am using port 443) but that doesn't seem to be enough for Alexa integration.


#19

Its communicating directly to your Plex Server, so you need to open port 32400 (unless you are using a different port for remote access)


#20

ok days later and still the same, I think this should have been marked as BETA, as atm it is pretty darn useless, no commands working very well at all.

come to the conclusion it not worth the hassle, quicker and more reliable to just use a remote :D