Sorry! Something went wrong - Newest Chromecast Update

chromecast

#1

Hello,

The newest Chromecast update doesn't work with Plex. I can't stream anything from Plex at all. I tried streaming directly to another Television and Apple TV and it works perfectly, so it must be Chromecast. I've found numerous people claiming the same issue on Reddit. Anyone else having the same issue and are there any workarounds that anyone knows of?

Thanks much.


Chromecast says: “Something went wrong - the transcoder failed” and sometimes it shows and “Error code: h4 (codec)” when streaming with subtitles
something went wrong H4 codec
#2

This is what happens when I try to stream anything from Plex via Chromecast. 1st Gen and 2nd Gen Chromcast having the same issue. The latest Chromecast autoupdate definitely broke it.


#3

I’m seeing something very similar. Would your entire collection happen to have been encoded the same way? And is it different from your friends?

As a complete guess… I think that Chromecast has changed what types of media it supports, and there is some miscommunication between PLEX and Chromecast for some of the transcoding targets.


#4

I am having the same message appear. Each time I try to cast to a TV Box (GoogleFiber) through Plex iOS or on Chrome the ‘Sorry! Something went wrong’ pops up. Twitch and YouTube cast without issues.


#5

Channel support with HLS is currently not supported on Chromecast. We’re looking into it.

Are you all using channels here, or is there local content that is also not playing?


#6

Everything I’ve tried to stream is local content. I get the “Sorry! Something went wrong” message.


#7

@jabadoo that’s interesting. Could you please send me a sample?


#8

Hi Guys,

I’m having an issue which sounds very similar.

I’ve got a film which I watched before the update, through plex and Chromecast app.

I tried to watch it again last night and now it comes up with Sorry! something went wrong.

It’s strange as it seems to work for some movies but not others? The file format are all MP4’s so I can’t see that being the issue?

The file works when using plex on a mobile or laptop, just not through Chromecast.

Let me know what you need to get to the bottom of this and I’ll try and send it though.

Thanks

James


#9

The file format are all MP4’s so I can’t see that being the issue?

It could still be the contents of those files. The audio and video codecs used, or other properties of the streams, can cause issues.

Small samples that exhibit the issue are welcome! https://support.plex.tv/articles/201035968-generating-sample-files-from-media/


#10

It seems to be working now so thought I’d update incase anyone else has the same headache.

I use a WD Cloud NAS. I’d already tried to uninstall and reinstall the app to see if this fixed the issue. It’s didn’t.

I then logged into the Plex configuration, realised there was an software update available there. Ran the update and all seems to be good now.

I know, I know… Update the software! but I assumed the auto uninstall and install would automatically give you the latest version… I was wrong.

Anyway this might help someone else with the same headache.


#11

I’ve determined that all video files with 5.1 audio do not stream. All vids using 2.0 aac audio stream just fine.

The problem is 80% of my content is 5.1 audio.


#12

I’m having exactly the same problem.

The files are served from Seagate and WD mounted drives to an NVIDIA Shield server. Never had an issue with it until Friday night after the latest update. Now nothing that I try to cast to Chromecast (original not ultra) works - I just get the Sorry! Something went wrong error.

Most of my files are 5.1 / DTS audio. I’ll see if I’ve got anything that’s 2.0 and will try it.


#13

When we tested downmixing 5.1 to stereo we didn’t get any issue, so I’m confused and worried. If it was downmixing before, I’m curious if we are getting our checks on transcoding from a NAS wrong.

Please can you send me an offending file/sample, and I’ll try and reproduce over here? Thanks!


#14

Ok, here is a sample. Thank you.


#15

I had also some isues with chromecast. Movies startet to buffer constantly at randome points and server recources where OK. I fixed it with a factory reset of my chromecast. And now it shows the album arts again what it didn’t do before.


#16

I am having the same issue where local files will not play but only on Android 7. I have a Galaxy S9 with Android 8.0 and it works with no issues…


#17

I have the same issue from Android (LG G5) from Plex Cloud. It’s not the files, files that played fine before the Chromecast update don’t any more. I had a brief period where two files played, then they stopped.


#18

I’ve raised an issue internally with the two samples I’ve now got. We’ll take a look.

Content not on a transcoding capable PMS that requires a transcode to play on Chromecast will no longer be transcoded by another PMS - so you may be seeing this when playing from Plex Cloud


#19

I can confirm that my all my Chromecasts have stopped streaming anything from my local Windows based PLEX server. All was working perfectly until latest update. Getting the “Sorry, something went wrong” message. Interestingly remote content streams fine from my brother’s sever across the pond.


#20

At the risk of banging on about it, samples and logs are the most helpful thing here. Thanks!