Sort Title Modification

server-mac

#1

I've been a user of Plex since 2012. I've never had an issue with categorizing and or modifying titles of movies for purpose of where they show in my collection. Meaning, for example, if I have ten movies with Bruce Lee in them in a section named Trilogy, I set the sort title to Bruce Lee (for all Bruce Lee Movies) and based on the year of the movie release, all movies will fall in line based on when they were released and they will show in one section (alphabetically) within Plex under the sort name Bruce Lee. That methodology for sorting has worked for years, but with the recent update (Version 1.9.0.4252) I noticed that everything has been reset to default names. So, even though I set the movie "Bruce Lee The Big Boss" to sort on the title "Bruce Lee" it's now renamed itself back to "Bruce Lee The Boss" and therefore isn't showing in the same section as other Bruce Lee Movies. Any idea of what is going on? I have over 3,000 movies in Trilogy and all of them have renamed themselves back to the default sort title name so, my collection is once again a mess. I have basically lost 40 or more hours and will need to go through the collection again cleaning it up. Why is this happening?


#2

Does anyone else experience this issue?


#3

I would be carefully looking at your agents, order from top is critical. In this case Movies.


#4

Thanks for the reply, here’s how mine is setup. I want the movies to be named based on local titles set within the sort title field. Hope that makes sense.



#5

To me it sounds like the other agents are over riding. I would be tempted to try terminating all other agents to see what happens.


#6

Each Library can be made specific to your settings via the Library advanced settings in “Home screen”


#7

Thanks! I know about tweaking each library. I did go in and confirm things were set correctly. I don’t get it. Something has changed with Plex through an update or something. Ideally, I’d for when I add movies for the Movie Scanner to look up the movie through the database I selected then, render it’s metadata. At that point, I want the final tweaking so if I want to rename the sort title for a trilogy, all movies in the trilogy will show up in the order they were released. For example, I have all of the Friday the 13th movies. They have titles all over the place so in theory, they would be all over the library. If I rename the sort title to Friday, that will allow for all of the movies to show in the same area of the library based on their released dates. That’s methodology has worked for over 3 or 4 years that I have been using Plex. Today, I can spend hours renaming sort titles, saving, etc, but any time that library gets refreshed, all the sorted titles go back to default. These are not MP4 files with hardcoded movie data. These are MKV files. It worked flawlessly historically. Today, not so much, if at all.


#8

@“Mr. BattlePlex” said:
Thanks! I know about tweaking each library. I did go in and confirm things were set correctly. I don’t get it. Something has changed with Plex through an update or something. Ideally, I’d for when I add movies for the Movie Scanner to look up the movie through the database I selected then, render it’s metadata. At that point, I want the final tweaking so if I want to rename the sort title for a trilogy, all movies in the trilogy will show up in the order they were released. For example, I have all of the Friday the 13th movies. They have titles all over the place so in theory, they would be all over the library. If I rename the sort title to Friday, that will allow for all of the movies to show in the same area of the library based on their released dates. That’s methodology has worked for over 3 or 4 years that I have been using Plex. Today, I can spend hours renaming sort titles, saving, etc, but any time that library gets refreshed, all the sorted titles go back to default. These are not MP4 files with hardcoded movie data. These are MKV files. It worked flawlessly historically. Today, not so much, if at all.

Did you ever find a solution to this issue? I’m having the same problem.