Sound disappears when subtitle is displayed.



Dear all,

I have a Cambridge Audio blueray player 752BD which is DLNA compliant. The player is connected to the LAN (cat6 fixed cable) and has a fixed IP address. It is as well connected to a beamer using HDMI.

My films are located on a QNAP fileserver on the same LAN. All files are ripped the same using DVDfab to MKV (contains Audio and Video) with external SRT subtitles in three languages, Dutch, English and Portuguese.

Files are stored in subdirectories ie. H:\The Matrix Reloaded (2003). Files are named according to Plex naming standard ie. The Matrix Reloaded (2003) - 426p.mkv and The Matrix Reloaded (2003) - Etc.

I am running Plex Media Server v on dedicated server Windows 10 pro on the same LAN. Plex preferences are Dutch subtitles with English audio. DLNA server is enabled and the Azur player is able to browse through the library structure, like 'Most recently viewed' which is better than going through an endless list of films.

Other clients on the network are using the Plex apps for LG, iPhone, Windows and iPad. All devices using the apps can use the subtitles and have sound.

Except for the Azur player using DLNA.

Now: I can also access the files stored on the QNAP directly from the Azur player. I then get a long (very long!) directorylist where I can select The Matrix reloaded.
Playing the film I can select subtitles and audio language with the remote control of the Azur and all plays fine.

When connecting the Azur player to the Plex DLNA server with the standard generic profile, I have video and sound, but no subtitles. As expected.

So I created a special DLNA profile for the Azur player which binds successfully to the device.

Then the really strange part happens: whatever I do, I have or 'a film with *Dutch * subtitle but no sound' or 'a film with sound but no subtitle'.

This is the profile:
<?xml version="1.0" encoding="UTF-8"?>

<!-- v1.0.0 - Met dit profiel een Nederlandse ondertiteling (SRT) -->
<!-- Profile tested with Plex Server Version:         -->
<Client name="AZUR BD 752BD">
    <!--                                    -->
    <!-- 20180111 / Identification improved -->
    <!--                                    -->
        <Header name="User-Agent" substring="AZUR BD PLAYER"/>
        <DeviceDescription type="urn:schemas-upnp-org:device:MediaRenderer:1">
            <ModelName substring="Azur" />
            <ModelNumber substring="752" />
            <ModelUrl substring="cambridge-audio" />
            <ModelDescription substring="Azur Media Renderer" />
            <Manufacturer substring="Cambridge" />
            <ManufacturerUrl substring="cambridge-audio" />
    <!-- 20180111: Profile succes from :  C:\Users\...\AppData\Local\Plex Media Server\Logs\Plex DLNA Server.log   -->
    <!-- Jan 11, 2018 13:58:43.126 [0860] DEBUG - Device C-002-752BD at will use AZUR BD 752BD profile -->
        <Setting name="TimelineBufferOffset" value="10"/>
    <!-- Transcode targets -->
    <!-- 20180111: VideoProfile works in directstream -->
        <VideoProfile container="mkv" codec="h264, mpeg4" audioCodec="aac,ac3" subtitleFormat="srt" > 
<!--        <VideoProfile container="mkv" codec="mpeg4" audioCodec="mp3,flac,vorbis" subtitleFormat="srt,''"> -->
            <Setting name="SubtitleSize" value="150"/>  
<!-- Direct play section - Sound but no subtitle as expected - v1.0.10 -->
<!--        <VideoProfile container="mkv" codec="h264, mpeg4" audioCodec="aac,ac3" /> -->
<!--        <VideoProfile container="mkv" codec="h264, mpeg4" audioCodec="aac,ac3" subtitleFormat="srt,''" /> -->
<!--        <VideoProfile audioCodec="aac,wma,mp3" codec="mpeg2video,mpeg4" container="mpeg"/> -->
<!--        <VideoProfile audioCodec="ac3,mp3,aac" codec="hevc,h265,h264" container="mpegts"/> -->
<!--        <VideoProfile audioCodec="aac,ac3,mp3,pcm" codec="hevc,h265,h264" container="mp4"/> -->
<!--        <VideoProfile audioCodec="aac,pcm" codec="h264" container="mov"/> -->
<!--        <VideoProfile audioCodec="mp3,pcm,ac3" codec="mpeg4" container="avi"/> -->
<!--        <VideoProfile audioCodec="aac" codec="h264" container="flv"/> -->
        <MusicProfile codec="mp3" container="mp3"/>
        <MusicProfile codec="aac" container="mp4"/>
        <PhotoProfile container="jpeg"/>

Please note that all lines that are outcommented are on purpose, to make the profile as small as possible to focus on the transcoding.

Now, the transcode log says:

SessionReport version="2" startTime="0" startTimestamp="Jan 11, 2018 15:22:39.748" key="/library/metadata/341" transcode="c1e34cc88670e17967a7dafde22ac5bed5b1a137">
<User id="1" thumb="" title="mahu64" />
<Player address="" device="AZUR BD 752BD" machineIdentifier="" model="" platform="" platformVersion="" product="" remotePublicAddress="" state="" title="" vendor="" version="" local="0" userID="1" />
<Variant id="7081e988-fa47-4150-b484-3f6a7d22309e" targetBitrate="17188" context="streaming" sourceVideoCodec="h264" sourceAudioCodec="ac3" **videoDecision="transcode" audioDecision="copy" subtitleDecision="burn" **protocol="http" container="mkv" videoCodec="h264" audioCodec="ac3" audioChannels="6" transcodeHwRequested="0" transcodeHwFullPipeline="0">
<Media id="462" videoProfile="main" audioChannels="6" audioCodec="ac3" bitrate="16369" container="mkv" duration="7954520" height="426" videoCodec="h264" videoFrameRate="PAL" videoResolution="480p" width="1024" selected="1">
<Part accessible="1" deepAnalysisVersion="2" exists="1" id="462" requiredBandwidths="29238,25425,20461,16212,16212,16212,16212,16212" videoProfile="main" bitrate="16369" container="mkv" duration="7954520" height="426" width="1024" decision="transcode" selected="1">
<Stream bitrate="15985" codec="h264" default="1" frameRate="25" height="426" id="2387" requiredBandwidths="28856,25041,20076,15850,15850,15850,15850,15850" streamType="1" width="1024" decision="transcode" location="direct" />
<Stream bitrate="384" bitrateMode="cbr" channels="6" codec="ac3" default="1" id="2388" requiredBandwidths="384,384,384,384,384,384,384,384" selected="1" streamType="2" decision="copy" location="direct" />
<Stream burn="1" id="2402" key="/library/streams/2402" **language="Nederlands" languageCode="dut"** selected="1" streamType="3" decision="burn" location="direct" />
<Segment duration="4400" startOffset="0" endOffset="4400">
<File name="chunk-00000" type="av">

Please note that the audio codec 'ac3' is directly supported by the player. If I use a non/supported format, the player will give an error message and not play the video. I also used the profile as 'DirectPlayProfile' and it worked fine, both audio and video.

The only way Plex can 'automatically' select the Dutch subtitle is imho because of the preferred subtitle. Even if I totally omit the subtitle section in the Transcode section, like:

        <VideoProfile container="mkv" codec="h264, mpeg4" audioCodec="aac,ac3"  > 
            <Setting name="SubtitleSize" value="150"/>  

I still get the Dutch subtitle, without an option to choose another one (using the remote, no options are there). Which is logical, because the transcoder burns the subtitle in the video stream.
But no sound, though the log implies that the transcoder is copying directly.

Any ideas?

Best regards,


Dear all,

The issue is resolved. By INCLUDING the SRT files into the MKV, the subtitles are displayed using the DLNA client. This way the Azur player is able to select the subtitles using the remote control as well as the other clients.

For this transcoding is not necessary/needed. A DLNA client profile seems not needed as well (I will come back to that).

The only thing I have to do is change all films.

Now - as far as I am concerned - I am not very happy how Plex handles this. First I had to transform all SUB/IDX formats to external SRT to enable all clients (otherwise the CPU would die by transcoding). Now, I have to include all the SRT´s into the MKV´s.

I am not impressed.

All the best,