# SQLITE3 Errors - "There was an unexpected error loading the dashboard"

**URL:** https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911
**Category:** General Discussions
**Created:** [July 3, 2017, 5:16pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911 "2017-07-03T17:16:49Z")
**Posts on this page:** 10
**Page:** 2

<div class="post-metadata">

### Author: ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)
#### Post date: [July 17, 2017, 3:04pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/21 "2017-07-17T15:04:45Z")

</div>

Look here. This was just posted

> **[Server Dashboard crashing.](https://forums.plex.tv/discussion/comment/1479621#Comment_1479621)**
>
> Ok guys, it seems i might have done a diskcleanup at some point where it deleted the temp folder “(C:\\Users\\ADMINI~1\\AppData\\Local\\Temp\\1\\etilqs\_JznenbxkqZg8wdK) - The system cannot find the path specified.” i repaired the database with the SQL tool...

---

<div class="post-metadata">

### Author: ![EricnM](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ericnm/32/8413_2.png) [@EricnM](https://forums.plex.tv/u/EricnM)
#### Post date: [July 17, 2017, 4:05pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/22 "2017-07-17T16:05:34Z")

</div>

> @ChuckPA said:  
> Look here. This was just posted
> 
> [https://forums.plex.tv/discussion/comment/1479621#Comment\_1479621](https://forums.plex.tv/discussion/comment/1479621#Comment_1479621)

Thanks ChuckPA! This does seem to be the exact issue as I see some of the same SQLite errors from that post as I do on mine. This mostly likely means if you only RDP into your server for management, you will have issues if you cleanup temp folders/perform a disk cleanup.  
I’m curious what Plex is saving in the %localappdata% temp folders… if these files/folders c an be redirected that will alleviate this kind of issue.

---

<div class="post-metadata">

### Author: ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)
#### Post date: [July 17, 2017, 4:08pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/23 "2017-07-17T16:08:15Z")

</div>

Run Plex server as a system service and this will be a non-issue.

> **[PMS as a service](https://forums.plex.tv/discussion/93994/pms-as-a-service/p1#top)**
>
> This post will always contain the latest version of the Plex service wrapper. This is not official or affiliated with Plex in any way and was originally made for personal use. Treat it as such and please don’t bug the Plex devs about it. (bug them...

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [July 17, 2017, 4:09pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/24 "2017-07-17T16:09:19Z")

</div>

Sqlite3 appears to be using temp files - for some reason only sqlite3,s affected. Zipping the logs also uses temp and I do not believe is failing

---

<div class="post-metadata">

### Author: ![Uh\_Oh](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/uh_oh/32/11983_2.png) [@Uh\_Oh](https://forums.plex.tv/u/Uh_Oh)
#### Post date: [July 17, 2017, 4:13pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/25 "2017-07-17T16:13:30Z")

</div>

If certain channels won’t work while running as a service, this is a no go for me. I use channels all the time. A refresh of the page on the web, or reload of PMP usually restores the dashboard. An annoyance is far easier to deal with.

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [July 17, 2017, 4:16pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/26 "2017-07-17T16:16:54Z")

</div>

Don’t think running as a service is a factor

It is to do with the windows policy discussed here

> <https://stackoverflow.com/questions/6521277/why-does-temp-resolve-to-a-non-deterministic-path-of-the-form-temp-digit>

It is still not known as to why this has become an issue now and whether there has been any windows updates or if it is within plex

---

<div class="post-metadata">

### Author: ![EricnM](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ericnm/32/8413_2.png) [@EricnM](https://forums.plex.tv/u/EricnM)
#### Post date: [July 18, 2017, 3:21pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/27 "2017-07-18T15:21:39Z")

</div>

Running as a service was my next choice to start testing so thanks for the link Otto.

While yes the creation of the temp folders per terminal services session are created, even when I don’t logout of the session that running PMS, somehow that “2” folders get cleaned up during some Plex transaction causing the dashboard again to fail.  
I don’t have any scheduled task that do cleanup or anything so I am assuming the terminal session is somehow doing it or it is plex.

Are there any downfalls to running as a service? Any reason why not too?

---

<div class="post-metadata">

### Author: ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)
#### Post date: [July 18, 2017, 3:33pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/28 "2017-07-18T15:33:37Z")

</div>

> @EricnM said:  
> Are there any downfalls to running as a service? Any reason why not too?

Most of the con’s are mitigated by the [service wrapper](https://forums.plex.tv/discussion/93994/pms-as-a-service/p1#top "service wrapper").  
I understand, even the update process is somehow cared for.

(Normally, installing a new version of PMS will create an entry in the Autorun branch of the Registry. Without the service wrapper, you’d have to remove it yourself so that plex is not attempting to start [a second time] as soon as you log into your Windows account.)  
Using the hardware transcoding abilities is also not possible, currently (but that is only possible with a special preview version of PMS anyway.)

Main advantage (besides the ‘running while no user is logged on’) is that you can create a special Windows user account just for Plex. Then you can tailor its privileges to minimize attack surface and also to protect against malfunction.  
For instances I only allow Plex to write into a few media folders (for DVR and ‘optmized versions’).  
Most folders are ‘read-only’ for Plex on my server.

The same can be done with PlexPy, btw. with a bit of tinkering.

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [July 18, 2017, 3:46pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/29 "2017-07-18T15:46:49Z")

</div>

> @EricnM said:  
> While yes the creation of the temp folders per terminal services session are created, even when I don’t logout of the session that running PMS, somehow that “2” folders get cleaned up during some Plex transaction causing the dashboard again to fail.  
> I don’t have any scheduled task that do cleanup or anything so I am assuming the terminal session is somehow doing it or it is plex.

If this is easily reproducible after a relaunch of plex media server, I would love to have a look at a procmon capture covering period from launch up to time when the temp  
\ folder disappears and the hubs fail to load

So if possible please download [Microsoft SysInternals Process Monitor](https://technet.microsoft.com/en-US/sysinternals/processmonitor.aspx "Microsoft SysInternals Process Monitor") and unzip it and prepare it to use to get a PML file

Enable verbose logging together with [debug logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) in plex media server

Shutdown plex media server

Launch procmon.exe and run as adminstrator capturing all events

Launch plex media server

As soon as the hubs issue arises, stop the procmon capture

Save all events to a PML file and exit

Zip the PML file

Disable verbose logging leaving only [debug logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) in the plex media server settings

Get the plex media [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) zip

Post here and upload the zipped PML on Dropbox or similar service and send me link by private message

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)
#### Post date: [January 7, 2020, 11:29pm UTC](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911/30 "2020-01-07T23:29:16Z")

</div>



[Previous page](https://forums.plex.tv/t/sqlite3-errors-there-was-an-unexpected-error-loading-the-dashboard/197911.md?page=1)
