.srt subtitle still showing after being removed

plex-web

#1

I added a .srt subtitle for a Breaking Bad episode (s04 e06 Cornered).  I've since removed the .srt file and PlexWeb still lists it in the drop down.  Other Plex clients don't see the .srt subtitle.  Steps to try and get PlexWeb to properly remove.

 

  1. Deleted the episode in question

  2. Then ran a deep scan so Plex knew it was gone

  3. Restarted plexmediaserver

  4. Emptied the trash

  5. Copied the episode back to the media location

  6. Ran another deep scan to pick up episode back up

PlexWeb still shows the .srt  This obviously isn't a huge problem, but I'd like to understand and fix the issue if possible.  I've attached the .xml of the episode, and the Media Scanner .log when I ran the deep scan to pick the file back up.  Any ideas?


GZP1W4G.jpg


 


#2

I can't select BUT in this case plex/web shows the subtitle (this is good), subtitle is a .srt file.

Vikings.png

Vikings.S01E07.A.Kings.Ransom.HD.TV.mkv
Vikings.S01E07.A.Kings.Ransom.HD.TV.swe.srt

#3

Is it possible it is cached by your browser?

Maybe the subtitle will disapear if you play the episode with one of your Plex players, the same way you have to play a video to have the subtitle appear?


#4

Thanks for the suggestion.  I've tried a different browser, as well as a different computer.  I've also started to play this episode in PlexWeb and another client and still the .srt is in the dropdown.  I wouldn't need to watch the entire episode for it to disappear, would I?


#5

I wouldn't think so, no...

How about your agents? Did you configure your system to automagically download subtitles?


#6

Hmmm... another issue now.  When I go to check out the agent settings there is nothing there.  I've tried to delete the system.bundle and framework.bundle and restarted PMS - still no dice?

xf73pxG.png

Edit: Agents seems to be missing becasue of the preview release: http://forums.plexapp.com/index.php/topic/66636-new-preview-release-09723/


#7

downgraded to .22 and agent settings are back.  I don't have the opensubtitles.org checked.  Any other suggestions?

iioMSys.png


#8

What platform are you running the media server on? I've heard of issues with agents and 0.9.7.23 on Linux.


#9

What platform are you running the media server on? I've heard of issues with agents and 0.9.7.23 on Linux.

I have the same problem (linux), but after a couple of refresh the setting options are back  :P


#10

I downgraded to 0.9.7.22 and the agents are back - I still however have the (English SRT) subtitile to select even though that .srt file no longer exists.  Only shows up on PlexWeb, not on other clients.


#11

I have the same problem. I renamed one subtitle, added .swe (swedish = svenska) now I can't get rid off the unknown subtitle

subtitle%201.png


#12

I can reproduce the issue with subtitles not being removed correctly. I've made a note of the issue so hopefully we can address it soon.


#13

It’s been more than 5 years yet still no fix for the issue… But at least we have podcasts… I would recommend fixing the core product (movies and tv shows) first, otherwise users will start migrating to a better solution whenever one arises


#14

I stand corrected. On the latest PMS (1.13.2.5142) I triggered Refresh All Metadata on the library and it has removed the references for all deleted subtitles. Still, would've been nice if it was done automatically