Strange behavior with multiple users



When I (as the server admin) play music through the sonos app it works flawlessly 99.9% of the time. but when I use plex through sonos as a different user then sometimes I get the message in the likes of "Sonos have lost connection to Plex" after a 15-20 second delay. or sometimes sonos manages to play 1s flashes of music before either moving on to the next song or display the same message. there shouldn't be anything preventing the user from playing since the user have full access to all my libraries. the user is part of my plex home but is a sepparate user with his own profile.

surely this isn't a NAT issue since it clearly works for my user...

also a minor issue. you can't shut down the playback from the activity field. but if you do the song currently playing crashes after a minute or so and then sonos moves on to the next song in the playlist.


I’ve been trying to read the log files that plex generate when I try to play from the other user.

two things sticks out:

May 10, 2018 16:38:16.164 [0x7f775effe700] DEBUG - Failed to stream media, client probably disconnected after 65536 bytes: 104 - Connection reset by peer


May 10, 2018 16:38:21.832 [0x7f775f7ff700] DEBUG - Failed to stream media, client probably disconnected after 32768 bytes: 32 - Broken pipe

this was an error when only trying to play one song. there is also a bunch of other nonsense that dosen’t seem relevant but I can post the entire log if this wasn’t enough.


Hi @“Karl Blixt” -

For other users in the house, it does sound like a NAT loopback issue. Are you able to access your PMS via your WAN IP:port? The reason it works for you is that, as the server owner, you are able to discover nearby devices such as the Sonos speakers, and the service is routing your playback directly to the PMS via its LAN address. When others access your server, even in a Plex Home, they do so as a shared server and are unable to discover nearby devices and hence playback gets directed to the WAN address.

Not being able to stop playback from Plex Web is a known issue on both Sonos & Alexa. Being a 3rd party client that we’re just handing playback URLs off to we have no control over playback and there’s no graceful way to stop playback. We have a ticket with the web team to hide that option on these clients.


I don’t get it. I sit on my phone on my sonos app where I’ve added my plex account and my fathers plex account. now, all I’m doing is changing what user is the active user for the app. and this somehow breaks the connection to the same phone, the same app.

note that both accounts are fully independent plex accounts with their own log-in and password. yes, his account is part of my plex home, but he isn’t a managed user.

I can literally start a song on my account, swap to my fathers account and 5 seconds later try to start a song that dosen’t work. then swap back and it works as if nothing happened. meanwhile scrolling through the library works like a charm on both accounts.

I can’t access plex through [MY IP]:32400. is this because my router don’t have NAT loopback enabled?


@“Karl Blixt” said:
I can’t access plex through [MY IP]:32400. is this because my router don’t have NAT loopback enabled?

Correct. And if that doesn’t work, that explains why your father’s account can’t play music.

Sonos doesn’t give us any feedback when playback fails, and PMS gives us many connections to choose from. We could blindly pick a local connection, but that’s likely to break as many, or more, users than it helps and we’d have no visibility that it’s happening. If PMS can discover nearby Sonos via SSDP then we know they can see each other and can try to choose a LAN connection for playback. In the case of shared users, though, we can’t see if the Sonos is visible on a LAN connection and default to the WAN address.

I’ve opened a ticket to see if there’s anything we can do on our end to help.


yeah… so I just assumed that my 300$+ mesh router solution from TP-link had NAT loopback capabilities. silly me… apparently a networking company with the word “link” in their name cant make NET loopback work… lmfao. what a joke. don’t ever buy tp-link stuff…

thank you for your answer. Ill stop harrasing you guys and will redirect and intensify my bitching towards TP-Link.