Stream to Plex Cloud and back to Sonos really required?



I did some network analysis to answer my question, why is my Plex access on Sonos so slow. It’s much less responsive than e.g. Apple Music. Hey, my Plex Server (Qnap and Sonos share same local network, most speakers have wired ethernet…

Above I found the URL the Sonos speaker is requesting. As a result it gets a cloud location delivered from a public Plex server (
When I filter than I see all the streaming content on my internet Interface! This answers my question why Plex on Sonos is so slow for me…

So my next question is:
Is this upload to cloud and re-download to local an intended behavior or a configuration issue?



The actual music doesn’t go through Plex cloud servers (unless you have a Plex cloud server that is handling your music library).

Data provided to your Sonos speaker about your music library - the artists, albums, songs, playlists, etc. - is retrieved from your Plex server and formatted for Sonos by the server. As soon as you go to play a song, it is streamed by your Sonos speaker from the Plex server.

If the Plex server you’re playing from is in the cloud, then it will stream from the cloud.

If your Plex server goes through the same router as your Sonos speaker, your router will, if it knows how to, “hairpin” the connection without using the WAN connection (some people have routers that can’t do this, and thus have problems playing music via Plex on Sonos).

As an example, while I was playing a song through Plex for Sonos, this is the active connection my router was showing for my Sonos speaker after a couple of minutes passed (to give the connections time to expire). Note that this is on the LAN interface, and it shows a connection to my WAN IP address (in parentheses, partially obscured) and the port I’m using for Plex. If it were using my internet connection, there would be an additional state on the WAN interface for the internet-based connection. My router (pfSense) is smart enough to know that this connection is to its own WAN address, so it keeps the connection internal and doesn’t use the internet connection in any way.


After months of not having sonos and plex working, I saw a post suggesting a $35 Google Chromecast Audio device as possible solution to have my music play from Plex through my whole house audio system. Within minutes I was able to use Plex without all the complicated “hairpin” issues, etc. It’s pretty elementary but it works. I guess I’ll just wait for sensible solution for Sonos and Plex. It’s a shame since I really like the Sonos capabilities and UI connected to Plex. Meanwhile, it would be nice if someone from Plex responded to anyone on this issue. If I’m not looking in the right place, please, someone let me know. Thanks ....


finally I found a possible incompatibility/bug on Plex side and a solution for me.
First I was not able to reproduce the “Relay” case of my initial post because yesterday when I want to reproduce my Plex on Sonos stopped working at all. Formerly It was slow but working somehow.
After some research I have found hints in a new network trace. I captured now a lot of “TSLv1.2 Encrypted Alert” flagged packages between local Plex server and a public Plex server. Yes I was using a own cert but it was working all the time? (It’s not expired)
Surprise, when I have removed my custom certificate from Plex (Server settings: Network) Plex on Sonos was working again immediately. Not only working again it also feels much more responsive!
A new capture confirms: Now I get actually a content location which points to my public IP and not a Plex cloud server:

My router supports NAT Loopback/Hairpin, I don’t capture any streaming content anymore on the routers internet interface!

From my observation above Plex for Sonos is not compatible with a custom certificate. Why it was working formerly I cannot tell (at least relayed). Maybe Plex did recently some changes on their server protocols? Did they disabled Relay for Sonos? I don’t know.