Stutter/lag on ATV

apple-tv

#1

Upgraded to ATV 4K, because I thought that the "old" wasn't powerful enough.
The problem is that many of my video is stuttering/lagging every 2-5 seconds for a few milliseconds.
All my content is MKV from DVD or Blu-ray.
I installed a new PMS (Windows 2012 R2). Old one is WIndows 7 32 bit. Same issue.
I have tried both wifi and cable on ATV. Same issue on both.
No problem om iPad pro or on web-player.
I have also on PMS tried to optimized to several other versions. I have tried Custom - iOS and Original Quality.
Same issue on all.

I have tried to change most settings on PMS and ATV, but same issue every time.
The one I try on now is a TV-show ripped from DVD.
Anyone have any idea what to try next?


Media Info:

Media
Video Resolution 576p
Duration 18:32
Bitrate 4398 kbps
Width 720
Height 576
Aspect Ratio 1.78
Container MKV
Video Frame Rate PAL
Video Profile main

Part
Duration 18:32
File (removed).mkv
Size 582.98 MB
Container MKV
Indexes sd
Video Profile main
Codec MPEG2VIDEO
Bitrate 4014 kbps
Language English
Anamorphic 1
Bit Depth 8
Chroma Subsampling 4:2:0
Color Range tv
Frame Rate 25 fps
Height 576
Level 8
Pixel Aspect Ratio 64:45
Profile main
Ref Frames 1
Scan Type interlaced
Width 720
Codec AC3
Channels 5.1
Bitrate 384 kbps
Language English
Audio Channel Layout 5.1(side)
Sampling Rate 48000 Hz
Title Surround 5.1
Codec VOBSUB
Language Norsk
Codec VOBSUB
Language English


#2

There is a special 1.9.6 version on this board that allegedly fixes atv4 stopping and stuttering .


#3

Thank you, but unfortunately this version did not solve my problem.


#4

The shuttering + introduction of artifacts is a real problem. There are a bunch of threads about this.

If you are remuxing anything to the Apple TV there is a good chance this will happen. (it doesn't just effect the Apple TV either many other platforms) Basically is has something to do with the frame rate when remuxing, it only happens to specific movies and happens at the exact same points in each movie. The developer on another thread responded saying that this basically is not an easy fix if it can be addressed at all.

So you are really left with one option and that is to transcode. Interesting enough the reason why the issue disappears when transcoding is because it forces the frame rate. I tried using FFMPEG to manually remux one of my files and the same issue occurs on the MP4 file contained in the MKV container so I suspect that many other plex like applications have this issue.

Now what they really need to do if fix the Apple TV Plex app so that it will play optimized versions before original so I can get around this issue assuming you are pretranscoding.

So unless Apple somehow starts allowing playback of MKV containers then you are stuck transcoding because remuxing is not reliable for all titles.


#5

I only have mkv files on my server. No transcoding. I just wish the player would cache because sometimes it stops to buffer.