Subtitles - Out of Sync

apple-tv

#1

Subtitles (.srt muxed in the original file) are inadvertently delayed by a couple of seconds and therefore out of sync when played by the PMP version 1.24 on AppleTV (Model A1625) running the latest tvOS 11.2.6
This just started happening after updating the Plex Media Server (Mac) to the newest version (Version 1.11.3.4803)
I've checked all server and media player settings and everything is intact
I've checked all subtitles and they are perfectly in sync when played through PMP on the server, but out of sync when the same file is played on PMP on AppleTV
Any assistance is appreciated
Thanks!


#2

TV show subs on my Apple TV app are all out of sync… if I play the same files on a Samsung TV app, they sync fine. I think the Apple TV app has bugs.


#3

I’m having the same issue, apple tv plex plays subtitles out of sync, android tv app plays the same substitles in sync, my browser (chrome) also plays everything in sync… Plex probably just needs to update the app for apple tv.


#4

Its something wrong with Plex app for ATV. I can’t even stop direct play and HW transcode.
I had to revert to version 1.21 (7688) to stop the ability for HW transcode and then the subtitles is in sync


#5

Edit: nevermind, noticed that this is a recent thing


#6

Yep. Me too. Since latest PMS update subs are out of sync but are fine on vlc on my Mac. Hope they address this quick as have to have subs on all the time.


#7

I’ve found a temporary fix to the problem.
If you change the Burn Subtitles setting to ALWAYS instead of AUTOMATIC under advanced section in the PMP App on AppleTV the subtitles are back in sync


#8

Having the same issue with all subtitles being out of sync. Only happens on the ATV out of all my players. Started happening with the latest server release.


#9

This ‘accepted answer’ fixed my problem. So grateful! We’d been intermittently dealing with it for a couple months. Thanks!


#10

The “accepted answer” is not a fix, it’s a workaround. Is anyone actually trying to fix the issue? Should be pretty easy to do a RCA since the issue seems to be prevalent and well defined.

I’m happy to provide whatever logs and debugging info that is needed to fix it and/or be a guinea pig for any fixes.

To clarify, while it’s good that there is a workaround, it’s causing a “waste” of resources since setting the subtitles to always be burned in will force Plex to do transcoding even when it otherwise wasn’t necessary. This is bad for us whom run PMS on weaker hardware.


#11

I agree with BeyondEvil - the accepted answer is not a fix - the reason we use SRTs is so that we don’t have to transcode and burn subtitles onto the video. Also, this is not an option for high-bitrate 4k HDR video - my Quad-core i7 Plex server can’t handle all of that transcoding on the fly. Nevermind most people’s underpowered servers.

Sounds like this used to work - so PLEASE fix this!


#12

Add me to the list of people experiencing this exactly as described above.


#13

I am also having this problem. Works great on my Nvidia Shield, but not on the ATV4K.
Please fix this!
I got a movie in 1080p Mp4 (h264) with srt-subtitles, and in that movie the subtitle is in sync.
But a 4k HDR MKV (h265) the subtitle is out of sync.


#14

@“skeandreas@gmail.com” said:
I am also having this problem. Works great on my Nvidia Shield, but not on the ATV4K.
Please fix this!
I got a movie in 1080p Mp4 (h264) with srt-subtitles, and in that movie the subtitle is in sync.
But a 4k HDR MKV (h265) the subtitle is out of sync.

@elan I also have the same problem.
Both iOS and TvOS are affected by this bug!
Use the latest PMS + latest Plex iOS or tvOS client to direct play H265 10bit video and enable SRT subtitle, you can reproduce this problem 100%.

My temporary solution:

Rollback Plex Media Server version to 1.10.1.4602
This version of PMS does not have this problem, and all versions after this version number have this problem.

1.10.1.4602 no this feature:
Support HDMI frame rate and dynamic range switching on the Apple TV 4K

I guess the addition of this feature has caused this problem. I hope Plex development team are trying to fix it.


#15

Same here, affects only x265 files.
Please fix the problem!


#16

Never mind


#17

Any updates on this? As some of u pointed out, the accepted answer is not a solution.


#18

Same here, same problem, burned subs in always fixed it for now but I’m already walking to infuse direction… Please fix this!


#19

I have this problem too, please fix it!.
The solution, which is to burn the subtitles always, is unacceptable, especially when playing 4 k content, this causes transcoding instead of direct streaming and playback performance goes to hell after that


#20

I have all that problems too, so I just bougth Infuse 5 that worked a lot better than plex and solved all the problems.
I recommend for you that have an apple tv.
Sorry Plex but you gonna loose some customers.