Sync run slow , by mistake through the WAN interface.

windows-store-app

#1

I have the same problem:

@martinbaines said:
I have an up to date Plex Media Server running on a Linux server. I can sync with no problem to my Android devices. Sync is horribly slow to the point of being useless.

Conversion completes okay, then transfer starts. Monitoring network usage, the speed looks suspiciously identical to what the uplink speed would be on my ADSL connection (which is slow being in a rural area). After a while the app then usually fails with ""tranfer failed, network error" at some point long before a single transfer has copied over.

Network access from the server to the PC works just fine with files regularly copied each way.

As another data point, I just tried playing "live" from the server, and got a message my connection was not fast enough for the content. That also implies it is somehow trying to go over my uplink and not doing direct play. Direct Play works just fine on my Smart TV (on the same network) and other forms of file transfer from the PC happen at a decent rate.

What is going on?

from this https://forums.plex.tv/discussion/278943/sync-very-very-slow-and-regular-fails#latest

Media server v1.7.6.4058
Windows app 3.2.20-25990c77

i've tried to edit the server settings on the app, but there is no way.
i've tried to set in plex advanced network settings the local LAN address follow this https://support.plex.tv/hc/en-us/articles/200430283-Network but nothing.
is there any way to "force" sync through LAN interface?
is there any update for this problem?
Thanks, bye.


#2

If you have DNS Rebinding Protection active this would be the expected behaviour.


#3

In my router I can exclude some domain from the rebinding DNS protection, should i exclude plex.tv?


#4

You should exclude plex.direct as stated in https://support.plex.tv/hc/en-us/articles/206225077-How-to-Use-Secure-Server-Connections


#5

Excellent, after excluding plex.direct from DNS Rebinding Protection now the plex uses the LAN interface for synchronization, thank you really bro.


#6

Anyone know how to do this with a TP-Link router?