# Synology package thread

**URL:** <https://forums.plex.tv/t/synology-package-thread/10450>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [August 12, 2011, 9:29am UTC](https://forums.plex.tv/t/synology-package-thread/10450 "2011-08-12T09:29:08Z")\
**Posts on this page:** 20\
**Page:** 5

<div class="post-metadata">

**Author:** ![smedberg](https://avatars.discourse-cdn.com/v4/letter/s/c6cbf5/32.png) [@smedberg](https://forums.plex.tv/u/smedberg)\
**Post date:** [August 26, 2011, 9:59am UTC](https://forums.plex.tv/t/synology-package-thread/10450/81 "2011-08-26T09:59:14Z")

</div>

I found the problem.  
  
  
  
The Mac file service has to be enabled on my Synology.  
  
The file /usr/syno/avahi/services/pms.service don’t get populated when the above service is disabled.  
  
Avahi outputs this error: XML\_ParseBuffer() failed at line 1: no element found.  
  
Failed to load service group file /usr/syno/avahi/services/pms.service, ignoring.  
  
  
  
I don’t think the Mac service should have to be enabled since the avahi-service is running but with faulty config. Bug?  
  
  
  
When enabled it will be populated with

```auto

<service-group><br />
<name>NAS01</name><br />
<service><br />
<type>_plexmediasvr._tcp</type><br />
<port>32400</port><br />
</service><br />
</service-group><br />

```

---

<div class="post-metadata">

**Author:** ![quorumz](https://avatars.discourse-cdn.com/v4/letter/q/cdc98d/32.png) [@quorumz](https://forums.plex.tv/u/quorumz)\
**Post date:** [August 27, 2011, 7:03am UTC](https://forums.plex.tv/t/synology-package-thread/10450/82 "2011-08-27T07:03:49Z")

</div>

> [@](#):
>
> I wanted to do a few tests, but real work got in the way each day.  
> I think this could be that the transcoding file gets too big for /tmp.  
>   
> What you could do to test is to create a folder /volume1/Plex/TempTranscoding via SSH (or File Manager), do:  
> 
> ```auto
> 
> chown plex:users /volume1/Plex/TempTranscoding
> 
> ```
> 
>   
> and then edit the file we mentioned earlier:  
> 
> ```auto
> 
> vi /var/packages/Plex\ Media\ Server/scripts/start-stop-status
> 
> ```
> 
>   
> to change this line:  
> 
> ```auto
> 
> su plex -s /bin/sh -c "export LD_LIBRARY_PATH=/usr/local/plex/;ulimit -s 3000;/usr/local/plex/Plex\ Media\ Server &"
> 
> ```
> 
>   
> to this line:  
> 
> ```auto
> 
> su plex -s /bin/sh -c "export LD_LIBRARY_PATH=/usr/local/plex/;export TMP_DIR=/volume1/Plex/TempTranscoding/;ulimit -s 3000;/usr/local/plex/Plex\ Media\ Server &"
> 
> ```
> 
>   
>   
> Then, stop/restart the Media Server.  
>   
> This allows the transcoding file to be located in the main filesystem.  
> I don't know how it works for performance or just plain stability, but if it does work, I'll edit it for future packages.

  
  
I am not a unix guy but how much space is there normally in tmp folder? Could this be the issue that movies will stutter? (so far only 720p series with 1.2gb seems to work normally everything else not (mkv like 3/4gb to 15gb)  
  
Edit:I changed the path but big mkv movies still stutter (on my 10.1"tablet and lg tv, could be the synology nas though)

---

<div class="post-metadata">

**Author:** ![majorseagull](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@majorseagull](https://forums.plex.tv/u/majorseagull)\
**Post date:** [August 30, 2011, 11:36pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/83 "2011-08-30T23:36:43Z")

</div>

I am thinking of buying a Synology NAS and thought I might benefit from asking this on this thread. Is the package available only for the models listed in the first post?  
  
  
  
I was thinking of going with the DS2411+ … or maybe the DS3611xs, but that seems way overkill just for storage. Those aren’t listed in the first page, but I’m thinking that they are Intel as well?..  
  
  
  
Also, how would the DS2411+ behave with transcoding? I know 720p/1080p is tough, but my HD files are already in a format which shouldn’t need transcoding for my player, but I was wondering, for example an intact DVD mpeg2 stream (either 480i for NTSC or 576i for PAL), could the Synology handle the transcoding of SD resolutions to h264 as high as 8Mbit/s? Because having tried 2 or even 4Mbit on my desktop, it doesn’t seem to be enough to retain the most of the original quality.  
  
  
  
Appreciate any answers 🙂

---

<div class="post-metadata">

**Author:** ![Ravester](https://avatars.discourse-cdn.com/v4/letter/r/3be4f8/32.png) [@Ravester](https://forums.plex.tv/u/Ravester)\
**Post date:** [August 31, 2011, 10:29am UTC](https://forums.plex.tv/t/synology-package-thread/10450/84 "2011-08-31T10:29:15Z")

</div>

Hi,  
  
  
  
is the Avahi-Package already in the Synology-spk or do we have to install it sepperatly?  
  
  
  
Because my Plex installation on my Mac-Mini dosn’t see the PMS running on my DS710+ !  
  
  
  
And does the PMS always Transcode the content or depends it on the resolution of the files  
  
or the client that tries to stream the content?  
  
  
  
Tanks in advance  
  
Ravester

---

<div class="post-metadata">

**Author:** ![Nudgenudge](https://avatars.discourse-cdn.com/v4/letter/n/9f8e36/32.png) [@Nudgenudge](https://forums.plex.tv/u/Nudgenudge)\
**Post date:** [September 1, 2011, 9:02am UTC](https://forums.plex.tv/t/synology-package-thread/10450/85 "2011-09-01T09:02:09Z")

</div>

Sorry for the delay, lots of work these few days.  
  
  
  
Multi-answering time:

> [@](#):
>
> I don't think the Mac service should have to be enabled since the avahi-service is running but with faulty config. Bug?

  
Well, yes and no; sine the Media Server still uses Bonjour/Avahi from its Mac roots, it really should be started before installation.  
And yes, since I use another service to create the Plex one, it could fail.  
  
I don't think I'll do a fix for it, however; if Plex moves away from Bonjour (which may happen when clients are on other platforms), I'll just remove the whole Avahi business.  
  

> [@](#):
>
> I was thinking of going with the DS2411+ ... or maybe the DS3611xs, but that seems way overkill just for storage. Those aren't listed in the first page, but I'm thinking that they are Intel as well?...  
>   
> Also, how would the DS2411+ behave with transcoding? I know 720p/1080p is tough, but my HD files are already in a format which shouldn't need transcoding for my player, but I was wondering, for example an intact DVD mpeg2 stream (either 480i for NTSC or 576i for PAL), could the Synology handle the transcoding of SD resolutions to h264 as high as 8Mbit/s? Because having tried 2 or even 4Mbit on my desktop, it doesn't seem to be enough to retain the most of the original quality.

  
Never tried it, but the processor is the same as the DS1511+. Check the thread for feedback on transcoding.  
Again, NASes aren't really made for transcoding files, even SD ones. It's more for clients like the Mac one.  
  
And for Ravester: it should be installed already, and activated if you checked "Mac sharing" or something like that in the Control Panel.  
  
  
  
Also, don't get me wrong: if Bonjour was changed for something more cross-platform and that doesn't fail for no reason, I'll be a happy camper and add it instantly. :D

---

<div class="post-metadata">

**Author:** ![eliter33](https://avatars.discourse-cdn.com/v4/letter/e/53a042/32.png) [@eliter33](https://forums.plex.tv/u/eliter33)\
**Post date:** [September 4, 2011, 12:01pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/86 "2011-09-04T12:01:17Z")

</div>

Hi. I have just bought a ds1511+ and am trying to install the plex app package on it. I connect to the NAS and then click “Package Management”; then “Install”. I then locate the file and hit the go button but the screen just hangs on “Processing. Please Wait…”  
  
Any thoughts? Any help would be great!  
  
I have Plex running on all my machines currently but would like it to only be serving the database from the ds1511+.  
  
  
  
Thanks

---

<div class="post-metadata">

**Author:** ![lazant](https://avatars.discourse-cdn.com/v4/letter/l/848f3c/32.png) [@lazant](https://forums.plex.tv/u/lazant)\
**Post date:** [September 5, 2011, 3:40am UTC](https://forums.plex.tv/t/synology-package-thread/10450/87 "2011-09-05T03:40:15Z")

</div>

For the most recent season of True Blood I am getting the following error in the Plex Media Scanner.log and none of the episodes are showing up in Plex anymore, though they were for the first week of use. I assume it is the right quotation mark in episode 3 as others mentioned problems with punctuation. Is the solution to just rename the episode without the punctuation?  
  
  
  
[xml]Sep 04, 2011 22:08:56 [0x4000] DEBUG - \* Scanning directory /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir (parent: yes)  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - \* Noting that ‘True Blood/Season 04/@eaDir’ was updated at 2011-08-29 00:31:54  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - \* Taking directory ‘True Blood/Season 04/@eaDir’ (947) out of the map (0 left)  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E10 - Burning Down the House.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E09 - Let’s Get Out of Here.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E02 - You Smell Like Dinner.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E07 - Cold Grey Light of Dawn.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E05 - Me and the Devil.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E08 - Spellbound.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E04 - I’m Alive and On Fire.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E01 - She’s Not There.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E03 - If You Love Me, Why am I Dyin’.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E06 - I Wish I Was the Moon.mkv@SynoResource  
  
Sep 04, 2011 22:08:56 [0x4000] ERROR - Error in Python: Running scanner:  
  
Traceback (most recent call last):  
  
File “/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Series/Plex Series Scanner.py”, line 44, in Scan  
  
VideoFiles.Scan(path, files, mediaList, subdirs)  
  
File “/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/VideoFiles.py”, line 141, in Scan  
  
Filter.Scan(path, files, mediaList, subdirs, video\_exts)  
  
File “/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/Filter.py”, line 24, in Scan  
  
if os.path.exists(filename) == False or os.path.getsize(filename) == 0:  
  
File “/usr/local/plex/Resources/Python/lib/python2.7/genericpath.py”, line 18, in exists  
  
os.stat(path)  
  
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\u2019’ in position 81: ordinal not in range(128)  
  
Sep 04, 2011 22:08:56 [0x4000] ERROR - We got an error scanning in /volume1/video/tv/sickbeard  
  
Sep 04, 2011 22:08:56 [0x4000] ERROR - There were errors scanning location: /volume1/video/tv/sickbeard  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Since it was an incomplete scan, we are not going to whack missing media.  
  
Sep 04, 2011 22:08:56 [0x4000] DEBUG - Refreshing section 8 of type: 2  
  
Sep 04, 2011 22:08:56 [0xc004] DEBUG - It took 190.000000 ms to retrieve 1 items.[/xml]

---

<div class="post-metadata">

**Author:** ![Media\_36](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/media_36/32/1641_2.png) [@Media\_36](https://forums.plex.tv/u/Media_36)\
**Post date:** [September 9, 2011, 3:31am UTC](https://forums.plex.tv/t/synology-package-thread/10450/88 "2011-09-09T03:31:20Z")

</div>

I just updated to the latest version of DSM 3.2-1922 and now Plex doesn’t work. It shows that it’s running in the Package Center, but I can’t connect to it. Any ideas?

---

<div class="post-metadata">

**Author:** ![Svein\_Jarle](https://avatars.discourse-cdn.com/v4/letter/s/b77776/32.png) [@Svein\_Jarle](https://forums.plex.tv/u/Svein_Jarle)\
**Post date:** [September 10, 2011, 9:22am UTC](https://forums.plex.tv/t/synology-package-thread/10450/89 "2011-09-10T09:22:33Z")

</div>

> [@](#):
>
> I just updated to the latest version of DSM 3.2-1922 and now Plex doesn't work. It shows that it's running in the Package Center, but I can't connect to it. Any ideas?

  
I updated too, and had to uninstall the spkg and reinstall it. Now it works like before. And DSM 3.2 actually made Plex auto start. With 3.1 I had to manually start it after reboot...

---

<div class="post-metadata">

**Author:** ![gbdesai](https://avatars.discourse-cdn.com/v4/letter/g/ecae2f/32.png) [@gbdesai](https://forums.plex.tv/u/gbdesai)\
**Post date:** [September 12, 2011, 12:54pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/90 "2011-09-12T12:54:45Z")

</div>

I have the same problem you describe below and I am using Unraid. Anyone have ideas on how to fix the ‘ascii’ encoding of a UTF-8 character that is causing the error?

> [@](#):
>
> For the most recent season of True Blood I am getting the following error in the Plex Media Scanner.log and none of the episodes are showing htup in Plex anymore, though they were for the first week of use. I assume it is the right quotation mark in episode 3 as others mentioned problems with punctuation. Is the solution to just rename the episode without the punctuation?  
>   
> [xml]Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E03 - If You Love Me, Why am I Dyin'.mkv@SynoResource  
> Sep 04, 2011 22:08:56 [0x4000] DEBUG - Adding file for scanner: /volume1/video/tv/sickbeard/True Blood/Season 04/@eaDir/True Blood - S04E06 - I Wish I Was the Moon.mkv@SynoResource  
> Sep 04, 2011 22:08:56 [0x4000] ERROR - Error in Python: Running scanner:  
> Traceback (most recent call last):  
> File "/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Series/Plex Series Scanner.py", line 44, in Scan  
> VideoFiles.Scan(path, files, mediaList, subdirs)  
> File "/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/VideoFiles.py", line 141, in Scan  
> Filter.Scan(path, files, mediaList, subdirs, video\_exts)  
> File "/volume1/Plex/Library/Application Support/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/Filter.py", line 24, in Scan  
> if os.path.exists(filename) == False or os.path.getsize(filename) == 0:  
> File "/usr/local/plex/Resources/Python/lib/python2.7/genericpath.py", line 18, in exists  
> os.stat(path)  
> UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 81: ordinal not in range(128)  
> Sep 04, 2011 22:08:56 [0x4000] ERROR - We got an error scanning in /volume1/video/tv/sickbeard  
> Sep 04, 2011 22:08:56 [0x4000] ERROR - There were errors scanning location: /volume1/video/tv/sickbeard  
> Sep 04, 2011 22:08:56 [0x4000] DEBUG - Since it was an incomplete scan, we are not going to whack missing media.  
> Sep 04, 2011 22:08:56 [0x4000] DEBUG - Refreshing section 8 of type: 2  
> Sep 04, 2011 22:08:56 [0xc004] DEBUG - It took 190.000000 ms to retrieve 1 items.[/xml]

---

<div class="post-metadata">

**Author:** ![majorseagull](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@majorseagull](https://forums.plex.tv/u/majorseagull)\
**Post date:** [September 14, 2011, 6:46pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/91 "2011-09-14T18:46:06Z")

</div>

> [@](#):
>
> I wanted to do a few tests, but real work got in the way each day.  
> I think this could be that the transcoding file gets too big for /tmp.  
>   
> What you could do to test is to create a folder /volume1/Plex/TempTranscoding via SSH (or File Manager), do:  
> 
> ```auto
> 
> chown plex:users /volume1/Plex/TempTranscoding
> 
> ```
> 
>   
> and then edit the file we mentioned earlier:  
> 
> ```auto
> 
> vi /var/packages/Plex\ Media\ Server/scripts/start-stop-status
> 
> ```
> 
>   
> to change this line:  
> 
> ```auto
> 
> su plex -s /bin/sh -c "export LD_LIBRARY_PATH=/usr/local/plex/;ulimit -s 3000;/usr/local/plex/Plex\ Media\ Server &"
> 
> ```
> 
>   
> to this line:  
> 
> ```auto
> 
> su plex -s /bin/sh -c "export LD_LIBRARY_PATH=/usr/local/plex/;export TMP_DIR=/volume1/Plex/TempTranscoding/;ulimit -s 3000;/usr/local/plex/Plex\ Media\ Server &"
> 
> ```
> 
>   
>   
> Then, stop/restart the Media Server.  
>   
> This allows the transcoding file to be located in the main filesystem.  
> I don't know how it works for performance or just plain stability, but if it does work, I'll edit it for future packages.

  
  
I just got my Synology and I'm having the 10minute hanging problem as well. However, I couldn't change the Temp directory :/  
  
Doing "chown plex:users /volume1/Plex/TempTranscoding", I get this:  

```auto

chown: /volume1/Plex/TempTranscoding: No such file or directory<br />

```

  
  
So I decided to use the File Browser in the DSM to create the folder.  
I changed the file you mentioned using vi (had to login as root to do it), and that part I changed looks like this.  

```auto

start_plex ()<br />
{<br />
    if [! -f $PMS_SERVICE]<br />
    then<br />
        more /usr/syno/avahi/services/afp.service | sed 's/_afpovertcp\._tcp/_plexmediasvr\._tcp/g' | sed 's/548/32400/g' > "$PMS_SERVICE"<br />
        avahi-daemon -r<br />
    fi<br />
    su plex -s /bin/sh -c "export LD_LIBRARY_PATH=/usr/local/plex;export TMP_DIR=/volume1/Plex/TempTranscoding/;ulimit -s 3000;/usr/local/plex/Plex\ Media\ Server &"<br />
    counter=20<br />
    while [$counter -gt 0]<br />
    do<br />
        plex_status && break<br />
        let counter=counter-1<br />
        sleep 1<br />
    done<br />
    plex_status<br />
}<br />

```

  
  
However, it's still not going to the folder I created. After a while the streaming stops and I get the following message while trying to get to DSM: "You cannot login to the system because the disk space is full currently. Please restart the sistem and try again". Ending with the transcoding session will allow me to login again.  
  
Any sugestions? :/

---

<div class="post-metadata">

**Author:** ![Nudgenudge](https://avatars.discourse-cdn.com/v4/letter/n/9f8e36/32.png) [@Nudgenudge](https://forums.plex.tv/u/Nudgenudge)\
**Post date:** [September 15, 2011, 12:16pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/92 "2011-09-15T12:16:19Z")

</div>

Again, lots of work, multi-answer:

- Media 36: I didn’t try the upgrade, but I think it changes a lot of things in the /root directory .  
  
So yeah, “upgrading” (re-installing without uninstalling) should help. If you do a full uninstall/re-install, just do:  

```auto

chown plex:users /volume1/Plex

```

  
after re-install.  
- gbdesai: for the ASCII, unless there is a new binary, no clue.  
But isn't there a more common thread with this bug? Since it happens on all Linux environments, I thought this was already covered in the Bugs forum.  
- samukas: you did everything well (except that the chown was supposed to be done after the folder was created, it doesn't create one. I should have mentioned it, my bad).  
I may have made a mistake in the environment variable however: try TMPDIR instead of TMP\_DIR (no underscore).

---

<div class="post-metadata">

**Author:** ![majorseagull](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@majorseagull](https://forums.plex.tv/u/majorseagull)\
**Post date:** [September 15, 2011, 1:31pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/93 "2011-09-15T13:31:58Z")

</div>

Thank you, Nudgenudge, that did the trick! It was indeed TMPDIR and not TMP\_DIR.  
  
  
  
Now whenever I start a transcoding session, I can see files going into that folder and when I exit the video the files are deleted as they should be.  
  
  
  
If I might say so, I think this is a better approach for future versions of the package than the regular tmpdir, because I’m guessing that all users (doing transcoding) will come across this issue.

---

<div class="post-metadata">

**Author:** ![Nudgenudge](https://avatars.discourse-cdn.com/v4/letter/n/9f8e36/32.png) [@Nudgenudge](https://forums.plex.tv/u/Nudgenudge)\
**Post date:** [September 15, 2011, 4:21pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/94 "2011-09-15T16:21:26Z")

</div>

> [@](#):
>
> Thank you, Nudgenudge, that did the trick! It was indeed TMPDIR and not TMP\_DIR.  
>   
> Now whenever I start a transcoding session, I can see files going into that folder and when I exit the video the files are deleted as they should be.  
>   
> If I might say so, I think this is a better approach for future versions of the package than the regular tmpdir, because I'm guessing that all users (doing transcoding) will come across this issue.

  
You may say so, it'll be in the next script I give to Elan (Synology asked for a few things too). :)  
Otherwise, any performance issues/improvements? Just to know beforehand.

---

<div class="post-metadata">

**Author:** ![majorseagull](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@majorseagull](https://forums.plex.tv/u/majorseagull)\
**Post date:** [September 15, 2011, 5:39pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/95 "2011-09-15T17:39:07Z")

</div>

> [@](#):
>
> Otherwise, any performance issues/improvements? Just to know beforehand.

  
  
Nothing I've nothing so far, but I haven't played much with it. I'll let you know if I notice any weird behaviour.  
  
In fact, and answering my question a few pages ago as well, I am able to transcode SD-DVD content (720x576) at 8Mbps just fine with the Synology DS1511+. HD 720p content is pretty much impossible at 1.5/2+Mbps.  
I might upgrade the RAM to give some room for SABnzbd as well, but so far it performed nicely, I'm really loving this NAS.  
  
Btw, I'm using the Roku as my Plex Client.

---

<div class="post-metadata">

**Author:** ![AUSMUG](https://avatars.discourse-cdn.com/v4/letter/a/a3d4f5/32.png) [@AUSMUG](https://forums.plex.tv/u/AUSMUG)\
**Post date:** [September 18, 2011, 10:29am UTC](https://forums.plex.tv/t/synology-package-thread/10450/96 "2011-09-18T10:29:07Z")

</div>

> [@](#):
>
> I am thinking of buying a Synology NAS and thought I might benefit from asking this on this thread. Is the package available only for the models listed in the first post?  
>   
> I was thinking of going with the DS2411+ ... or maybe the DS3611xs, but that seems way overkill just for storage. Those aren't listed in the first page, but I'm thinking that they are Intel as well?...  
>   
> Also, how would the DS2411+ behave with transcoding? I know 720p/1080p is tough, but my HD files are already in a format which shouldn't need transcoding for my player, but I was wondering, for example an intact DVD mpeg2 stream (either 480i for NTSC or 576i for PAL), could the Synology handle the transcoding of SD resolutions to h264 as high as 8Mbit/s? Because having tried 2 or even 4Mbit on my desktop, it doesn't seem to be enough to retain the most of the original quality.  
>   
> Appreciate any answers :)

  
  
I have a RS3411xs with the Intel Bromlow CPU and while it was suggested it would work the fact is it was a big fail. On trying to install PLEX all I get is a failure message that it couldn't be installed because it is an unsupported platform. This is extremely disappointing. I hope this package is upgraded to support Synology's new models.

---

<div class="post-metadata">

**Author:** ![Nudgenudge](https://avatars.discourse-cdn.com/v4/letter/n/9f8e36/32.png) [@Nudgenudge](https://forums.plex.tv/u/Nudgenudge)\
**Post date:** [September 18, 2011, 11:14am UTC](https://forums.plex.tv/t/synology-package-thread/10450/97 "2011-09-18T11:14:42Z")

</div>

> [@](#):
>
> I have a RS3411xs with the Intel Bromlow CPU and while it was suggested it would work the fact is it was a big fail. On trying to install PLEX all I get is a failure message that it couldn't be installed because it is an unsupported platform. This is extremely disappointing. I hope this package is upgraded to support Synology's new models.

  
Okay, since the processor is able to transcode 1080p without issues, that must mean that the "Supported Platform" variable must be different for those ones.  
Which is strange, since it is a x86 processor. That's more of a question for Synology, as nothing in their wiki describes the new variable.  
  
Of course, if you do find the variable, tell me here, I'll add it ASAP.

---

<div class="post-metadata">

**Author:** ![xzer](https://avatars.discourse-cdn.com/v4/letter/x/ce7236/32.png) [@xzer](https://forums.plex.tv/u/xzer)\
**Post date:** [September 20, 2011, 7:10pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/98 "2011-09-20T19:10:05Z")

</div>

hello guys need a little help.  
  
  
  
i have a synology 1010+ can’t start plex pms from dms…i install/uninstall------uninstall/install … this is the error i’m getting.  
  
i tried to change the users plex to read only…nothing seem to work…  
  
  
  
DiskStation\> chown plex:user/volume1/plex  
  
  
  
BusyBox v1.16.1 (2011-09-04 02:17:22 CST) multi-call binary.   
  
  
  
Usage: chown [-RhLHP]… OWNER[\<.|:\>[GROUP]] FILE…  
  
  
  
Change the owner and/or group of each FILE to OWNER and/or GROUP  
  
  
  
Options:  
  
-R Recurse  
  
-h Affect symlinks instead of symlink targets  
  
-L Traverse all symlinks to directories  
  
-H Traverse symlinks on command line only  
  
-P Don’t traverse symlinks (default)

---

<div class="post-metadata">

**Author:** ![xzer](https://avatars.discourse-cdn.com/v4/letter/x/ce7236/32.png) [@xzer](https://forums.plex.tv/u/xzer)\
**Post date:** [September 21, 2011, 12:25am UTC](https://forums.plex.tv/t/synology-package-thread/10450/99 "2011-09-21T00:25:09Z")

</div>

yes newbie here and idot well learning . reset my 1010+ and lets see what happens…

---

<div class="post-metadata">

**Author:** ![cariost](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/cariost/32/1756_2.png) [@cariost](https://forums.plex.tv/u/cariost)\
**Post date:** [September 23, 2011, 1:30pm UTC](https://forums.plex.tv/t/synology-package-thread/10450/100 "2011-09-23T13:30:47Z")

</div>

Hi,  
  
  
  
I had installed Plex on my Syno, then I had to deleted it to re-install it.  
  
Now I can’t launch Plex on my Syno.  
  
  
  
Any tips ?  
  
  
  
Thank you !

[Previous page](https://forums.plex.tv/t/synology-package-thread/10450.md?page=4)

[Next page](https://forums.plex.tv/t/synology-package-thread/10450.md?page=6)
