The server "X" does not have a valid connection for casting. Check that the server is claimed

chromecast

#1

Hello all. I just downloaded Plex, as I'm evaluating the product. It finished scanning my music, and when I try to cast to a Chromecast device, it will display the following error:

"The server "X" does not have a valid connection for casting. Check that the server is claimed in server settings"

Where X is the name of my computer with Plex installed. I'm not sure what does this mean, but I haven't been able to use Plex at all. I've been searching for this issue to no avail.

The PC has Windows 10 with Plex version 3.20.8. Thanks in advance.


#2

I'm having the same issue. No luck at all searching for an answer in the FAQ's.


#3

Signing out and signing back in (under Settings>General>"Server Signed In As"; I hit the button, signing out and signed right back in) fixed it for me. I wonder what that was about...


#4

Same error, no idea how to fix it. I signed in & out, uninstalled & reinstalled, nothing is working. Using the latest version of Plex on a Mac with Chromecast. Any help would be very much appreciated. Thx


#5

Could you show me a screenshot of your settings page?


#6

Hi DomC — this part?


#7

This is the error I’m getting.


#8

Interesting. If it’s not too much to ask, could you please share your server with me? I’m Dom C.

If you can reproduce the issue on a new library with just one item, then that would be best - but no worries if not.


#9

Not sure if I did this right, but I think I just sent you an invite.


#10

You did, thanks. I can cast your content to my Chromecasts :confused: I’m listening to one of your movies right now on my Chromecast Audio :blush:

Where are you browsing your library from? plex.tv or the PMS IP address? Do you see any errors in the browser console?


#11

That’s so weird. I just got what you said about one item, so I deleted the library, added only one movie — and I still get the same problem.

I’m browsing the library through the IP address.

I just tested trying to browse and stream to the Chromecast from my Android app — and it works. So somehow it’s just streaming from the mac that doesn’t work.

Thanks again for your help.


#12

Actually, I take that back — the Android app can play the movie on my mac, but not stream it to the Chromecast.


#13

Where do I look for errors in the browser console? Thanks.


#14

It’s buried under the settings in Chrome:

Hopefully that will shed some light. There may be addresses/details you don’t want to post publicly here. Please feel free to PM me.


#15

PM sent! Thanks again.


#16

Hi Dom, do you have an update for me? Plex is still not working. Thanks!