There was a problem saving these settings

server-linux

#1

I just installed PMS on a fresh Ubuntu server (18.04) and I get to the first server setup screen, where you choose a friendly name, and when I click the continue button, I get "There was a problem saving these settings" message after about 20 seconds or so. I know the server is able to write to Preferences.xml as the date shows it is modified.

After this, if I go back to start over (go to :32400/Web, I get to the configure server screen saying that II have to claim my server. I click on the claim server button, and the spinner goes for a while then stops. Nothing else happens. This is where i'm stuck.

Any suggestions?


#2

Can you please dive into the file system and manually grab the logs?

tar cfz /tmp/Logs.tar.gz "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Logs"

Attach the tarball from /tmp/Logs.tar.gz here with your next post and I’ll see what it’s complaining about.

I do wish to ask in advance; Are you using a high performance processor (i7-7xxx class) on a SSD-based system?


#3

Attached is the log file. I am not using a high performance processor. I am trying to get this to run on an old Dell Inspiron - Intel Core Duo. And it is on a standard HDD system.

Thanks in advance!


#4

18.04 is so new and fresh I can’t tell if is that weak C2D or 18.04

You’re getting communications timeouts trying to talk to Plex.tv

Do you have an isolating firewall or something else possibly getting in the way and dropping the requests being sent?


#5

I do think this has something to do with my network. This is the 4th time I’ve tried this. The last three times were with Centos 7 and I was getting to the same point, so I’m guessing it is maybe my router. Can you point me to the address / port it is trying to hit? I can take a look at my router logs.


#6

I just checked and ufw is not running, so it shouldn’t be that.


#7

This will test and look at the connection from you to Plex.tv

  1. mtr www.plex.tv
  2. traceroute www.plex.tv
  3. ping www.plex.tv from the 18.04 shell command line

Look for lost / dropped pings & too much delay


#8

iklein99@plexserver:~$ traceroute www.plex.tv
traceroute to www.plex.tv (104.18.157.41), 30 hops max, 60 byte packets
1 www.routerlogin.com (192.168.1.1) 7.164 ms 7.415 ms 7.400 ms
2 XX.XXX.XXX.XXX (XX.XXX.XXX.XXX) 25.170 ms 28.438 ms 32.485 ms
3 xe-5-0-0-ur02.phoenixville.pa.panjde.comcast.net (68.85.193.177) 32.472 ms 32.457 ms 32.442 ms
4 be-41-ar03.ivyland.pa.panjde.comcast.net (68.86.209.149) 32.706 ms 32.692 ms 32.676 ms
5 be-33287-cr02.newyork.ny.ibone.comcast.net (68.86.93.173) 38.304 ms 38.279 ms 38.255 ms
6 be-10203-cr01.newark.nj.ibone.comcast.net (68.86.85.185) 38.245 ms 41.516 ms 41.745 ms
7 be-10249-pe03.newark.nj.ibone.comcast.net (68.86.85.90) 41.432 ms 12.705 ms 13.195 ms
8 66.208.229.78 (66.208.229.78) 13.495 ms 13.469 ms 16.078 ms
9 104.18.157.41 (104.18.157.41) 15.785 ms 15.750 ms 15.709 ms
iklein99@plexserver:~$ mtr www.plex.tv
iklein99@plexserver:~$ ping www.plex.tv
PING www.plex.tv.cdn.cloudflare.net (104.18.156.41) 56(84) bytes of data.
64 bytes from 104.18.156.41: icmp_seq=1 ttl=56 time=12.8 ms
64 bytes from 104.18.156.41: icmp_seq=2 ttl=56 time=13.7 ms
64 bytes from 104.18.156.41: icmp_seq=3 ttl=56 time=12.6 ms
64 bytes from 104.18.156.41: icmp_seq=4 ttl=56 time=12.2 ms
64 bytes from 104.18.156.41: icmp_seq=5 ttl=56 time=13.2 ms
64 bytes from 104.18.156.41: icmp_seq=6 ttl=56 time=13.5 ms
64 bytes from 104.18.156.41: icmp_seq=7 ttl=56 time=12.2 ms
64 bytes from 104.18.156.41: icmp_seq=8 ttl=56 time=13.7 ms
64 bytes from 104.18.156.41: icmp_seq=9 ttl=56 time=14.0 ms
64 bytes from 104.18.156.41: icmp_seq=10 ttl=56 time=11.3 ms
64 bytes from 104.18.156.41: icmp_seq=11 ttl=56 time=12.2 ms
64 bytes from 104.18.156.41: icmp_seq=12 ttl=56 time=14.8 ms
64 bytes from 104.18.156.41: icmp_seq=13 ttl=56 time=12.9 ms
64 bytes from 104.18.156.41: icmp_seq=14 ttl=56 time=13.0 ms
64 bytes from 104.18.156.41: icmp_seq=15 ttl=56 time=13.9 ms
64 bytes from 104.18.156.41: icmp_seq=16 ttl=56 time=12.3 ms
64 bytes from 104.18.156.41: icmp_seq=17 ttl=56 time=12.8 ms
64 bytes from 104.18.156.41: icmp_seq=18 ttl=56 time=12.7 ms


#9

Looks ok to me, although it seems a bit slow in resolving…

Maybe I should try to chance my dns server to 8.8.8.8 and see if that changes anything


#10

that first hop is killing you. Consider mine. I am also in Pa.

[chuck@lizum ~.104]$ traceroute www.plex.tv
traceroute to www.plex.tv (104.18.156.41), 30 hops max, 60 byte packets
 1  dsl (192.168.0.1)  0.182 ms  0.160 ms  0.151 ms
 2  h2.0.214.67.dynamic.ip.windstream.net (xx.xxx.xxx.xxx)  6.902 ms  7.945 ms  8.000 ms
 3  ae1-0.pe03.mdvl01-pa.us.windstream.net (40.136.114.124)  8.049 ms  8.096 ms  9.844 ms
 4  ae22-0.cr01.asbn01-va.us.windstream.net (40.129.34.16)  16.702 ms  15.218 ms  15.730 ms
 5  206.126.237.30 (206.126.237.30)  17.679 ms  18.122 ms  18.392 ms
 6  104.18.156.41 (104.18.156.41)  18.594 ms  19.282 ms  19.717 ms
[chuck@lizum ~.105]$

#11

The hop to my router or the next one?


#12

Look at:

  1. First hop from your computer to your router. I do it in fractions of a millisecond… You need 7. not good
  2. From your router to the first ISP point. 32 ms. Mine is 8 ms.

This isn’t a good sign already and you’ve only gotten to the ISP’s first point. I have 24/1.5 Mbps DSL which isn’t fast at all


#13

is there a timeout setting I can tweak? The interesting thing is that, from my mac, on the same network, when I do a ping, it starts right away. When I do it from the Ubuntu server, it takes 13 seconds before anything happens. However, it is only showing a 12.7 ms ping time, which seems fair.


#14

No. Timeouts are internal and hard set.

There is most likely a problem with running 18.04 on that machine. It’s been in public release only a few days. ANYTHING is possible and, with a fresh release, usually is.


#15

I solved the problem (sort of). I added plex.tv to my hosts file and it worked! The issue is that the DNS resolution was taking too long. Not sure why that is. I want to try using a different DNS server and see if it is my routers DNS. But at least I found the culprit. Thanks for your help!