There was an unexpected error loading this library

server-freebsd

#1

Plex newbie here. Running version 1.7.1.3856 on FreeNAS. Brand new, clean installation. I've been able to add Music, Videos, and Movies as new libraries. No issues. After I create a new library for Photos I get the following when I click on it:

There was an unexpected error loading this library
Please visit our forums if you continue to experience problems

So I completely removed all of Plex and the storage shares from my FreeNAS and started installing Plex again. Same, exact problem happens. But only when adding libraries that are for Photos specifically.
Yes, I've updated the libraries. It skips right over the Photos library. Yes, I've optimized the database. It's a virgin installation.

Can duplicate on command.

Any suggestions?

-Rob


#2

Hey Rob,

Had the same error on a Windows install version 3.2.1 after the initial install; I just deleted the Photos library and created a new one leaving all the default options pointing to a mapped network drive on my NAS for the folder and that worked for me.

Hope you find a solution. Scott


#3

I have the same problem on FreeNAS. Everything was fine, I was looking for a show before I updated, going back and forth from TV shows, Movies, looking for things to sync to my phone. I noticed an update, went ahead and applied it, now Version 1.7.2.3878 and I get the same error. Now the odd thing if you let it sit, not sure how long, maybe 10 minutes i'm sure it depends on the size of your library, the error corrects itself and all seems well. So I don't have a clue.


#4

I was running the 1.5.x version (the one FreeNAS installs with the plug-in) and had the same problem. I updated Plex hoping the error would go away. No luck.

There is no media on my server. It's a virgin installation. I've deleted and recreated the Photos folder. I've used one called 'photos' and another called 'pictures'. Set them up as Photos folder and they're not accessible. WTH?? How do I get someone's attention at Plex? Right now, I'm kinda sorry I bought the Plex Pass if this isn't remedied soon.


#5

The way you installed plex could be the issue. Version 1.5 is pretty old, not saying it won't or shouldn't work, but I would suspect the plugin way of installing plex could be your issue. Since you have a new install I would definitely give this way of installing plex in freenas a shot. The plugin way of adding anything in freenas is very old and outdated.
If you want to give it a shot and try this to see if it fixes your issue I will help you in any way I can. Here is a link to all you need to install the latest and greatest plex app and the correct way of doing it. https://forums.freenas.org/index.php?threads/tutorial-how-to-install-plex-in-a-freenas-9-10-jail.19412/

Since youre a plex pass suscriber I would say do it, so you have the newest version. Right now the people who use plex for free or install it for the first time are running version 1.7.2.XXX or newer, thats how old the version you're trying to install using the old plugin method on freenas is. So go for it, and if you have any problems I will help.


#6

I'm getting the same error here with Version 1.7.6.4058. Log file attached, any help is appreciated.


#7

This is frustrating.
No changes were made to the libraries and now I get the error that everyone here seems to be getting.
The plex server has been running perfectly for about 2 years now on FreeNAS and with a plex update installed about 6 or 8 months ago.
The error only happens to my TV Shows library. By changing the "sort" or filter in the title bar I can still access the content if changed from the default All > TV Shows > By Title view to something like Season > Season view but that kind of sucks.
Uninstalling the plex plugin, rebooting everything on my network and reinstalling the fresh plugin has not helped. It took about one full day for plex to re-scan and build its new database for only 2 TB of content.

No amount of Scan Library Files, Optimize Database, Clean Bundles or Empty Trash produces any benefit.


#8

And then... a few hours later, after giving up all hope... plex media server and plex player both start to work perfectly again.
The plex player was a huge pain to navigate in Season > Season mode and it has now somehow reset itself to the normal default of All > TV Shows > By Title view with no help from me. I swear the player changed itself from Season > Season mode to the more desired default mode and only then did I change the server's mode back to the default.
And everything was once again right in the world.
No, I do not understand why. I am happy that plex is working as it did before whatever triggered this hiccup.

This is all very strange behavior.
Did uninstalling the plugin, rebooting everything, reinstalling the media server plugin, giving plex enough time to rebuild its database and then waiting a few extra hours do the trick?
I don't know.

I was frustrated but now I'm just confused. Happily confused because plex is working well again.


#9

I am on version 1.13.2.5102 beta channel

I just recently built a new badass server to by my new plex server. Everything was fine, then all of a sudden in my movie library i was getting the "unexpected error loading this library". Then realized it was only doing it when sortby title was used.

I literally just went and click edit on the library and checked and unchecked a check box and save, boom everything is fine again. And as others said it went away on its on, not the case for me, it was like this for several days.


#10

having the exact same problems here. I've gone in to some detail about which views break for me.

https://forums.plex.tv/discussion/320050/there-was-an-unexpected-error-loading-this-library-in-certain-views


#11

hey folks, @OttoKerner solved my problem in the above discussion ^

he suggested that I repair my database using the repair steps here:

https://support.plex.tv/articles/201100678-repair-a-corrupt-database/

even though my database wasn't actually corrupt, I rebuilt the database, then optimized my database. Suddenly I can see everything in all my views.

no idea why, but it worked.