Tidy up library shares on plex

server-qnap

#1


The above image shows redundant empty folders (Spooks and The Professionals for example) which appear on plex but not in the qnap shares
Whilst not a pain is there any way to tidy this up ?


#2

I see no ‘redundant empty folders’ as you describe. Only the folder selector is visible in this screenshot.
Is "CACHEDEV1_DATA’ the ‘root’ of your library section? If so, this is an incorrect selection.
You will want to select /share/CACHEDEV1_DATA/MyMedia/movies (or similar named) for your Movies library.


#3

Chuck PA - I was referring to the right hand panel - I mentioned specifically The Professionals which is an empty folder. The “real” movie folder is in my library mymedia/movies - westerns/The Professionals as per its Qnap location. The folders on my screenshot The Professionals , Spooks & Billy Connolly are all empty and do not appear in Qnap outside The Mymedia location - I think we are at cross purposes


#4

Thank you for clarifying.

PMS reads the directory (/share/CACHEDEV1_DATA in this case) and lists all the directory names it finds there.

If you’re using MultiMedia and CodexPack, you’re in for a lot of anguish which is what I think you’re encountering here.

CodexPack 4.5.0 (QNAP) caused so many issues with PMS that I issued a special warning announcement at the top of the QNAP forum.

If I am understanding you correctly, “The Professionals” does not exist at the top of your CACHEDEV1_DATA as either a symlink, directory or vfs overlay (caused by Codex Pack and the MultiMedia share).

The problem with the MultiMedia share is because it is an application-level interface and not the Linux file system interface. Media which isn’t actually in the MultiMedia share only appears to be there. This causes huge problems with PMS because we reach directly to the Linux standard OS API glibc.

Here is my announcement:

Here is the QNAP FAQ where use of MultiMedia is strongly discouraged. Q14 http://forums.plex.tv/discussion/175405/qnap-faq-read-me-first#latest


#5

Hi ChuckPA
Sorry to be a pain - The “multimedia” share is still there but is totally empty thus redundant. The Qnap NAS will not let this share be deleted - I guess because it has legacy issues. All my media is in the separate “Mymedia” share - that being the case I’m not sure if your kind response is an exact fit to my problem. I could be wrong ? I’m a relative newbie who is quite easily technologically challenged !!!
Cheers.


#6

That’s ok. We were all newbies once :smiley:

Would you please respond to:

If I am understanding you correctly, “The Professionals” does not exist at the top of your CACHEDEV1_DATA as either a symlink, directory or vfs overlay (caused by Codex Pack and the MultiMedia share).

Is this the problem you’re seeing? “The Professionals” is being shown by Plex as existing but does not exist when executing ls -la /share/CACHEDEV1_DATA ??


#7

Hi ChuckPA
Yes - it only appears in Plex and does not exist at all on the Qnap filestation. It’s not doing any harm but being a little OCD it looks untidy
Thanks for your time


#8

@Johnrob1955 If you install WINSCP it will also see those folders. And you can delete them if you wish. There are many folders under CACHEDEV1_DATA but FileStation only shows the ones classified as shared folders (and Plex does not show the ones whose name starts with a .).

In particular the .qpkg folder contains the code for your installed packages, and in the case of Plex it also contains logs and other files.


#9

moody_blue Thanks. I gather WINSCP is file transfer software. If loaded on my PC and I run it where will the Plex files appear ? .qpkg folder ? Where is that located ?
Sorry to be a pain - I’m a little out of my comfort zone :*
Thanks


#10

WINSCP is a file explorer for Windows where you can have two panes, one to manage PC’s local disks, another to manage QNAP’s disks. You can also use it to transfer files between systems (with drag and drop). Since I have it, my usage of QNAP file station dropped significantly.

Q15 in QNAP FAQ has some hints for WINSCP. The .qpkg folder is under /share/CACHEDEV1_DATA (on the QNAP pane shown in WINSCP)


#11

moody_blue
Hi - Thanks for pointing me in the right direction. I have installed WINSCP and connected to my QNAP - see attached screenshot
In the right hand panel it goes straight to mymedia share which is inside the cachedev1_data share - therefore (I assume) that is why I don’t see the -qpkg folder needed. Have I done something wrong? Thanks for your patience AND Seasons Greetings.


#12

You have to login with the admin userid and enable show hidden files in WINSCP


#13

I am in London for a few days and will follow Moody_blue’s advice on return.