Timeout - Change Request

plex-vr

#1

Some of my library content is on an external hard drive, and this drive takes a few seconds to spin up and respond if it hasn't been used for a while. The Plex web app, and the Plex app on my Android TV seem to handle this OK, they just wait a few seconds and then the video plays. Plex VR behaves differently. On the first appempt to play a file, it waits a few seconds (but not quite long enough it seems) and then flashes up a timeout message. trying again straight after that works fine, because the drive has woken up. I can work around it by trying twice, but it's a pain. Could you please increase the timeout on the Plex VR apps?

Thanks.


#2

Interesting. How many seconds are we talking about here, approximately? I guess we should use a larger timeout since your use case sounds relatively reasonable (and common).

(Oh, and apologies for the belated reply).


#3

Thanks for your reply. It's difficult to tell exactly from the VR app, but if I'm just browsing to it from Windows Explorer it's about 7 or 8 seconds for the drive to respond and show the files in a folder. I guess that would need to be added to whatever the normal timeout is for a drive that's always ready. Does that help?


#4

I'd love a server-side timeout setting that all clients could respect. I've got a similar issue with a sleepy NAS (Plex itself runs on a big-boy computer instead of on the NAS). Often I'll open a share on my desktop just to wake it up before using Plex.


#5

I'd be happy with access to set the timeout in each client settings section. I only see the issue with the Plex VR client though. Others (web client, Android TV) seem fine accessing the same content with time for the drive to spin up.