Trailers is unavailable, try again later



Up until last week everything was working fine, i had plex connect working and loving it. all of a sudden my trailers app stopped working. I thought maybe it was an update to plex connect that broke it or something so i disabled plex connect restored me dns setting back to normal to see if i can get the regular trailers to come up. all i get is the trailer is unavailable. i preceded to do a restore, even after that i am still getting that error, i'm not sure what to next.


iOS 5.3?

Beta 4? Trailers is known to NOT work...


yeah I'm on beta 4


Beta 4 is known to be broken.

So is PlexConnect as it seems:


restored back to latested version on itunes and apple trailers works fine, plexconnect still seems broken. guess it might have to do with todays update to atv with the new channels


Mine has worked perfectly all the way up until today. I think its an issue with the new ATV update that came out this afternoon


Hello, I had PlexConnect on Win7 working for a couple days on my APT2 with 5.02 . I had shut everything down after viewing videos. A couple days later I restarted PlexConnect and went to the trailers app and received "Trailers is Unavailable..." I can still view my Netflix and Other ATV components, just not PMS thru Trailers app. I have verified DNS is correct on ATV. I also deleted all the PlexConnect files and reinstalled them. I also tried it on  ATV3 running

5.2.1 in another room and received the same results



PlexConnect is broken with the new update. The Trailers app connects over HTTPS now rather than HTTP as before.

Sooo not sure where we go from here


Same here.

Is there any way to fix this?

Any way to refer to an older update on apple tv ?


Plexconnect is down for me too.


It's down for everyone right now.


There is a fix, sort of. It will have to be put into the main branch assuming it works, it will also require installing the cert onto the apple TV using the configurator tool as well. 


This is odd because I have not updated my ATV2, still on 5.02


This is odd because I have not updated my ATV2, still on 5.02

Its pushed out automatically without a firmware update.. check the link above for a solution..


Is it possible to install the certificate on a non jail broken ATV?


Is this a proven fix that is sanctioned by the program designers?


I suggest we move discussions regarding the fix and the current state of PlexConnect with the channel updated pushed to this thread: