Transcode crash with CentOS 7.3, PMS container:newest

server-docker

#1

I've got PLEX in a docker container, clean install. Not a migration.

Server is a Xeon E3-1241, lots of ram, SSD local, ESXi 6u2. Media & config is on a NFS mount via freenas VM (16gb ram dedicated, HW passthrough for jbod). --->> Bunch of jails on the (PMS as well) freenas. I've been in IT for a long time, no need to discuss the nuances of virtualization or difficulty/complexity. This setup has absolutly ROCKED for a couple years.

Attempting to remove my jails and use docker. Built a simple CentOS 7.3 VM on same ESXi host. Current everything. This VM has 4 cpu, 8gb ram. NAS storage network (dual Nic) for the NFS mounts.

The freenas has a 10gb virtual link to the docker NIC.
Plex in the container freezes the container if I play more then one stream. transcode is a local disk, now has a dedicated mount in centos. originally I tried using a NFS mount. Again, all this is local - no phy switch involved between NAS and container, just from webui/clients to container. Should be screaming fast.

Below is my docker startup config. 0
Logs attached.

docker run -d --name plex -h tarkin -e TZ="America/Chicago" -e PLEX_CLAIM="claim-Masdfasdfasdfasdf5ND" -e PLEX_UID="816" -e PLEX_GID="816" -e CHANGE_CONFIG_DIR_OWNERSHIP=false -v /mnt/transcode:/transcode -v /mnt/plexdb:/config -v /mnt/media:/media -p 32400:32400/tcp -p 3005:3005/tcp -p 8324:8324/tcp -p 32469:32469/tcp -p 1900:1900/udp -p 32410:32410/udp -p 32412:32412/udp -p 32413:32413/udp -p 32414:32414/udp --restart unless-stopped plexinc/pms-docker:plexpass


#2

Thank you in advance


#3

Should mention - also clean installed same config on a dual xeon,32gb workstation with similar results. I believe there is something in the container that's not happy with... not sure. maybe overlay disk driver? Transcode dir default was on SSD with the container... then tried the NFS mount. Then moved it to it's own ssd. Permissions are 777, owned by 816/816.