TV Playback Stops Before End

plex-web

#1

When watching tv episodes of any format, the playback stops about 1-2 minutes before the end.

I'm running Plex 1.11.2.4772 on my Synology and using the latest version of Chrome. Old posts that mention this issue haven't lead anywhere. Any help would be appreciated.


#2

I am having the same issue. On a 45 min episode of a show it will stop at about the 41-42 min mark, orange circle and sometimes it will start playback again. This is with no transcoding, direct play over LAN and remotely. It seems to happen with mkv files for sure, and the only avi files I watch are 23 min shows and have not noticed this issue with those. I am on the latest version of plex, and the server is on Windows 10, and streaming to a Windows 10 computer via web player. This has been happening for at least a week now, and started happening without an update happening to Plex. There has been no changes to my hardware or network at all.

I have attempted to adjust buffer size, but that seems to have more relation to transcoding than direct play. Below is the log report of this happening to me just now.

Feb 12, 2018 15:39:46.543 [9936] WARN - Transcode runner appears to have died.
Feb 12, 2018 15:39:46.653 [9936] WARN - Timed out waiting for segment.
Feb 12, 2018 15:39:46.731 [7372] WARN - Transcode runner appears to have died.
Feb 12, 2018 15:39:46.840 [7372] WARN - Timed out waiting for segment.
Feb 12, 2018 15:39:48.184 [6020] WARN - Transcode runner appears to have died.
Feb 12, 2018 15:39:48.247 [9936] WARN - Transcode runner appears to have died.
Feb 12, 2018 15:39:48.309 [6020] WARN - Timed out waiting for segment.
Feb 12, 2018 15:39:48.372 [9936] WARN - Timed out waiting for segment.
Feb 12, 2018 15:39:50.403 [11256] ERROR - [Transcoder] [dash @ 049e8120] Cannot use rename on non file protocol, this may lead to races and temporary partial files
Feb 12, 2018 15:39:51.793 [11256] ERROR - [Transcoder] [dash @ 04202d20] Cannot use rename on non file protocol, this may lead to races and temporary partial files


#3

Just chiming in. Experiencing the same thing on both Plex Web and the iOS app. Seems that this error might have been “fixed” in a server hotfix in November but has appeared again. I commented in a similar thread here: https://forums.plex.tv/discussion/295667/latest-version-dropping-last-two-minutes#latest

and from reddit:


#4

Confirming that this is still happening on both iOS and Plex Web with the new server update released last night.


#5

I am running Version 1.10.1.4602 and it is still happening.


#6

Still the same problem with 1.11.3.4793 !!
(Plex Web on Chrome)


#7

New larger Reddit thread forming about this issue. https://www.reddit.com/r/PleX/comments/7xoh1w/plex_server_videos_pause_for_a_few_seconds_before/


#8

We’re testing a fix that should address this issue and related issues. A critical error from the player stack is emitted near the end of certain videos, which either leads the player to fallback to a transcode or there is an error. We’ll hopefully get that fix out on app.plex.tv today or tomorrow.

However, the issues I’m referring to are specific to the web app and would not affect the iOS app. Keep in mind that the versions you mentioned are for Plex Media Server. If you follow release announcements for the web app, you’ll see different versions.