tvOS/iOS: Forced subtitles are not shown (without transcoding)

apple-tv

#1

I recognized yesterday that the Plex App of tvOS and iOS no longer shows forced subtitles.

My files are all MP4s with SRT subtitles.

If I play the same file on macOS with Quicktime or on tvOS via the Computer app the forces subtitles are shown.

Selecting in the tvOS player other non forced subtitles works (even without transcoding :-) ). Only if the subtitle mode is "automatic" where the forced subtitles should appear is not working.
Selecting the forced subtitle in the Plex splash screen of the movie before I start the movie has also no effect.

A few month ago this worked since years... Must be an update from the last months.

On tvOS 10 and 11 forced subtitle are broken. Must be a Plex issue.

Some Subler screenshots of a movie with forced subtitles:

https://imgur.com/a/98DCf
https://imgur.com/a/tndT8


#2

Leaving the subtitles setting automatic doesn't show forced subtitles for me (I would assume that qualifies as a bug by itself), but if I select them in the splash screen before I play it they do work.


#3

Selecting them in the splash screen (before starting the video) doesn't work for me.

But I recognized a few minutes ago, when I switch from automatic to none oder an other subtitle and than back to automatic the forced subtitles works again. At least until I restart the movie.
This is no solution, it's more a workaround for this annoying problem.

Let's hope that the Plex developers read this and working on a bugfix.


#4

I started having this problem recently too. Forced aubtitles showed up just fine in Plex a few months ago but now the same files don’t automatically show them.

One WIERD thing is that if I go to the subtitle menu while playing and reselect the currently selected option (in my case OFF), the forced subtitle shows up. If I change it from OFF to anything else it also shows up. I can duplicate thus on all my MP4s with forced subtitles. Seems like toggling any subtitle option causes it to suddenly recognize the force subtitle.

Again these same files worked with forced subtitles previously and still work in QuickTime and VLC on my Mac, as well as the Computers app on the Apple TV.

I’m using the latest Plex Media Server and tvOS (including PlexPass betas) with no luck on an Apple TV 4K.

Please help.


#5

The in-video-player subtitles toggle doesn't do anything at all for me. I wish they would sort this out, it's really irritating to be halfway through a movie and someone starts speaking an alien language and I have to stop the movie and go fiddle around with the subtitles or worse just assume I'm not supposed to know what they are saying and miss big plot points lol


#6

This issue occurs still with
Plex Media Server 1.9.7.4441
and Plex on tvOS Version 1.19
or Plex on iOS Version 4.20

I'd like to know if the developers even aware of this bug and do they consider to fix this?


#7

I just noticed this issue with my Apple TV 4k. Are others still experiencing this?


#8

I am still experiencing this issue with the Apple TV 4k, latest Plex app, and latest Plex Media Server (on Mac). It happens on both the tvOS and iOS.

I’ve mentioned before that there appears to be a bug with the subtitle toggle. When playing a movie with forced subtitles that aren’t automatically displayed, if I go into the subtitles settings and just reselect Off or Auto or anything, then they start working. I’ve been able to duplicate this on multiple MP4s with forced subtitles for months now. It used to work.

The forced subtitles work fine if played outside of Plex on the Apple Tv.

@danmcq said:
I just noticed this issue with my Apple TV 4k. Are others still experiencing this?


#9

I confirm the problem.

Apple TV 4k, latest app version. I need to select the gear, then select the subtitles before playing the video.

Happens with all MKVs with SRT subs.


#10

Yes, it is still not fixed in the newest Plex Server and Apple TV app. It is really a shame that this is still not fixed, after this worked for a long time perfectly.

Shame on you Plex Team!


#11

Just experienced the same problem on Apple TV 4K.


#12

I think that the Plex Server cause this issue. Infuse with Plex has the same bad behavior with Forced Subtitles.


#13

Same issue here with Plex Server 1.13.0.5023 running on OSX 10.13.4 and accessed with the Plex app on Apple TV4 (TVOS1.4)


#14

This is yet another issue why I gave up on Plex for Apple TV. The subs management is awful. On Android TV one can choose the subs while streaming a video. Why does it have to be different on Apple TV? I have no idea what “Automatic” does for example.


#15

The sad one is that got in this thread not a single response of a plex employee… since a 3/4 year.