ubuntu trusty plex home theater



Im using (L)Ubuntu 14.04 Trusty on my Orange Pi Plus (Rasberry Pi Clone).

I followed the isntructions for the Plex Home theater on page: blog.hack.cd/plex/

Hoever on the last command when we install plexhometheater:
sudo apt-get install plexhometheater

I get error message saying:
E. Unable to locate package plexhometheater

anyone seen this?




If Ubuntu is unable to locate the package, that usually means you don't have the right repository [enabled]. The guide you used mentions adding a PPA [covered under the header "First Let's Cover The Prequisites". In that chapter, you'll be adding the proper repository. Did you do that?

If so, please do a "sudo apt-get update" first, in order to fetch an overview of all available packages throughout the enabled repositories.


Hi jeroendop

Thank you for the reply.

What i did was:

sudo add-apt-repository ppa:plexapp/plexht
sudo apt-get install git
git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg
sudo add-apt-repository ppa:pulse-eight/libcec
sudo apt-get update
sudo apt-get install plexhometheater

Sorry im very new too linux.. im trying to figure this out.

Ill have a look in the /etc/apt/sources.list file to see if i see my package.

I enabled all the packages in the /etc/apt/sources.list GUI, and saw that plexht had both ninary and source there. When i exit the gui it wants to reload, and tries to download files. It downloads some then gives the message: Failed to download repository information.

Also tried to remove them all and add them anew, but get the same error on:
sudo apt-get install plexhometheater





I went to the Software and updates and added the PPA for my Ubuntu version (Trusty):

Also doublechecked the version:

And checked my /etc/apt/sources.list with nano:

I still get the same error

werid hu? :stuck_out_tongue:


Whoops -- just realized this was for Plex Home Theater. My mistake.

After getting the PPA to your system, did you do an 'apt-get update' before trying the install of 'plexhometheater' ?

I created a test ubuntu1404 server and did the following:

# echo "deb http://ppa.launchpad.net/plexapp/plexht/ubuntu trusty main" >> /etc/apt/sources.list

# echo "deb-src http://ppa.launchpad.net/plexapp/plexht/ubuntu trusty main" >> /etc/apt/sources.list

# add-apt-repository ppa:plexapp/plexht

# apt-get update

# apt-cache search plexhometheater

plexhometheater - The most awesome Media Center you'll ever need.

# apt-get install plexhometheater



The next thing you could try is this:

sudo apt-get clean && sudo apt-get update && sudo apt-cache search plexhometheater

The line above is a single command. What is does, is clear the entire apt cache, refresh it and search it for plexhometheater. I've looked at the PPA repo, it doesn't contain a package for 14.04.2 [just 14.04.1], but this shouldn't form a problem. If the command above doesn't resolve the issue, we are going to install it manually.

So, don't worry, we'll get this sorted out and solved!


Thank you jeroendop ! :-)


Hi Guys
Thanks for the replies.
I tried the command:

sudo apt-get clean && sudo apt-get update && sudo apt-cache search plexhometheater

Cleaned, updated but did not find plexhometheater.

albertcard, Ive tried as you described, same issue, when i try to install plexhometheater it cant locate the package..




Hi Bjorn,

You might want to try downloading and installing the package manually. On this link, you can download the package yourself and put it to install: https://launchpad.net/~plexapp/+archive/ubuntu/plexht/+build/7424218

The file you need is listed under 'built files' and should come in at 31.7Mb.

Best regards,


Hi Jeroen

I downloaded the deb package and tried installing but met a new problem:

my orange Pi Plus uses a Allwinner H3 Arm Cortex A7 Quad core processor:/

So the architecture seems to be wrong:/



I am able to install the Plex media Server on my Orange Pi.
Is the browser client/local app there as good as the plex home theater concerning video/audio quality ?




Right. Now I feel stupid.

I completely overlooked the architecture. That was the underlying problem the whole time and the reason why apt couldn't find any package, since there is no compiled package for your platform.

This complicated things pretty badly. Guess you aren't familiar with compiling? That'll leave you with few options, like trying PleXBMC, using Plex' DLNA features or using another platform...


Hi jeroendop
Ive installed Android 4.4 and manually installed the plex app. I am unable to authenticate (I already bough the android app) to google play as it wont run properly on my android Os. I am going to get myself a plex pass and try again. Think this is the only way to go for me:P

Thank you for all your support!




Hey Bjorn,

No problem, I am always in to solve a complex problem, or two ;)

From what I remember, I am not an expert when it comes to Google Play Services or the inner workings of Andoid APK's, but you only authenticate against Google Play when installing the app, yet, from your words I tend to understand that you succeeded in installing Plex on Android?

You might want to try Plex in the "demo mode", without buying the app or buying a Plex Pass. It won't play further than one minute or so, but it should give you an idea if it works at all.

Are you able to use the "free functionality" as listed in the attached image?

Best regards,


I was able to install the Google Play APK, but it would not start on my android. So i just downloaded and installed the Plex App APK without Google Play. This means that it will not activate. It plays 1 minutt yes. But there are some media files that the Plex will not play, even though these files play on my normal android phone using my Plex app. So there is something buggy going on.

I shall await to see if the Orange Pi people adjust the rasplex to fit Orange Pi :)

Meanwhile im testing other tools and roles on my Orange Pi.




Hello Bjorn,

Sorry for my late answer, life took up quite some time recently.

This may sound blunt, but aren't you able to ditch the Orange Pi and get a Raspberry? I currently have the RPi v2 running as my main player, and it's quite awesome. Where RPi v1 suffers from lags, the RPi v2 boasts a shitload of power for such a little device. :)

Nevertheless, all the best and good luck!


Hey jeroendop

I have considered buying a Raspberry Pi 2, and i still might.
The only thing that puts me off is the limit of 100mb network connection. Im thinking that there might be lag issues when watching large movie files (more that 15GB) from my nas to my home cinema. I do not want downscaling when at home.

The Orange PI works great as a Plex media Server which transcodes 1080p easily. So ill keep it as a server for now. I wish the Raspberry had a gigabit network adapter card:P




I hope Plex will focus on supporting Arm processors as they grow more potent all the time.


@bjorn80 said:
The only thing that puts me off is the limit of 100mb network connection. Im thinking that there might be lag issues when watching large movie files (more that 15GB) from my nas to my home cinema. I do not want downscaling when at home.

Good point. I think you already know this, so excuse me for overstating this and being captain obvious, but the file-size says very little. You should look for the bitrate. The bitrate defines how much bandwidth is being used per second. The maximum bitrate for a -full- BluRay sits at 40mbit/s, so you should be more than safe with a 'fast ethernet' interface ;)

You made me very curious to your setup, because from a technical stance, the Orange Pi shouldn't be able to transcode a 1080p movie on the fly. Are you really, really sure it transcodes, instead of direct-playing or remuxing?



I found this thread because I experienced a similar problem. I followed all the troubleshooting advice here to no avail. However, I am using Ubuntu 15.10 (Vivid) on an Intel NUC Core i5 Broadwell processor (AMD 64 architecture).

From Packages in “Plex Home Theater PPA” it seems that the last build failed. Would this build failure explain why the package is missing?