Unable to access Plex server locally or remotely until Server PC is completely restarted



I have been having some trouble for the last couple of months with my Plex Mdia Server randomly stopping being accessible. I run PlexPy monitoring so I get notified that my server has gone down, and no matter what I try it from (including the server PC) I cant access the server at all. When I right Click the tray icon and click Exit, all the plex services apart from Plex Update Service are shutdown (not sure if that is normal behaviour). If i try to restart the Plex Media Server program, the server starts and it even starts logging but the server is still not accessible either through localhost:32400, launching through double clicking the system tray icon, trying on other devices on my local network and trying on devices on mobile/other networks. I have to shutdown windows on my PC that is running the server and restart it in order for Plex to start working properly again. This seems to happen every few days so I am not quite sure why it does this.
The error message I get is " refused to connect" when trying to access Plex through Chrome on my server PC.
Today, I got notifies at 10:58 AM that my plex media server was down from PlexPy. I checked the Plex Media Server.log file and the last entries were at 10:52 AM and they said
WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x0
DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x0
It stopped logging anything else after that. Unfortunately, I have since restarted my media server so the logs are no longer there so I cant attach them. I read that this error appears if you are running plex as a service as there is no tray icon but I am not running plex as a service and the tray icon is very much there. I have noticed the logging stop on those messages previously when my server has done this so I'm not sure if that error is whats causing my plex to stop working, but I also remember it stopping on other messages aswell.
I have been updating Windows 10 and Plex every time a update is available in the hopes that this issue was identified and would be fixed but I cant find anything online about this particular issue. As Plex is still technically running and not crashing when this happens, there are no crash logs either.

Does anyone have any suggestions as to whats going wrong here? This is proving to be quite annoying as I generally leave my PC running 24/7 apart from a restart on Sundays.



Hi Sulaiman,

I have the same problem, my laptop is a Dell XPS with windows 10, and I leave it running usually 7x24, just sometimes I power it off or I restart it, but the fact is that when the laptop is on, and the internet is ok, for some strange reason Plex Media Server stops responding (as you report) so I’m unable to login locally from my laptop and also my clients (iphones and roku devices) cannot connect to my server since it appear offline.

When that happens I need to manually go into my laptop (Plex media server device), and close the tray icon and restart it, but sometimes that doesn’t work and I have to open task manager and kill the plex media server from there, then restart the plex media server application.

Just on very rare cases, the above is not working and I need to reboot my laptop

So, I’m with you Sulaiman and hope there is a permament fix to this annoying and frustrating issue

Hector Barajas


HI, Does anybody know if this issue has been fixed with latest releases??



I have the same issue. I am getting a little sick of this issue…


I have been testing since released version, and it seems that the problem is like 90% fixed, why 90%?

Because since version was released I just noticed once that the plex server was down, I did nothing just waited for about 2 hours and without doing nothing, Plex server was again up and running.

So this seems to be a huge process and perhaps the issue was fixed since version, because the changelog mention that several crashes are fixed:
(Library) Crash when attempting to download extras (#7713)
(Library) Crash when getting children of an unparented season (#7677)
(Transcoder) A crash on certain FreeBSD configurations
(Transcoder) A crash when trying to use hardware transcoding in macOS 10.10 (#7692)
(Transcoder) A crash with certain subtitles in files with embedded fonts (#7436)

You should give a try to and comment any problem


UPDATE: still with the latest version
December 13, 2017

This annoying bug is still present, not as frequently as with other versions, but the problem is not solved.

I have to roll back to:

is Plex staff aware of this? will this be fixed 100%?