"Unable to browse music" error with latest update?

sonos

#1

Any pointers appreciated. It's been awhile since I've used Plex under SONOS so I may have missed something along the way.


#2

I have the same issue (I posted on the Sonos forum as well). Yesterday I had a 701 error but Sonos sais on their forum that the Plex integration was being updated. Today, I tried again to delete and add the Plex service. The app take me to the plex website to sign in (not asking a pin, probably the new integration). Then, when Plex is added to Sonos, I got the message “unable to browse music” after a few seconds. If I try again, Sonos asks me to reauthorize Plex. I’m taken back to the Plex website, I sign in, I go back to the Sonos app and then it asks me again to reauthorize the account. Then the same thing, in a loop.

Should I wait while Plex and Sonos sorts things out or am I doing something wrong?

Please not that my plex server in not on the same LAN as my Sonos (remote server) and that I was able to play music from that server before the update.


#3

Seems to be fixed now!


#4

The updated configuration for the new app is still in the process of rolling out globally. You can try to force the update by checking for updates in the Sonos app and then restarting it. Worse case scenario you can remove the Plex service and re-add it.


#5

I tried:

  1. check for updates, NG
  2. remove Plex service, shut down SONOS Windows app, re-add Plex, NG

I guess I’ll just wait. Maybe it’s because I’m actually in VA? :slight_smile:


#6

Was that even tested? Almost nothing works anymore. All the time just: plex connection was disconnected.
Plex music tracks can’t be used in a saved sonos-playlist. Just the error above.

  • no updates yet
  • re-added the Plex service several times.
  • inside plex service the music will play, but that’s it.

#7

I’m seeing this too. “Unable to browse music”.

My Sonos players and controllers are up to date. I’m running the latest Plex server.

I tried removing Plex from Sonos and re-adding. Got the scary Ashburn auth message, completed the setup, and it didn’t work.

I also tried checking for updates within Sonos, then restarted the app. No change.


#8

Same “Unable to browse music”, perhaps we are waiting for an update from Sonos in Europe?

What are the network requirements for this to work? Standard Plex port from Sonos to Plex server? Anything from the outside required?


#9

Hey gang thanks for the patience today as we’ve been working through the issues. The app should be working better but we’re continuing to monitor.

As far as network requirements the PMS you’re accessing needs to be remotely accessible, and if your Sonos and PMS are on the same network your router will need to support NAT loopback.


#10

Add me to the list. I’d been using Sonos on Spotify for months without an issue and suddenly can’t access my music at all. Bummer.


#11

Hi Folx, got same problem in Germany that the sonos app wanna have an authorize and the browser opens up with that security alert, i can login but the sonos app is empty when i try to browse the plex libary. Does Anyone has to get it workiing again ?


#12

I’m having a similar problem but it’s only for Playlists? I can browse and play music from Plex fine but I can’t browse my playlists…I get the “Unable to browse music” error.

Anything unique for that?


#13

Update: We identified an issue in which if you had a single PMS that was not accessible remotely or via relay it would cause the “Unable to browse music” error. The fix has been shipped - if you’ve had issues browsing music please give it another shot.


#14

@johnclayton

Still have the problem. Here’s what I just did:

  • Remove Plex as a source from the Sonos application (on Mac OSX)
  • Exit Sonos application
  • Shut down Plex server
  • Restart Plex server
  • Verify Plex server is remotely accessible (yep)
  • Open Sonos application (on Mac OSX)
  • Go to add service / visit sonos labs / choose Plex / authorize
  • Return to main Sonos app. Click on Plex as a much source

All I see is “Unable to browse music”


#15

I’m still seeing “unable to browse music” when trying to browse my Plex library. This happens when using Sonos clients both on my LAN (while at home) and externally (at the office using our Sonos setup here).


#16

There should not be an “accepted answer” to this issue. The issue is not fixed. Very frustrating to wake up this morning to the third day of not having access to my music, no response to my post from yesterday, another person chiming in with the problem AND somehow a previous answer is accepted as the fix? Bogus.


#17

Nothing has changed for me either. I continue to get the “Unable to browse music” error.


#18

I ran into this issue over the weekend and I am still having problems this morning. After being prompted for reauthorizaton I was only able to browse the music of a friend. I thought it was a weird mapping issue so I requested that he stop sharing that category with me. Now I have checked for updates, restarted everything, removed/added/reauthorized Plex on Sonos and still I am “unable to browse” my music library. Please send along a fix soon.


#19

same here. tried everything recommended so far - no luck… HELP! :smile:


#20

Also getting “Unable to browse music” error when selecting Plex in Sonos. Sonos and Plex are up-to-date. Verified Plex Remote Access is working. Also removed and re-added Plex service in Sonos app several times. Re-authorized Sonos Beta. Rebooted both Plex Media Server and Sonos controller. Issue is still occurring today (3/14/2018). Resolution?