Unable to claim server

server-freebsd

#1

Hey folks,

First of all I don't think this is related to FreeBSD, but I'm just too tired to find the right place to ask this question.

I'm trying to run my plex server on my FreeBSD (installed plexmediaserver-plexpass-1.12.1.4885 from ports). However when I connect to the server I don't see the usual server setup wizard. <server-ip>:32400/web/index.html#!/setup tells me that I can't claim a shared server (guess plex is thinking I want to claim my friends shared server). So did some research, tried the ssh tunnel (which apparently solved this issue for others) but had no luck. On a new plex account I only get a message that I have no plex servers yet.

Here is where things become a little strange: I imported my older Preferences.xml and was able to see the server (marked as "nearby"). But my friends didn't see the server. Neither did I when being outside of the servers network.

Any suggestions how to solve this problem? Any help is appreciated.

Cheers czeru


#2

Ok, little update: I got it “working”. While connected with an ssh tunnel from outside of my home network with the old config it worked. That was when the setup wizard showed up. I have no idea what went wrong, if anybody is interested I will try to investigate further.


#3

Do you still have a copy of the Preferences.xml that doesn’t work?

Can you post the contents of both (hiding the token and other relevant private info such as machineid etc) I suspect its related to allowedNetworks setting, but just want to be sure.

You can also send the content in PM if you prefer.


#4

Sure, here are my configs.

The old one (and currently working):

<Preferences AcceptedEULA="1" AnonymousMachineIdentifier="<uuid>" CertificateVersion="2" CloudSyncNeedsUpdate="0" FriendlyName="<nas-name>" LanguageInCloud="1" LastAutomaticMappedPort="0" MachineIdentifier="<uuid>" ManualPortMappingMode="1" MetricsEpoch="1" OldestPreviousVersion="legacy" PlexOnlineMail="<email>" PlexOnlineToken="<token>" PlexOnlineUsername="<user>" ProcessedMachineIdentifier="<identifier>" PubSubServer="<some-ip>" PubSubServerPing="43" PublishServerOnPlexOnlineKey="1" agentAutoEnabled.com.plexapp.agents.lastfm.Artists.com.plexapp.agents.vevo="1" allowMediaDeletion="1" collectUsageData="0" disableRemoteSecurity="0" BackgroundQueueIdlePaused="0" PubSubServerRegion="fra" logDebug="0" ButlerTaskCheckForUpdates="0" WanPerStreamMaxUploadRate="8000" WanTotalMaxUploadRate="32000" DlnaEnabled="0" CinemaTrailersFromBluRay="1" CinemaTrailersFromTheater="1" CinemaTrailersType="0" GracenoteUser="<some-base64>" FSEventLibraryUpdatesEnabled="1" GenerateBIFBehavior="never" GenerateChapterThumbBehavior="asap" ScheduledLibraryUpdateInterval="900" ScheduledLibraryUpdatesEnabled="1" TranscoderTempDirectory="/transcode" FSEventLibraryPartialScanEnabled="1" PlexOnlineHome="1" HardwareAcceleratedCodecs="1" ButlerUpdateChannel="8"/>```

The new (clean) one:
```<?xml version="1.0" encoding="utf-8"?>
<Preferences OldestPreviousVersion="1.12.1.4885-1046ba85f" MachineIdentifier="<uuid>" ProcessedMachineIdentifier="<identifier>" AnonymousMachineIdentifier="<uuid>" MetricsEpoch="1"/>```

I made a zfs snapshot when everything was working fine. I reverted to my old clean install snapshot, copied the config and reverted back to the currently working one only to see that it wasn't working anymore. I can see the server in my local network, but not from an external point of view. It's showing up as "nearby" again so I guess my problems aren't gone yet...