Unable to connect content server



I am having problems playing some of my video files recently. The video starts playing and then after a few seconds there are some distortions in video and loading icon pops up and after a few seconds the message "unable to connect content server message comes.
I tried same video from pc's browser and it is successfully played however in tv it gives error.

My system details:
Plex server (installed at qnap ts-431)
Plex app version: 2.009
Samsung UE40JU6070U (2015 model)

Server log is attached

Any help is appreciated.
Thanks in advance.


If you see artifacts in the video, that is usually a sign of a bad encoded movie.
Have you tried to switch to transcoding? Not sure if your server can handle that though.


Friend of mine has a similar issue. Content of my server he can see, but whatever he wants to watch he gets the message unable to connect content server. His samsung runs 2.009, mij PMS 1.10.1.
I really have no idea how to fix this.
Help would be appreciated.


Check how the server is set for secure connections .
Set it to preferred. Some TV models are not very good at encoding the video signal.

If you must use https, then make sure the app is set for using secure connections too.


Hello Orca,

Thank you so much for your quick response.

My friend has been watching for over a year whitout any problems. Since last week he gets this message.
In my PMS secure connections are set to required and on his tv it is also set on able.
I would prefer to keep my PMS on required.
Like I said, last week it stopped working. I found out his tv had 2.005. I told him to update to the latest version 2.009.

If you really think that would be the best option I’ll set it to preferred.
Hope to hear from you.

update 02-02-18 21:40

I changed PMS to preferred, and told my friend to set secure connections to off.
I did a restart on PMS but it didn’t work. Still not able to connect to server.

Kind regards from the Netherlands


Well if it worked before, it should still work. The question as always is, what has changed?
Can you friend play anything through Plex web from your server?

What sometimes helps is to log your server out and then back in again to refresh your account details.


Have the same issue in my Samy TV, I tried what you asked about and it worked for me but I downgraded the server and the TV still not work the movie library, TV shows work fine


Try to add a new test/temp library and add some movies to it, to see if it is a problem with the library itself.


How can it be a problem with the library, if other people can watch everything in al my libraries.
He had samsung support, and they looked remotely into his tv with support view, but they couldn’t bring a solution either.

Any further suggestions?

regards Berry


@orca, for me it is solved. I created a new TEMP library, moved some titles to it and it worked. Came back to the MOVIES library and it started to work… Next step, upgraded to the latest version and all running smooth… Really dont know what happened!!! Any clue ?


The problem you had occurs when the file location in the database is no longer matching the actual file location.
This can be caused by things like renaming folders, files or network connections after you already created the library.
Renaming files can be fixed with running the library update, but changing network paths need manual changes to the library.
Sometimes, showing the database where to look will fix things.