"Unable to connect to this server securely"

server-linux

#1

Hello,

I've been working on this problem for a few days now, trying to get my plex server working correctly. I have setup a reverse proxy using nginx for plex, as well as a SSL setup for my domain as a whole including plex. Whenever I try to connect to my server using https://mydowmain.net/web Plex loads the page, but then says it cannot connect to my server securely so nothing works. Navigating to https://mydomain:33400 (which is the port I use) gives me a bad cert error, saying it is only for some plex.direct URL. I haven't been able to find a solution for this after a couple days of searching and trying different things so any help would be appreciated. I am using Ubuntu 16.04, Plex Version 1.13.0.5023 , and nginx 1.10.3. I can provide more info if needed, just ask.

Thanks for any help!


#2

My Tip: don’t try to setup a reverse proxy for plex. Just access your server via plex.tv in the browser, like anybody else, and everything will be fine. I do not see any benefit in using the proxy and it’s also not really supported and even if you have a working setup it could break any time.

And if privacy is your concern: it does not matter if you access your server “directly” or via plex.tv. The data transmitted to plex.tv is the same.


#3

I use a reverse proxy because I use a project called Organizr to condense all my services into a single webpage that I can access outside my network. I was finally able to get this working last night by adding a custom cert and custom access URL to the settings under Network on my server. Only issue now is that I am unable to access plex from my work network as they block non-standard ports. Meaning both my domain and plex.tv don’t work. Any help with that would be nice, but not really critical.

Also, I forgot to mention it in my OP, but plex.tv was giving the same error as my domain

Thanks


#4

I’m using Swizzin for the same organizational purpose and would love to get this worked out as well.

I’ve tried linking the certificate details to the .pem files as well as the .cer/.key files, but neither seems to work with Plex that way.

@KoopaTroopas - I’ll report back here, should I find a solution.