Unable to display subtitles (.srt) on movie

roku

#1

I have a movie with a .srt file of the same name in the same folder that I am attempting to play on Plex with my Roku Stick 3600R.

I have gone into the menu and selected "Unknown (srt)" under the Streams menu. I have tried closing out of Plex and resuming the movie, but the subtitles do not kick in. I have also confirmed there are subtitles in the .srt file that should be on-screen during the portion of the movie I was watching.

Is there anything more that I need to do in order to display subtitles in a movie on a Roku?

Thank you for any and all assistance!


#2

I am having the same issue on Roku TV and Roku 3. This is on Plex Cloud, with external SRT subtitles. They are confirmed to work on web app in Chrome and Chromecast. I have already checked that global captions settings are on, on Roku. Embedded SRT subtitles work fine on Roku. Not sure what's going on, but seems like a bug. Also not sure where to report bugs like this


#3

I can confirm that this issue is persistent on Roku devices. I followed instructions from a post on Reddit and installed the Sub Zero Subtitles channel. While I now have a subtitle option for all movies, they only display when I am viewing a movie on an iDevice or Android. I have not been able to get the subtitles to appear on the Roku Stick 3600R or the Roku 3 in my house.


#4

Turn on sub titles globally (Roku Home) - or play item, hit *, arrow left to first icon, press * turn on Subs.

Roku changed the sub-title game a while ago - for some reason. Once you turn those on they'll be on for everything on Roku unless you turn them back off. PITA? Yes. Work-Around? None.


#5

@JuiceWSA said:
Turn on sub titles globally (Roku Home) - or play item, hit *, arrow left to first icon, press * turn on Subs.

Roku changed the sub-title game a while ago - for some reason. Once you turn those on they'll be on for everything on Roku unless you turn them back off. PITA? Yes. Work-Around? None.

What a dumb way to hide a fairly important menu item... Thank you. That solved it.