Unable to play videos on AppleTV and iOS apps (error: "Something went wrong playing your media.")

apple-tv

#1

Hi Plex forums. I'm having problems playing videos through both the AppleTV and iOS apps. When I start a video, it takes ~10 seconds of loading and then displays an error "Something went wrong playing your media. Please try again".

This only occurs for most files, but not all. I was able to play these very same files without problems about 2 or 3 days ago. They have just started failing now.

I have tried restarting everything (AppleTV, iOS, Plex server, Network drive), but nothing helps.

I am able to play the exact same files through the Plex web interface. So I don't think it's an issue with the files or Plex server. I think it must be just the AppleTV and iOS apps. I noticed that the Plex AppleTV app was updated on Apr 5. Has there perhaps been a change that might have caused this?

Has anyone else had a similar problem? Any ideas what to do to fix this?


#2

What version of Plex media server do you have installed? What are the hardware specs of the Plex media server computer?

How are your video files included ? (Not file type, like MKV, but video encoding type: such as h264 or h265)


#3

Thanks for your help darcilicious.

My plex media server is version 1.12.1.4885

My media computer is pretty old. A MacBook from 2011 with 2.7 Ghz i7 processor, 8GB RAM. But it was working without any problems a few days ago and has been working for ~2 years. Restarting this doesn’t seem to help.

The codecs (as shown in VLC) are…

Working examples:
• H264 - MPEG-4 AVC
• H264 - MPEG-4 AVC
• H264 - MPEG-4 AVC
• H264 - MPEG-4 AVC

Failing examples:

• H264 - MPEG-4 AVC
• H264 - MPEG-4 AVC
• MPEG-4 Video (DIVX)

So not really a pattern?


#4

I have the same issue


#5

I’m not sure if I’m going through the same thing.
My Win10 server has worked just fine, but starting a few weeks ago, it’s been taking longer and longer to buffer series or movies.
Once they video loads, it works perfectly, but not it’s taking more than 30 seconds.
Sometimes it even crashes the server. I reload the PMS and most often than not, the second try works.
Tonight, after several tries, I’m still unable to play a video.

The curious thing is, the long buffer time and crashes only seem to take place when I’m streaming from my Win10 server to my Apple TV all on my local network.
Tablets and phones are streaming just fine, both on LAN of streaming over the internet.

Any idea what log I could check to see what is causing the crashes?

PS; I updated the server tonight to v1.12.3.4973

thanks,


#6

I’m having the same problem with iOS only. I can use my iPad and cast to chromecast or watch on Xbox or android but not directly on my iPhone or iPad. None of my movies will play , even ones I’ve watched in my iPad in the past so I know it’s not a video file issue.
What has changed? Thinking the latest update has done something