Unable to Play Watch Later YouTube videos on Plex Web

plex-web

#1

There is an issue with Plex Web for Chrome playing YouTube Watch Later videos. They just sit there loading forever.

There was an issue with PMS for Windows v1.5.2 being unable to transcode YouTube videos, but that issue has been resolved in PMS for Windows v1.5.6 and later. I know this issues is resolved because the Plex app for Roku must trancode some YouTube Watch Later videos and they play and transcode fine on the Plex app for Roku using PMS for Windows v1.5.6 or later.

The same YouTube Watch Later videos will direct play on the iOS app and transcode on the Roku app. But I have tried playing these YouTube videos in Plex Web v3.2.1, v3.4.1, and v3.6 in Chrome and they just sit there loading forever.

I even tried disabling Direct Play under Settings > Plex Web > Player, but they still will not play.


#2

~~I have also tried the latest version of the Plex Web app (v3.6) on Firefox and Safari from another device (including disabling direct play) and YouTube Watch Later video playback fails on those browsers as well.~~

EDIT:

I have also tried the latest version of the Plex Web app (v3.6) on browsers from Ipad (Safari and Firefox) and YouTube Watch Later video playback fails as well. But Firefox on Windows 10 can play YouTube Watch Later videos.


#3

It appears there is an issue with the Plex Web app sending the POST request necessary to get the video stream. This same request works fine on the Plex app for Roku and iOS.


#4

Just as a side note, it is working in Microsoft Edge on Windows 10


#5

This does appear to be an issue affecting the Chrome and Safari browsers. Firefox works as well (except on Ipad).


#6

Still not working in chrome or edge(for me). This has been a problem for about 2 months. :'(


#7

Still not working in Chrome (Works fine in M$ Edge)

PlexWeb: Version 3.6.0
Plex Media Server: Version 1.7.0.3840
Chrome: Version 58.0.3029.110 (64-bit)


#8

@shopgirl284 said:
There is an issue with Plex Web for Chrome playing YouTube Watch Later videos. They just sit there loading forever.

There was an issue with PMS for Windows v1.5.2 being unable to transcode YouTube videos, but that issue has been resolved in PMS for Windows v1.5.6 and later. I know this issues is resolved because the Plex app for Roku must trancode some YouTube Watch Later videos and they play and transcode fine on the Plex app for Roku using PMS for Windows v1.5.6 or later.

The same YouTube Watch Later videos will direct play on the iOS app and transcode on the Roku app. But I have tried playing these YouTube videos in Plex Web v3.2.1, v3.4.1, and v3.6 in Chrome and they just sit there loading forever.

I even tried disabling Direct Play under Settings > Plex Web > Player, but they still will not play.

I am getting the same issue with Watch later not working in Chrome. I have tried IE and that works but not Chrome. So far I have tested the following:

  • Chrome (Doesn't work)
  • Internet Explorer (Works)
  • Plex Windows App (Works)
  • Android (Works)
  • iOS (Works)

Not sure where the issue is with Chrome but it is for sure the browser that won't play the videos in the Watch Later playlist.

Question

Does anyone know if there is a way to send an email to Plex and have their development team take a look at the issue? I know it is a small thing but it would be nice to have this working.


#9

We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.


#10

@chrishoage said:
We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.

Thank you!


#11

As per https://forums.plex.tv/discussion/comment/1448504#Comment_1448504

Upgraded to
PMS Version 1.7.2.3878
Still not working


#12

Same here with the latest version of Chrome on a Chromebook - playing videos from Youtube via Watch Later just sit with a spinning circle like it's trying to buffer them.


#13

I posted a thorough investigation the issue here:
https://forums.plex.tv/discussion/280030/cant-play-youtube-videos-from-watch-later-in-plex-web-app-in-google-chrome

The problem is the Accept-Encoding HTTP header that Chrome sends to PMS, when it requests the HTML required to play a YouTube video.
The fix should be simple from there, for a Plex developer.

For end-users who can’t wait for Plex to fix this issue, you can install a Chrome extension that allows you to modify the HTTP headers sent to servers, and force the Accept-Encoding header to always send the value gzip, deflate

I tested with the Requestly extension, and the following settings:

You can import this rule in Requestly by visiting this URL after installing Requestly. Use the Import List button in the top-right corner.

And I (and you!) can now play YouTube videos without problems in Chrome. Yay!


#14

@chrishoage said:
We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work.

As mentioned previously in this thread there is a POST request that is hanging which the Plex Media Server team needs to figure out why that is.

@chrishoage Would you mind updating the ticket you opened in the PMS repo with the information I posted in the above thread?


#15

@gboudreau I have attached that thread to the internal issue. Thanks!


#16

Thanks very much @gboudreau you are the greatest.


#17

@gboudreau, thank you so much for the Chrome fix!


#18

Thanks @gboudreau for fixing a deal breaker. I wonder why plex employees couldn't address this sooner? There were tons of complaints on it. Hopefully the update with the fix doesn't take till Christmas as I'm sure there many out there who don't know about the chrome extension workaround.


#19

It still doesn't work in firefox.


#20

@rckmnr said:
It still doesn't work in firefox.

The Brotli encoding, where the problem lies, is implemented in Firefox version 44+ (and Chrome version 49+). You can turn it off in Firefox and YouTube videos in the Watch Later queue will start working again.

Turn off Brotli encoding in Accept-Encoding header in Firefox

  1. Type about:config into the location bar of Firefox and press enter.
  2. Read the warning and click "I accept the risk!" if you feel comfortable.
  3. Type encoding in the search bar and look for the entry named network.http.accept-encoding.secure.
  4. Change the value of network.http.accept-encoding.secure to gzip, deflate (the default value is gzip, deflate, br).

Turn off Brotli encoding in Accept-Encoding header in Chrome

  1. Type chrome://flags into the location bar of Chrome and press enter.
  2. A long page with options will open. Look for Brotli Content-Encoding.
  3. Select Disabled from the dropdown menu.
  4. Press the "Relaunch Now "button at the bottom of the screen for the change to take effect.

.
Don't forget to change the values back once PMS has been fixed.