Unable to proceed with Plex Server setup after finishing setup on Shield



I don't know if this has been asked already but I just bought an NVIDIA Shield TV and ran through the setup procedures on the device. Yet, when I try to finish setting up on my computer the server setup prompt doesn't appear and the shield shows up as not being able to connect. I'm not sure what I'm doing wrong. I've tried having the server run on ethernet and wireless connections but nothing changes.


I forgot to mention but I also tried to access the webpage for the device but it fails to load every time I attempt to connect.


Hello and welcome to the forums.

I’m a bit confused by your issue. If you went through the setup on the Shield, what are you trying to do on your computer? Are you able to access the server from the Plex client on the Shield itself. If this is the first time you are using Plex Media Server on the Shield, did you update the app first? The original version of PMS that comes pre-built on the Shield is an old version and might cause issues. Make sure to update to the newest version.


I setup the Shield device to act as a Plex Media Server, and then I read I need to go onto the webpage to add directories from my Shield for Movies, TV, etc. Yet, when I go to the Plex webpage my Shield device only shows up as ‘Unavailable’, preventing me from going further into setting up my server.

I have of Plex and of the Plex Media Server. I don’t know how to update apps on the Shield and I don’t think I saw any update prompts for the app.


Go to Google play store on a web browser, find Plex Media server, then you
should be able to install to your Shield. You’ll only have to do this once,
updates should happen automatically afterwards.


Ok, I updated both Plex and Plex Media Server and my device still isn’t recognized. I’m not sure what I’m missing to get it to appear as available.


I have the same problem for 6-8 months now and gave up in frustration trying to intall Plex Media Server on my Shield 2017. All my Plex Apps are up to date. Yet the Shield Device shows “unavailable” like you from my PC. Plex on my Computer works perfectly.
I now watch all my videos through Kodi.


I’m hoping I don’t have to resort to that. It’s annoying I can’t get this setup when I’m doing everything correctly.


Please provide the log from the PMS on the Shield. Not the client, the server.

Since you can’t get to Web to see the server, you will need to do it manually. Turn on the option in the Shield’s network settings to enable accessing the Shield from a computer. https://support.plex.tv/hc/en-us/articles/220347688 Then browse to /sdcard/Plex Media Server/Logs on the Shield and zip up all the files and send it to me.


I setup my Shield for local network access on wifi since ethernet wasn’t recognizing for some reason, yet I’m still unable to connect. I had PMS running and stopped when trying to access it. I double checked if I entered “smb://ipaddress” and when I attempted to connect on my Mac I received this message:

The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.


I got your logs. It shows that when you are connected via ethernet, your Shield is using it’s public IP address and not a local IP address. That isn’t right. Can you explain your network setup.


I have my Shield device plugged into an Ethernet switch, with the switch being plugged in via Ethernet connection from a wall port.


Ok, then it IS using your public IP. How do you have WiFi setup? Something isn’t correct in your network.


My WiFi setup is not fully known to me since my apartment complex provides the WiFi service (Pavlov Media). Not sure if it’s relevant, but I had to register the MAC address of the device separately when running it on either WiFi or Ethernet.


Ok. That’s the problem. Your WiFi and ethernet are not on the same network so your clients are not going to see your server this way. Your best option is to go buy a Router (with WiFi). Connect your server to the router and your clients to this WiFi (not your apartment WiFi).

A temporary fix, not sure if it will work, is to connect your Shield to the apartment WiFi as well. Hopefully the WiFi is set in a way that your clients can now see your server.


Weird. I tried running it on my apartment WiFi and my client didn’t recognize the server. I’ll have to see if I can configure my apartment’s WiFi in any way to get my device to recognize properly. I was hoping not to have to buy a router but that’ll be a last resort.

Thanks for taking the time to help me out, I appreciate it.


It’s possible that since the WiFi is being used by the entire building, each connection is a separate dedicated connection so you don’t see what your neighbors are using. This is the same way airports and coffee shops setup their WiFi. Getting a router might be your only option.