# Unable to run Plex binaries or DBUpdate on command line

**URL:** <https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666>\
**Category:** Plex Media Server\
**Tags:** server-qnap\
**Created:** [December 2, 2024, 2:20pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666 "2024-12-02T14:20:16Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![ChrisQew](https://avatars.discourse-cdn.com/v4/letter/c/c89c15/32.png) [@ChrisQew](https://forums.plex.tv/u/ChrisQew)\
**Post date:** [December 2, 2024, 2:20pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/1 "2024-12-02T14:20:16Z")

</div>

Plex Server Version#: Version 4.140.0  
Player Version Not Applicable  
QNAP Server Version#: QuTS Hero h5.2.2.2952 (Running on TS-873A)  
Nvidia Quadro P2000 running in QTS Mode (works fine for transcodes)

When I try to run any of the Plex binaries (without the .sh script, or outside of the App Center) the apps fail to launch with the following error, including any binaries called by the most recent instance DBRepair.sh script, that itself appears to call these same binaries.

/share/ZFS530\_DATA/.qpkg/PlexMediaServer/Plex\ SQLite --help  
Error relocating /share/ZFS530\_DATA/.qpkg/PlexMediaServer/Plex Media Server: drmGetDevices2: symbol not found

This worked previous to the last QNAP security update. I updated the NVidia drivers post QNAP upgrade, and reinstalled the .qpkg of Plex as well.

It should be noted that the app starts fine via App Center, just not via the plex.sh start script (same error)… Stopping via the .sh script works reliably, just not starting.

Thank you for any insight you may be able to provide.

---

<div class="post-metadata">

**Author:** ![ChrisQew](https://avatars.discourse-cdn.com/v4/letter/c/c89c15/32.png) [@ChrisQew](https://forums.plex.tv/u/ChrisQew)\
**Post date:** [December 9, 2024, 5:50pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/2 "2024-12-09T17:50:09Z")

</div>

I’ve continued looking into this and it appears that a shared library link either being incorrect or missing is probably the issue based on what I read here (albeit for docker issue): [Error on start - plexmediaserver (1.29.1.6260-420892357) - drmGetDevices2 - #43 by jesplex](https://forums.plex.tv/t/error-on-start-plexmediaserver-1-29-1-6260-420892357-drmgetdevices2/812910/43)

The logs of my attempt to stop, repair, start here:

> **[\[~\] # /share/ZFS530\_DATA/.qpkg/PlexMediaServer/plex.sh stopStopping Plex Media...](https://pastebin.com/X8xKVHEZ)**
>
> Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.

Starting plex via appcenter works reliably, and is the only method I can use to start it so perhaps some differences in the shell environment between logging in as qnap admin vs appcenter are to blame…

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [December 9, 2024, 8:11pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/3 "2024-12-09T20:11:46Z")

</div>

For command line start/stop, try `/etc/init.d/plex.sh start` or stop or restart

Regarding the DB tool, I’ll leave that to the experts 😉

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [December 9, 2024, 9:17pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/4 "2024-12-09T21:17:41Z")

</div>

> [@ChrisQew](#):
>
> This worked previous to the last QNAP security update.

can you provide some information about this please ?

I don’t use Hero on a daily basis.

---

<div class="post-metadata">

**Author:** ![ChrisQew](https://avatars.discourse-cdn.com/v4/letter/c/c89c15/32.png) [@ChrisQew](https://forums.plex.tv/u/ChrisQew)\
**Post date:** [December 10, 2024, 2:56pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/5 "2024-12-10T14:56:22Z")

</div>

There was a v5.2.2.2952 security upgrade: [QuTS hero h5.2.2.2952 build 20241116 | Release Notes | QNAP (US)](https://www.qnap.com/en-us/release-notes/quts_hero/h5.2.2.2952/20241116?ref=nas_product)

I installed the QuTS upgrade November 16th and following that I installed the NVidia driver update for my Quadro P2000, NVidia driver version v5.2.0.0621 on November 22, NvKernelDriver v5.2.2.2952 as part of the new qnap/linux kernel, also on November 22.

After that, I’ve been unable to start/stop or use DBrepair.sh (which calls the same binaries in the same environment as the SSH shell I guess) since.

@dane22: Command output follows, only seems to start via Appcenter, not via SSH

# /share/ZFS530\_DATA/.qpkg/PlexMediaServer/plex.sh stop

Stopping Plex Media Server…  
[/] # /share/ZFS530\_DATA/.qpkg/PlexMediaServer/plex.sh start  
Starting Plex Media Server…  
Error relocating /share/ZFS530\_DATA/.qpkg/PlexMediaServer/Plex Media Server:  
drmGetDevices2: symbol not found  
[/] #

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [December 10, 2024, 3:00pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/6 "2024-12-10T15:00:01Z")

</div>

And you tried the `plex.sh` from `/etc/init.d` ?

---

<div class="post-metadata">

**Author:** ![ChrisQew](https://avatars.discourse-cdn.com/v4/letter/c/c89c15/32.png) [@ChrisQew](https://forums.plex.tv/u/ChrisQew)\
**Post date:** [December 10, 2024, 3:35pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/7 "2024-12-10T15:35:46Z")

</div>

so sorry, I misread that. Yes, same result:

[/] # /etc/init.d/plex.sh start  
Starting Plex Media Server…  
[/] # Error relocating /share/ZFS530\_DATA/.qpkg/PlexMediaServer/Plex Media Server: drmGetDevices2: symbol not found  
[/] #

It seems like maybe a conflict between the libdrm shared objects?  
Since it’s able to load via appcenter, maybe it’s started with a different #LD\_LIBRARY\_PATH?

> [/] # ls -l /share/ZFS530\_DATA/.qpkg/PlexMediaServer/lib/libdrm.so.2  
> -rwxr-xr-x 1 admin 1001 84640 2024-11-13 13:11 /share/ZFS530\_DATA/.qpkg/PlexMediaServer/lib/libdrm.so.2\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/lib/libdrm.so  
> lrwxrwxrwx 1 admin administrators 15 2024-11-23 22:20 /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/lib/libdrm.so → libdrm.so.2.4.0\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/PlexMediaServer/lib/libdrm.so.2  
> -rwxr-xr-x 1 chris 1001 84640 2024-11-13 13:11 /share/ZFS530\_DATA/.qpkg/PlexMediaServer/lib/libdrm.so.2\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/lib/libdrm.so.2.4.0  
> -rwxrwxrwx 1 admin administrators 64176 2024-06-20 22:54 /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/lib/libdrm.so.2.4.0\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so  
> lrwxrwxrwx 1 admin administrators 15 2024-11-23 22:20 /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so → libdrm.so.2.4.0\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so.2  
> lrwxrwxrwx 1 admin administrators 15 2024-11-23 22:20 /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so.2 → libdrm.so.2.4.0\*  
> [/] # ls -l /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so.2.4.0  
> -rwxrwxrwx 1 admin administrators 64176 2024-06-20 22:54 /share/ZFS530\_DATA/.qpkg/NVIDIA\_GPU\_DRV/usr/nvidia/libdrm.so.2.4.0\*  
> [/] # echo $LD\_LIBRARY\_PATH  
> :/usr/local/cuda/lib64:/opt/NVIDIA\_GPU\_DRV/usr/syslib:/opt/NVIDIA\_GPU\_DRV/usr/lib:/opt/NVIDIA\_GPU\_DRV/usr/applib  
> [/] # whoami  
> admin

Edit: yeah, seems like this is enough to fix it for now:

> [/] # echo $LD\_LIBRARY\_PATH  
> :/usr/local/cuda/lib64:/opt/NVIDIA\_GPU\_DRV/usr/syslib:/opt/NVIDIA\_GPU\_DRV/usr/lib:/opt/NVIDIA\_GPU\_DRV/usr/applib  
> [/] # LD\_LIBRARY\_PATH=“:/share/ZFS530\_DATA/.qpkg/PlexMediaServer/lib:/usr/local/cuda/lib64:/opt/NVIDIA\_GPU\_DRV/usr/syslib:/opt/NVIDIA\_GPU\_DRV/usr/lib:/opt/NVIDIA\_GPU\_DRV/usr/applib”  
> [/] # /etc/init.d/plex.sh start  
> Starting Plex Media Server…

No error

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [March 10, 2025, 3:36pm UTC](https://forums.plex.tv/t/unable-to-run-plex-binaries-or-dbupdate-on-command-line/897666/8 "2025-03-10T15:36:27Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
